Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

  • Este tópico foi criado há 1348 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Moderadores
19 minutos atrás, sergiomicro disse:

Boa Tarde!

estou com problemas ao tentar enviar carta de correcao , da o erro 403 sendo que

eu consigo eu envio e consulto a nota sem problemas.o certificado e A3.

 

se tiverem alguma sugestão eu agradeco.

 

obrigado

Paulo Sergio

 

Boa tarde, sergiomicro.

Estranho... Esse erro pode ser acontecer, quando o tempo de requisição de acesso a SEFAZ passou do seu limite ou  o seu certificado está vencido. Anexe o XML para realizar uma verificação.

Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Link to comment
Share on other sites

Felipe, Bom dia!

o estranho é que eu estou emitindo nfe normal so da esse erro quando envio carta de correção , baixei o

acbrdemo e a carta de correção foi emitida normalmente ,mas quando mando pelo meu aplicativo da esse erro

já verifiquei as configurações de  ssl e estão identicas . alguma dica?

 

Obrigado

Paulo Sergio

Link to comment
Share on other sites

  • Moderadores
35 minutos atrás, sergiomicro disse:

Felipe, Bom dia!

o estranho é que eu estou emitindo nfe normal so da esse erro quando envio carta de correção , baixei o

acbrdemo e a carta de correção foi emitida normalmente ,mas quando mando pelo meu aplicativo da esse erro

já verifiquei as configurações de  ssl e estão identicas . alguma dica?

 

Obrigado

Paulo Sergio

Bom dia, sergiomicro.

Se no demoACBr está funcionando, acredito que é algo na sua aplicação. Tente atualizar os fontes e debugar.

Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Link to comment
Share on other sites

  • Consultores

Boa tarde Sergio,

Você tem uma rotina de configuração do componente para cada ação?

Pois se o enviar esta funcionando e o envio de evento, no caso a carta de correção não, pode ser que na rotina de configuração executada antes do envio do evento você esteja configurando o componente de forma errada, por exemplo a versão. 

Verifique o valor da propriedade de configuração: VersaoDF

  • Like 1
Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Consultores

Bom dia Sergio,

Você tem apenas uma rotina que configura o componente, e esta é chamada toda vez que uma ação é realizada?

Por exemplo, no form de emissão a rotina de configuração é executada, no form de carta de correção a mesma rotina de configuração é executada.

Ou essa rotina é executada uma única vez?

Se ela é executada uma única vez, em que momento ela é executada?

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Consultores

Bom dia Sergio,

É muito estranho, se o envio e a consulta funciona sem nenhum problema com o certificado A3 no seu cliente, deveria funcionar no envio de eventos.

Faça um teste com o evento de cancelamento.

  • Like 1
Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Consultores

Sergio,

Pelo programa exemplo funciona tanto com certificado A1 quanto A3?

Você não esta carregando na sua aplicação o arquivo ACBrNFeServicos.ini desatualizado?

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

Italo! só me tira uma duvida na minha aplicação a propriedade do acbrnfe.iniservicos está vazia, se eu pegar

o acbrnfeservicos.ini que esta no diretorio do acbrdemo e copiar para pasta da minha aplicação já vai buscar

o acbrnfeservicos.ini certo ou tenho que fazer mais alguma coisa.

 

Obrigado

Paulo Sergio

Link to comment
Share on other sites

  • Consultores

Sergio,

Se a propriedade Configuracoes.Arquivos.IniServicos esta vazia na sua aplicação, isso significa que ela não utiliza o arquivo ACBrNFeServicos.ini e sim o ACBrNFeServicos.res que é carregado e compilado.

Portanto faz parte do seu executável.

A principio o programa exemplo funciona da mesma forma, ou seja, a propriedade de configuração também deve estar vazia.

Se no programa exemplo e na sua aplicação a propriedade IniServicos esta vazia, mas no programa exemplo funciona e a sua aplicação não, chego a conclusão que algo esta errado na sua aplicação.

  • Like 1
Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Consultores

Bom dia Sergio,

Com a sua aplicação você consegue enviar os eventos de cancelamento e carta de correção em ambiente de homologação com os certificados A1 e A3?

O problema ocorre quando os eventos são enviados para o ambiente de produção?

E com o programa exemplo ocorre a mesma situação?

Precisamos eliminar as variáveis (Certificado, Ambiente, Aplicação).

 

  • Like 1
Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

Boa Tarde!

Com a sua aplicação você consegue enviar os eventos de cancelamento e carta de correção em ambiente de homologação com os certificados A1 e A3?

  enviei para homologação com certificado A1. com A3 so na area de produção .

O problema ocorre quando os eventos são enviados para o ambiente de produção?

    não enviei para area de produção com certificado A1. com o certificado A3 ocoore o erro no evento de cancelamento.

E com o programa exemplo ocorre a mesma situação?

  com o programa exemplo eu nem testei com certificado A1 , nem na homologação. testei direto com certificado A3 na

 produção e deu certo.

 

obs:  estou tentando junto ao cliente pegar o certificado A3 dele para fazer teste na minha maquina. acho que vai ser o unico jeito de descobrir.

 

Obrigado

Paulo Sergio.

  • Like 1
Link to comment
Share on other sites

  • Administradores

Tópico fechado por falta de retorno do usuário

Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

  • Este tópico foi criado há 1348 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.