Ir para conteúdo
  • Cadastre-se

ÚLTIMOS DIAS!

Delphi com até 25% de desconto
Ganhe Acesso ao SAC ACBr Brindes exclusivos do ACBr
Saiba mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Luciana Cristina Pereira

SPED-EFD-Reinf Registro R-2099, Em Processamento

Recommended Posts

Boa tarde Luciana,

Você já alterou seu sistema para utilizar a nova consulta?

O webservice utilizado pelo consultarProtocolo está demorando mesmo para retornar. Aqui esta levando em média 30 minutos.

Foi implementado a nova consulta. Estou alterando minha rotina para utilizá-la. Qualquer coisa posto aqui.

Att,

Rubens

Compartilhar este post


Link para o post
Compartilhar em outros sites
12 minutos atrás, jrubensmartins disse:

Boa tarde Luciana,

Você já alterou seu sistema para utilizar a nova consulta?

O webservice utilizado pelo consultarProtocolo está demorando mesmo para retornar. Aqui esta levando em média 30 minutos.

Foi implementado a nova consulta. Estou alterando minha rotina para utilizá-la. Qualquer coisa posto aqui.

Att,

Rubens

Rubens, boa tarde!

Eu estou consultando pelo demo e mesmo assim esta em processamento, eu acabei de atualizar o ACBR gerei um demo e fiz por ele para verificar.

O problema meu ainda é pior, foi enviado todos os arquivos de uma vez, passou o 1000 e o 2010 deu erro, o 2099 foi e ficou em processamento, agora tenho que esperar para enviar o 2010 novamente e desde sexta não consigo o retorno do erro para fazer o envio novamente.

Luciana

Editado por Luciana Cristina Pereira

Compartilhar este post


Link para o post
Compartilhar em outros sites

Você chegou a conferir no xml de retorno da consulta se está realmente em processamento?

Tive alguns casos que o envio foi rejeitado e por erro meu, no tratamento do retorno, não apresentava a mensagem de erro. E continuava em processamento.

Eu estou conseguindo o recibo de entrega, mas está demorando um pouco mesmo.

Seria interessante vc ajustar o seu processo para enviar o R-2099 somente quando os demais estiverem ok.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Luciana Cristina Pereira também está acontecendo com um determinado cliente.

Enviamos o fechamento de 5 empresas na sexta-feira, destas 2 estão com status aguardando retorno até hoje. Fiz alguns testes para verificar se foi realmente efetivado o fechamento, para tal, verifiquei se as retenções constavam na DCTFWeb e não havia nada. Depois forcei o envio do evento de reabertura R-2098, e a mensagem de retorno dizia que estava em processo de fechamento ou sem evento de fechamento. A última cartada foi enviar outro R-2099 e o retorno foi que há um evento em processamento.

Desta forma, concluí que realmente é uma lentidão no servidor. Se até amanhã continuar, vou repetir esses procedimentos e entrar em contato com a receita.

Compartilhar este post


Link para o post
Compartilhar em outros sites
37 minutos atrás, jrubensmartins disse:

Você chegou a conferir no xml de retorno da consulta se está realmente em processamento?

Tive alguns casos que o envio foi rejeitado e por erro meu, no tratamento do retorno, não apresentava a mensagem de erro. E continuava em processamento.

Eu estou conseguindo o recibo de entrega, mas está demorando um pouco mesmo.

Seria interessante vc ajustar o seu processo para enviar o R-2099 somente quando os demais estiverem ok.

Acabei de receber o retorno do 2099, com o erro já previsto devido ao problema que tive no registro 2010, agora consegui enviar com sucesso o 2010 e o 2099 enviei novamente e retorno na luta de ficar consultando.

Acho que o processamento do 2099 não poderia demorar precisava ser imediato, já imaginou no ultimo dia acontecer de demorar de um dia para o outro ou 3 dias como foi no meu caso?

Vou ajustar o processo e travar o 2099 somente quando os demais estiverem com numero de recebido.

Luciana

34 minutos atrás, arce disse:

@Luciana Cristina Pereira também está acontecendo com um determinado cliente.

Enviamos o fechamento de 5 empresas na sexta-feira, destas 2 estão com status aguardando retorno até hoje. Fiz alguns testes para verificar se foi realmente efetivado o fechamento, para tal, verifiquei se as retenções constavam na DCTFWeb e não havia nada. Depois forcei o envio do evento de reabertura R-2098, e a mensagem de retorno dizia que estava em processo de fechamento ou sem evento de fechamento. A última cartada foi enviar outro R-2099 e o retorno foi que há um evento em processamento.

Desta forma, concluí que realmente é uma lentidão no servidor. Se até amanhã continuar, vou repetir esses procedimentos e entrar em contato com a receita.

Eu enviei diversos e-mail para RFB e até agora sem resposta.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Peguei um caso aqui onde ele está em processamento, porém no eCAC fala que foi rejeitado. Fizemos várias consultas e não retorna o erro de rejeitado, somente em processamento. Vamos ter que ter um pouco de paciência até eles (SERPRO) ajustarem tudo.

Só precisamos tomar cuidado, pois pelo eCAC eles conseguem fazer o fechamento. Não sei se vocês previram isso, pois o sistema pode ficar diferente do Oficial.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
3 horas atrás, Luis Lambranho disse:

Boa tarde a todos.

 

Estamos com o mesmo problema em nossos clientes. Alguém já conseguiu retorno como transmitido no fechamento nesses últimos dias?

Luiz, o retorno do XML quando consulto esta com erro MS0010 - Nenhuma informação encontrada para os parâmetros informados.
Porem ao entrar no eCac a Reinf está ok e fechada.

Luciana

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Estou transmitindo o R2099 em produção restrita e ainda não consegui um retorno da consulta diferente de "EM PROCESSAMENTO".  Esse problema está acontecendo em produção também?

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 11/02/2019 at 14:30, jrubensmartins disse:

Boa tarde Luciana,

Você já alterou seu sistema para utilizar a nova consulta?

O webservice utilizado pelo consultarProtocolo está demorando mesmo para retornar. Aqui esta levando em média 30 minutos.

Foi implementado a nova consulta. Estou alterando minha rotina para utilizá-la. Qualquer coisa posto aqui.

Att,

Rubens

Rubens, bom dia!

Veja se pode me ajudar.

Esse mês estou com o mesmo problema, meu clientes não conseguem o retorno de "Sucesso" no fechamento do REINF.

Só retorna "Em Processamento" 

Quando vc fala aqui pra utilizar a nova consulta, de qual vc está falando?

Eu estou utilizando a "ConsultaReciboEvento", tem alguma outra?

Grata se puder me ajudar

 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 12/02/2019 at 20:44, Luciana Cristina Pereira disse:

Luiz, o retorno do XML quando consulto esta com erro MS0010 - Nenhuma informação encontrada para os parâmetros informados.
Porem ao entrar no eCac a Reinf está ok e fechada.

Luciana

Luciana, bom dia!

Mês passado, não tive nenhum problema

Todos os meus clientes entregaram o REINF e obtiveram o retorno "Sucesso" do fechamento rapidamente

Esse mês. Todos os meus clientes estão com o registro de Fechamento  R2099 "Em Processamento", refaço a consulta e só retorna "Em processamento!

Já abri diversos chamados na Receita Federal, e não tive retorno de nenhum até o momento

O prazo de entrega termina hoje. Não sei o que fazer!

Você resolveu o problema mês passado? E esse mês conseguiu transmitir sem problemas?

Grata se puder me ajudar

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia, pessoal.

 

Percebi nos últimos meses que sempre que está chegando próximo do dia 15 ocorrem essas situações. Não chega a ser um problema, pois é uma situação prevista na documentação (afinal é um evento assíncrono), mas o cliente sempre fica apreensivo.

 

Ontem tivemos um caso desses e no fim do dia a cliente conseguiu obter o status de transmitido com sucesso.

Enquanto eles não estabilizarem eu creio que o que nos resta é orientar e acalmar o cliente.

Dos nossos clientes aqui nenhum ficou sem entregar dentro do prazo por essa situação até agora.

Compartilhar este post


Link para o post
Compartilhar em outros sites
3 minutos atrás, Luis Lambranho disse:

Bom dia, pessoal.

 

Percebi nos últimos meses que sempre que está chegando próximo do dia 15 ocorrem essas situações. Não chega a ser um problema, pois é uma situação prevista na documentação (afinal é um evento assíncrono), mas o cliente sempre fica apreensivo.

 

Ontem tivemos um caso desses e no fim do dia a cliente conseguiu obter o status de transmitido com sucesso.

Enquanto eles não estabilizarem eu creio que o que nos resta é orientar e acalmar o cliente.

Dos nossos clientes aqui nenhum ficou sem entregar dentro do prazo por essa situação até agora.

Bom dia Luis!

O estranho é que tenho cliente que transmitiu segunda-feira, dia 11 e até agora não teve o retorno de sucesso.

Estranho ficar um registro tanto tempo assim aguardando processamento, não é?

Por isso minha preocupação.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 minuto atrás, Fabiana Gentil disse:

Bom dia Luis!

O estranho é que tenho cliente que transmitiu segunda-feira, dia 11 e até agora não teve o retorno de sucesso.

Estranho ficar um registro tanto tempo assim aguardando processamento, não é?

Por isso minha preocupação.

 

Concordo, realmente é preocupante.

 

Eu oriento nossos clientes aqui a consultarem de 30 em 30 minutos a situação. Ontem esse problema ocorreu por volta de 14hs e a cliente só conseguiu o sucesso quase lá pelas 18hs.

Compartilhar este post


Link para o post
Compartilhar em outros sites
49 minutos atrás, Luis Lambranho disse:

Concordo, realmente é preocupante.

 

Eu oriento nossos clientes aqui a consultarem de 30 em 30 minutos a situação. Ontem esse problema ocorreu por volta de 14hs e a cliente só conseguiu o sucesso quase lá pelas 18hs.

Olha essa situação!

Agora pouco meu cliente entrou no site eCAC e a Situação da EFD-REINF competência 02/2019 aparece como "Fechada", porém no XML de retorno que o meu sistema obteve o status é "Em Processamento", desta forma o cliente tem o REINF "Fechado" lá na base da Receita Federal e "Em Processamento" dentro do ERP.

Espero realmente que eles consigam estabilizar este serviço.

Tá ficando complicado "explicar" para os clientes essa situação.

O que me deixa preocupada, é que não tenho resposta dos atendimentos abertos na Receita, e quando faço busca na net, não acho nada a respeito, parece que não tem mais ninguém com este problema?????

Isso me levou a questionar se o problema não seria meu sistema/ componente

Por via das dúvidas, fui agora fazer update do ACBr, vi que atualizou algumas correções de erro no REINF,  inclusive correções no ConsutarReciboEvento e outros , essas correções subiram no repositório dia 13/03. 

Atualizei e gerei uma nova versão do meu sistema e mesmo assim o problema persiste.

Sinceramente não sei mais o que fazer!

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 horas atrás, Fabiana Gentil disse:

Rubens, bom dia!

Veja se pode me ajudar.

Esse mês estou com o mesmo problema, meu clientes não conseguem o retorno de "Sucesso" no fechamento do REINF.

Só retorna "Em Processamento" 

Quando vc fala aqui pra utilizar a nova consulta, de qual vc está falando?

Eu estou utilizando a "ConsultaReciboEvento", tem alguma outra?

Grata se puder me ajudar

 

 

 

Bom dia,

O registro 2099 retorna sempre em processamento e na sequencia deve ser feito a consulta, esse mês tive problema em apenas um ciente os demais foram.
Fiz a atualização do ACBR, utilizamos o exemplo da consulta e também atualizamos os schemas e deu tudo certo esse mês com exceção este cliente que verifiquei no eCac e realmente estava em processamento que neste caso o retorno do ACBR está ok e o problema é lá.

Luciana

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

×
×
  • Criar Novo...