Jump to content

110.png

Curso Gratuito para todos Usuários
+ Super Treinamento Assinando o SAC Anual

botao_campanha_thulio.png

sem_ttulo-620.fw_-e1583866078274.png 

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

MaikonPanazzolo

ANSWERED URL QRCode CTe

Recommended Posts

1 hora atrás, Italo Jurisato Junior disse:

Não tem nenhum fonte cujo ícone esteja com uma bolinha vermelha?

Se você altera um fonte, o Tortoise as vezes não consegue realizar o merge, neste caso o fonte fica desatualizado.

Não é breakponit. Estou falando da variáveis que estão sendo carregada.

Não existe "URL-QRCODE_";

Olhe valores das variáveis;

O sistema não encontra a url do qrcode correto no INI.

 

erro.jpg

erro2.png

Edited by jcanjo
corrigindo erro de digitação

Share this post


Link to post
Share on other sites

Bom dia,

Me responda uma pergunta.

Porque os demais colegas do fórum estão conseguindo emitir o CT-e com o QR-Code?

  • Haha 1

Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites
2 horas atrás, Italo Jurisato Junior disse:

Bom dia,

Me responda uma pergunta.

Porque os demais colegas do fórum estão conseguindo emitir o CT-e com o QR-Code?

Vamos lá.

CT-e com QR-Code é gerado sim, mas não com caminho "http://dfe-portal.svrs.rs.gov.br/cte/QRCode".

Quando fazem a busca no arquivo INI a chave "URL-QRCode_" não existe, portanto ele pega da chave "URL-ConsultaCTe"

Eu acho que a URL no ACBrCTeServicos.ini digitado não está correto pela lógica de pesquisa.

Deveria ser "URL-QRCode_" ou "URL-QRCode_0.00" ?

Porque na pesquisa de registro ele não pega "URL-QRCode".

URL-QRCode=http://dfe-portal.svrs.rs.gov.br/cte/QRCode
URL-ConsultaCTe=https://dfe-portal.svrs.rs.gov.br/CTE/Consulta

@Italo Jurisato Junior quero agradecer pela atenção dada.

 

Share this post


Link to post
Share on other sites

gostaria de colocar uma interrogação...

qdo se lê o qrcode pelo celular, o retorno da url é http// 

faltando o : entre o p e //

não sei se isso se trata de erro do componente

Share this post


Link to post
Share on other sites

Bom dia Ricardo,

Você utiliza o ACBrCTe?

Se sim, a URL do QR-Code se encontra no arquivo ACBrCTeServicos.ini

Em uma breve checagem não detectei esse erro.

Pelo que entendi o componente esta removendo o ":" que esta entre o http e a "/".

Você poderia anexar o XML do CT-e que foi gerado com esse problema?


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites
1 hora atrás, Italo Jurisato Junior disse:

Bom dia Ricardo,

Você utiliza o ACBrCTe?

Se sim, a URL do QR-Code se encontra no arquivo ACBrCTeServicos.ini

Em uma breve checagem não detectei esse erro.

Pelo que entendi o componente esta removendo o ":" que esta entre o http e a "/".

Você poderia anexar o XML do CT-e que foi gerado com esse problema?

Prezado Italo, fiz outros testes e percebi que quando o leitor lê o qrCode, no meu aplicativo nativo do celular, tem o botão copiar. Quando você clica nele para copiar e joga na url do navegador, não sei porque motivos ele não interpreta o dois pontos 

Share this post


Link to post
Share on other sites

Boa tarde Ricardo,

Então o problema é no App que você esta utilizando e não na geração da string do QR-Code realizada pelo componente.

  • Like 1

Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

Boa tarde Sérgio,

Você esta com todos os fontes de todas as pastas atualizados?

Se sim, reinstalou a suíte ACBr usando o ACBrInstall_Trunk2 com a opção de apagar arquivos antigos marcada?

Se sim, compilou a sua aplicação com a opção Build?

Se sim, na pasta que contem o executável consta o arquivo INI ACBrCTeServicos?

Se sim, apague ele, pois possa estar desatualizado.

  • Like 1

Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...