Jump to content

Compre o Delphi
Com até 30% de desconto
e parcelado em até 12x sem juros

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Minas Software

raised exception class EACBrDFeException with message

Recommended Posts

Olá, bom dia.

  Tenho um sistema que emite NFC-e usando os componentes do ACBr, quando vou transmitir a venda acontece este erro:

raised exception class EACBrDFeException with message

Procurei no fórum e no google mas não encontrei nada que poderia ajudar, se alguém puder ajudar ficarei grato.

O Certificado ta ok, consigo ler ele como mostrar na img abaixo

image.png.707c0cc6a5399c83b1dd061057fed297.png

Erro NFCe1.png

Erro NFCe2.png

Share this post


Link to post
Share on other sites
5 horas atrás, Italo Jurisato Junior disse:

Bom dia,

Quando foi a ultima vez que você atualizou os fontes dos componentes e reinstalou a suíte ACBr?

Olá, ontem logo que acabei de resolver um problema no componente do FortesReports, sei que a SefazMG esta em manuntenção, eu selecionei a opção de emissão OffLine, no acbrmonoitorplus consigo emitir o cupom, mas direto pelo componente não consigo

Share this post


Link to post
Share on other sites
2 minutos atrás, Italo Jurisato Junior disse:

Boa tarde,

Qual é o problema que ocorre ao tentar emitir a NFC-e em Offline usando o componente?

é o erro acima, onde mostro as imagens

Share this post


Link to post
Share on other sites

Você esta com todos os fontes de todas as pastas atualizados?

Se sim, reinstalou a suíte ACBr?

Compilou a sua aplicação com a opção Build?


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

Você esta com todos os fontes de todas as pastas atualizados?

R: Sim, baixei pelo svn e coloquei tudo na pasta C:\ACBr

Se sim, reinstalou a suíte ACBr?

R: Sim, pois tive que instalar o Fortes Reports e ai depois rodei o ACBrInstall_Trunk2

Compilou a sua aplicação com a opção Build?

R: Sim, usei a opção desta img e a Compile all Projects

image.png.af50337e6219645f75385d9de2a3d16e.png

Share this post


Link to post
Share on other sites

Ok, mas quando você atualizou pela ultima vez os fontes, ontem, hoje?

Se foi ontem depois das 14:27, você esta com os fontes atualizados, caso contrario não esta.


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites
2 minutos atrás, Italo Jurisato Junior disse:

Ok, mas quando você atualizou pela ultima vez os fontes, ontem, hoje?

Se foi ontem depois das 14:27, você esta com os fontes atualizados, caso contrario não esta.

Vou atualizar agora e ai posto aqui

Share this post


Link to post
Share on other sites

Acredito que a instalação dos componentes no Delphi não esteja correta.

Você deve estar compilando em 64 bits e usando as DLLs de 32.

  • Like 1

Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites
5 minutos atrás, Italo Jurisato Junior disse:

Acredito que a instalação dos componentes no Delphi não esteja correta.

Você deve estar compilando em 64 bits e usando as DLLs de 32.

Ok, vou fazer mais alguns teste aqui e te reporto, obrigado brother pela ajuda, volto a postar aqui caso ocorro tudo bem.

Share this post


Link to post
Share on other sites
15 horas atrás, Italo Jurisato Junior disse:

Acredito que a instalação dos componentes no Delphi não esteja correta.

Você deve estar compilando em 64 bits e usando as DLLs de 32.

Bom dia, peguei as dll dentro desta pasta

image.thumb.png.5bc330584f64f8dea9e8f4778d373495.png

Peguei as DLL da pasta x64 e coloquei dentro da pasta C:\Windows\SysWOW64

e as DLL da pasta x86 coloquei dentro da pasta C:\Windows\System32

Junto com o meu programa qual tenho que colocar a x86 ou x64 pois tentei com as duas e o erro continua, tem outro lugar que preciso copiar as dll?

image.png.de4fd7f695c90a922ec142cb8744fc24.png

Share this post


Link to post
Share on other sites

   Olá.

Por favor, verifique o seguinte:

2 horas atrás, Minas Software disse:

Peguei as DLL da pasta x64 e coloquei dentro da pasta C:\Windows\SysWOW64

e as DLL da pasta x86 coloquei dentro da pasta C:\Windows\System32

Se o seu Windows tem a pasta SysWow64, então é justamente o contrário... as dlls em 64 bits vão pra System 32 e as x86 vão pra SysWOW64.

2 horas atrás, Minas Software disse:

Junto com o meu programa qual tenho que colocar a x86 ou x64 pois tentei com as duas e o erro continua, tem outro lugar que preciso copiar as dll?

Se o seu programa está sendo compilado em 32 você deve colocar a x86. Caso seu programa seja 64 bits então deve colocar as x64.


[]'s

Consultor SAC ACBr

Elton
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Um engenheiro de Controle de Qualidade(QA) entra num bar. Pede uma cerveja. Pede zero cervejas.
Pede 99999999 cervejas. Pede -1 cervejas. Pede um jacaré. Pede asdfdhklçkh.

Share this post


Link to post
Share on other sites
2 horas atrás, EMBarbosa disse:

   Olá.

Por favor, verifique o seguinte:

Se o seu Windows tem a pasta SysWow64, então é justamente o contrário... as dlls em 64 bits vão pra System 32 e as x86 vão pra SysWOW64.

Se o seu programa está sendo compilado em 32 você deve colocar a x86. Caso seu programa seja 64 bits então deve colocar as x64.

Certo, coloquei as dll nas pasta como você sugeriu, tentei compilar meu programa usando as dll x86 e deu erro e com x64 tb deu erro, eu tb baixei o Truck2 e reinstalei os componentes do acbr no meu delphi e mesmo assim continua com este erro, tem mais algum lugar que posso tentar algo? meu certificado é A1

Share this post


Link to post
Share on other sites
2 horas atrás, Minas Software disse:

Certo, coloquei as dll nas pasta como você sugeriu, tentei compilar meu programa usando as dll x86 e deu erro e com x64 tb deu erro, eu tb baixei o Truck2 e reinstalei os componentes do acbr no meu delphi e mesmo assim continua com este erro, tem mais algum lugar que posso tentar algo? meu certificado é A1

Estranho. Verifique a possibilidade de você estar com dlls de versões misturadas. Exemplo a libeay32.dll ser da versão 1.0 mas outras dlls relacionadas serem da versão 0.9.

  • Like 1

[]'s

Consultor SAC ACBr

Elton
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Um engenheiro de Controle de Qualidade(QA) entra num bar. Pede uma cerveja. Pede zero cervejas.
Pede 99999999 cervejas. Pede -1 cervejas. Pede um jacaré. Pede asdfdhklçkh.

Share this post


Link to post
Share on other sites

Pessoal, peguei as dll de um amigo no pc dele e deu certo, pode ser que eu fiz confusão com essa questão de dll, peço desculpas pelo trabalho que dei a todos, mas foi resolvido o problema, agradeço a todos mais uma vez

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...