Jump to content

logo_acbr_paygo.png

Chegou o TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao_saibamais.png

beneficios.png

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Leonardo Moreira

ANSWERED Iprimi somente uma guia.

Recommended Posts

Boa tarde.

Verifique se o mesmo ocorre no demo do componente.

Att.


Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Share this post


Link to post
Share on other sites

Boa tarde , é do demo que estou tentando gerar antes de implementar no meu sistema, esse xml foi gerado pelo demo e tanto na hora que mando imprimir ou gerar PDF ele só gera ou imprimi 1.

Obrigado

Share this post


Link to post
Share on other sites

Boa tarde Leonardo,

Esse XML é o retorno e nele contem as informações referentes as guias dentro da tag <resultado>.

Na forma que as informações das guias foram retornadas, o envio foi feito segundo a versão 1.00

Se não me falha a memória é para o componente salvar um arquivo TXT para cada guia.

Para imprimir as guias é preciso carregar esses arquivos TXT.

No programa exemplo use o botão [Imprimir Guia TXT] para carregar o arquivo TXT de cada guia para poder imprimir.


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

Leonardo,

Me recordo de ter feito algumas alterações no componente visando a gravação dos arquivos tanto TXT quanto o XML da versão 2.

Bem como a impressão das guias.

Você esta com todos os fontes atualizados?

Se sim, reinstalou a suíte ACBr através do ACBrInstall com a opção de apagar arquivos antigos marcada?


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

Leonardo,

Vai salvar na pasta informada em: Configuracoes.Arquivos.PathArqTXT

Por outro lado as guias da versão 2.00 que são em XML são salvas na pasta informada em: Configuracoes.Arquivos.PathGNRE


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

Bom dia , eu passei o caminhio , em Configuracoes.Arquivos.PathArqTX  e tambem passei o caminho em Configuracoes.Arquivos.PathGNRE

no txt nao gerou os arquivos  e no pathGNRE nao gerou a guia(gerou os arquivos em anexo).

Estou gerando  a guia manualmente o retorno que esta vindo depois que eu consulto o lote . (nao sei se e o certo).

Outra coisa se tambem nao ei se esta certo para gerar o lote estou dando um while no AlimentarComponente da demo ai ele gera , acho que deve esta

certo , pois ele cria e envia e me da o retorno certo certo.

Outro ponto eu vi

Share this post


Link to post
Share on other sites

Bom dia o comentario de cima nao deixou eu anexar os arquivos ou editar .

eu passei o caminhio , em Configuracoes.Arquivos.PathArqTX  e tambem passei o caminho em Configuracoes.Arquivos.PathGNRE

no txt nao gerou os arquivos  e no pathGNRE nao gerou a guia(gerou os arquivos  : 2000511193 -ped-rec , 2000511193 -pro-rec ,2000511193-ped-rec,2000511193-pro-rec, 20200504081631-env-lot , 20200504081632-rec   ).

Estou gerando  a guia manualmente o retorno que esta vindo depois que eu consulto o lote . (nao sei se e o certo).

Outra coisa se tambem nao ei se esta certo para gerar o lote estou dando um while no AlimentarComponente da demo ai ele gera , acho que deve esta

certo , pois ele cria e envia e me da o retorno certo certo.

Outro ponto eu vi que tem o botao assinar mais nao precisei assinar para enviar e receber a resposta.

Desde ja agradeco , sou novo nesse desenvolvimento.

Share this post


Link to post
Share on other sites

Bom dia Leonardo,

O método Enviar, no final ele realiza uma consulta automaticamente.

Você esta fazendo testes com o programa exemplo?

Manda para mim esses XML gerados por e-mail, para que eu possa analisar.


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

Bom dia  Italo ,

Atualizei o ACBR do jeito que voce me orientou, mas continua sem gerar a guia automática e nem os arquivos textos e quando gero manualmente

so imprimi uma.

Desde já agradeço.

Share this post


Link to post
Share on other sites

Bom dia Leonardo,

Como não tenho nenhum cliente que emite o GNRE não tenho realizar testes.

Vai ser necessário debugar para descobrir o porque o componente não esta separando as guias retornadas para salva-las em disco separadamente.


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

Bom dia Leonardo,

Antes de você dar continuidade aos seus testes, por favor atualize o fones.

Fiz uma alteração que faz com que o componente considere o tempo estimado de processando antes de realizar a consulta para obter o resultado do processamento.

Pois o componente após o envio ele realiza uma consulta automaticamente, se o tempo estimado para o processamento for de 3 segundos (por exemplo) pode não retornar a guia.

Procure debugar o método LerXml que se encontra na unit pgnreRetConsResLoteGNRE.


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

Bom dia , eu atualizei, mas , em lote continuou tendo problema em imprimir todas as guias resolveram mandar um a um em vez de lote , outra coisa que observei tem UF que precisa do produto e não tem esses campos, como mando ?

Share this post


Link to post
Share on other sites

Boa noite Leonardo,

Não tenho condições de testar, pois além de não ter um certificado digital, não tenho nenhum cliente que emite a GNRE.

Logo acabo fazendo alterações que julgo que vai funcionar e fico no aguardo de um retorno de quem utiliza, mas vou voltar a verificar a rotina para ver se descubro algo que possa estar ainda errado.

Quanto a informar o produto, você tem algum XML de GNRE a ser enviado que contenha essa informação?

 


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...