Jump to content
Notícias do ACBr

click.png

click.png

click.png

logos

Texto.png

p200

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

Layoute de Remessa: pegando sempre o anterior


Go to solution Solved by Rafael Dias,

Recommended Posts

  • Usuários SAC

Boa tarde,

Estou fazendo uns testes com a dll de boletos e notei q dll nao esta considerando quando mudamos o LayoutRemessa de "0" pra "1", ou vice-versa.

O interessante eh que isso acontece DEPOIS da emissão do PRIMEIRO boleto.

Exemplo

- Emito a primeira vez com LayoutRemessa "0" (cnab 240), blz a remessa eh gerada nesse cnab;

- Saio do sistema totalmente e entro novamente (fazendo uma nova carga da dll), desta feita mudo o LayoutRemessa para "1" (cnab 400), mas ao gerar uma nova remessa continua com layoute cnab 240.

Como se de alguma forma a configuração anterior estivesse "presa" na memoria da dll

Lembrando que sempre ao sair do sistema eu finalizo a dll

 

ACBrLib.ini ACBrLibBoleto-20210223.log

Link to post
Share on other sites
  • Usuários SAC

Qual seria o comando pra mudança das configurações, Rafael?
Tentei Boleto_ConfigurarDados mas nao surtiu efeito.

Detalhe: configuro os dados que quero direto no ACBrLib.ini

Link to post
Share on other sites
  • Solution

Não se deve configurar os dados direto no ini tem metodos para configuração na lib já para isso, se configurar direto no ini tem que mandar a dll recarregar os dados.

Métodos de Configuração (sourceforge.io)

Consultor SAC ACBr Rafael Dias
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Desenvolvedor ACBrLib.

 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...