Jump to content

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png click.png click.png

click.png

click.png

click.png

lucimauro

Membros
  • Posts

    268
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by lucimauro

  1. Boa noite. Voce esta consultando no portal do Cfe ou no SIGET? Nesse caso ah possibilidade do contador subir os xml em contingência pelo portal do contribuinte, mais no caso da chave que esta em seu log em anexo ela já consta no portal.
  2. Versões leia-se: 0.4.6.114 e 0.4.6.118
  3. Boa tarde, Houve mudança nos retornos da dll em relação aos métodos de distribuição? Na versao 0.14 os retornos era Items001, Items002, .... Agora na versao 0.18 sumiu os "items" e passou a ser ResNFe001, ResNFe002, ... Isso mesmo?
  4. Bom a todos; Fiz mais testes aqui com a função SAT_GerarImpressaoFiscalMFe() do acbrlibsat32(MT) e pelo visto não esta funcionando, continua me retornando erro -10 access violation, já passei a variavel buffer de todos as maneiras e nada de me retornar o espelho do cupom eletrônico em txt
  5. É, isso é possível. Se o usuário for sair somando... pode ser que ele faça essa confusão. Mas opção de não mostrar nada (nem desconto e nem acréscimo) que já existe tbm não poderia ser confuso? Nao sei. Qualquer modo, segue xml AD35210608723218000186599000168050014072601925.xml
  6. @Rafael Dias Inicializou a variavel buffer com um tamanho predefinido ? Sim , inclusive deixei o tamanho dela o tamanho do arquivo xml enviado Passou este valor na variavel bufferlen ? SIm Erro de acess violation geralmente é erro no acesso a variavel buffer. No caso desta funcao o extrato gerado vem por referencia em buffer diferente por exemplo do SAT_GerarPDFExtratoVenda() que voce manda o nome do arquivo pdf?
  7. Sim, como esta no meu post inicial estou executando o método correto(eu acho) mais ele não funciona.
  8. Em meus testes aqui estou usando essa classe dos demo, e outros metodos testados como impressão por exemplo estão funcionando, somente o metodo SAT_GerarImpressaoFiscalMFe() que me retorna esse erro.
  9. Uso Harbour , mais acredito que pelo demo do satteste.exe não der para simular já que ele não usam a dll da acbrlib pelo menos eu acho.
  10. Ola a todos Estou migrando meu PDV aqui no CE do acbrmonitorplus para acbrSat32.dl(MT)l e me deparei com um problema na função SAT_GerarImpressaoFiscalMFe(), no acbrmonitorplus funciona perfeitamente mais com a Dll me retorno um erro Como envio o comando: hResult:=DllCall(nAcbrSatDll, DLL_OSAPI, 'SAT_GerarImpressaoFiscalMFe', nPonteiroDll, hb_StrToUTF8(tp_arqxml),@buffer,@bufferLen) retorno : SetRetorno(-10, Access violation)
  11. Ola Daniel, Não entendi sua colocação, já que essa possibilidade (de SUPRIMIR essa informação) já existe no AcbrMonitor. O acréscimo (ou desconto) consta no xml, mas a opção de IMPRIMI-LOS, ou nao, ja existe no acbr. O problema eh que marcando (ou desmarcando) essa opcao no monitor, vale para as duas opções (desconto e acréscimo), e no caso gostaríamos servisse apenas para uma opção, o acréscimo no caso
  12. Bom dia. Atualmente podemos parametrizar o AcbrMonitor pra imprimir ou não os descontos e acréscimos nos itens no cupom Sat/Mfe. Estou tendo um problema em alguns clientes que gostariam de que o ACRÉSCIMO, apenas o ACRÉSCIMO, não fosse impresso item a item, mas que ele fosse mostrado apenas la no subtotal do cupom eletronico. Explico: Para o meu cliente não é vantajoso rsrs mostrar acréscimo no item pq a bem da verdade esse acréscimo que consta no item, em 99,99% da vezes não é um adicional de valor intencional que foi inserido no item, mas refere-se aquela obrigação que temos de RATEAR entre os produtos os descontos/acréscimos que são inseridos no SUBTOTAL do cupom. Esse adicional inserido na finalização do cupom é uma taxa de entrega, que não diz respeito a um produto específico. Haveria alguma possibilidade de suprimir, esconder na impressão o acréscimo no item? La no subtotal continua sem problema
  13. Achei o problema hehehe Errado [DESC001] cMuncarrega=2312908 XMuncarrega=SOBRAL Correto [DESC001] cMunDescarga=2312908 xMunDescarga=SOBRAL
  14. Boa noite, Estou gerando o ini para a dll ACBrMDFe (versao 0.2.1.114) igualzinho ao que gero para o ACBrMonitor, porém, esta acontecendo como se a dll não estivesse lendo alguns blocos do INI. o Bloco no XML infDOC ta sendo fechado sem ter sido aberto rsrs, gerando erro na hora de validar. Segue anexo as informações ACBrLib.ini mdfe.txt 23210507439697000140580010000000131000000180-mdfe.xml
  15. Ola @wil Já tentou substituir o arquivo mfe.dll pelo que esta em C:\Program Files\SEFAZ-CE\Driver MFE\Biblioteca de funções?
  16. Qual seria o comando pra mudança das configurações, Rafael? Tentei Boleto_ConfigurarDados mas nao surtiu efeito. Detalhe: configuro os dados que quero direto no ACBrLib.ini
  17. Boa tarde, Estou fazendo uns testes com a dll de boletos e notei q dll nao esta considerando quando mudamos o LayoutRemessa de "0" pra "1", ou vice-versa. O interessante eh que isso acontece DEPOIS da emissão do PRIMEIRO boleto. Exemplo - Emito a primeira vez com LayoutRemessa "0" (cnab 240), blz a remessa eh gerada nesse cnab; - Saio do sistema totalmente e entro novamente (fazendo uma nova carga da dll), desta feita mudo o LayoutRemessa para "1" (cnab 400), mas ao gerar uma nova remessa continua com layoute cnab 240. Como se de alguma forma a configuração anterior estivesse "presa" na memoria da dll Lembrando que sempre ao sair do sistema eu finalizo a dll ACBrLib.ini ACBrLibBoleto-20210223.log
  18. Boa tarde, Muitos anos usando o AcbrMonitor e agora tentando migrar para a dll devido a todos os imensos benefícios que todos sabem. Porém, nao estou sabendo como pegar a descrição da msg de erro da função NFe_Validar. Um xml invalido, retorna -11 na função blz, mas como pegar a descrição exata do que tem errado?
  19. Sensacional! Agora sim, retornando -11 na validação! Muito obrigado
  20. Ah entendi. A nota nem chegou a ser enviada a sefaz. O erro q deveria ter retornado la na validação, apareceu la no envio rsrs Blz, Obg
  21. Rafael, Aproveitando o ensejo e acredito que os erros estao relacionados: Nesse caso que passou liso na VALIDAÇÃO, foi dar erro la no ENVIO (retorno -10). Bateu la na sefaz e retornou como REJEIÇÃO (lógico). Nesse caso a função NFE_Enviar não deveria retornar ZERO e nós (sistema) tratar a rejeição?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.