Jump to content

dev botao

Não há retorno do método se o SAT estiver inoperante


Go to solution Solved by Daniel Simoes,
  • Este tópico foi criado há 973 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Estou utilizando a ACBrLibSAT no C#, quando envio um comando para o Sat e o mesmo não é localizado por qualquer motivo, seja uma problema de conexão ou até mesmo o equipamento desligado, minha aplicação trava aguardando o retorno do método.  Fiz o teste na aplicação de exemplo ACBrLibSat.DemoMT e o mesmo problema ocorreu. Há alguma forma de resolver isto? Também observei que mesmo após fechar a aplicação de forma forçada, se religar o Sat o comando que causou o travamento é executado.

Link to comment
Share on other sites

  • Administradores

Tópico movido para a área do SAC, para que o SLA de respostas seja considerado

Consultora SAC ACBr

Juliana Tamizou

Gerente de Projetos ACBr / Diretora de Marketing AFRAC
Ajude o Projeto ACBr crescer - Seja Pro

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

  • Fundadores
  • Solution

Apenas a DLL do Emulador de SAT, disponibilizada pela SEFAZ, tem esse comportamento...

As DLLs de SAT, fornecidas pelos fabricantes, tem TimeOut... porém cada uma delas, tem uma configuração específica, de como configurar

 

  • Like 1
Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

The popup will be closed in 10 seconds...