Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

Caixa dos Dados Adicionais da DANFE não aparece


Go to solution Solved by BigWings,
  • Este tópico foi criado há 253 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Bom dia a todos. 

Eu atuaizei os fontes e copiei os reports da pasta de exemplos para testar com meu sistema, mas não esta mostrando a caixa de dados adicionais no arquivo: DANFeRetrato.fr3  da NF-e.

Em tópicos antigos, ví informações sobre o Fast Report, mas a versão que eu uso é a versão 6.0 do fast instalado com uma licença comercial, não uso o embarcado do Delphi...

Eu tentei usar o fortes mas não tive uma adesão muito boa por parte dos clientes, uns acharam que não ficou com o mesmo "padrão" que está acostumados.... Não é fácil a vida de programador. Rssss

Como faço para resolver ?

_____________________________________

Junior - Rhovanion Tecnologia

(11) 4224.6543

Link to comment
Share on other sites

  • Consultores

Bom dia, consegue anexar uma foto de exemplo de como está saindo ?

tampe os dados sensíveis por favor. 

Consultor SAC ACBr

Victor H Gonzales - Pandaaa
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

"Aprender é a única coisa que a mente nunca se cansa, nunca tem medo e nunca se arrepende” - Leonardo da Vinci

"Ter sucesso é falhar repetidamente, mas sem perder o entusiasmo"

Link to comment
Share on other sites

  • Membros Pro
2 horas atrás, Victor H. Gonzales - Panda disse:

Bom dia, consegue anexar uma foto de exemplo de como está saindo ?

tampe os dados sensíveis por favor. 

@Victor H. Gonzales - Panda Obrigado por responder....

Segue o print:

image.thumb.png.9fc145441dda8117be29705cd33878b5.png

_____________________________________

Junior - Rhovanion Tecnologia

(11) 4224.6543

Link to comment
Share on other sites

  • Consultores

image.png

\Report\DANFeRetrato.fr3 Gerado no FastReport 6.5.6

verifique realmente se é o que está atualizado no svn

Consultor SAC ACBr

Victor H Gonzales - Pandaaa
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

"Aprender é a única coisa que a mente nunca se cansa, nunca tem medo e nunca se arrepende” - Leonardo da Vinci

"Ter sucesso é falhar repetidamente, mas sem perder o entusiasmo"

Link to comment
Share on other sites

  • Membros Pro
1 hora atrás, Victor H. Gonzales - Panda disse:

image.png

\Report\DANFeRetrato.fr3 Gerado no FastReport 6.5.6

verifique realmente se é o que está atualizado no svn

Sim, confirmei agora inclusive, os arquivos estão com a data de 03/09/2021. Se eu usar o arquivo que está em obsoletos retrato_basic imprime normal, creio que é referente a versão do Fast Report... A versão que temos aqui é esta : FastReport VCL 6.2.1 for Delphi 10.3 Rio

Você informou acima que o desenvolvimento é feito com a 6.5.6, correto ?

Creio que seja este o problema....

_____________________________________

Junior - Rhovanion Tecnologia

(11) 4224.6543

Link to comment
Share on other sites

  • Consultores
2 horas atrás, Edevair Viesa Junior disse:

Sim, confirmei agora inclusive, os arquivos estão com a data de 03/09/2021. Se eu usar o arquivo que está em obsoletos retrato_basic imprime normal, creio que é referente a versão do Fast Report... A versão que temos aqui é esta : FastReport VCL 6.2.1 for Delphi 10.3 Rio

Você informou acima que o desenvolvimento é feito com a 6.5.6, correto ?

Creio que seja este o problema....

É compatível até o fastreport 5.

O que eu disse da versão acima, é aque eu usei para o teste.

Única coisa que pode causar problemas é se você não tiver acesso a parte de Scripts, pois os danfes tem programação.

Então a versão Embarcadero do fastreport não roda os reports.

Consultor SAC ACBr

Victor H Gonzales - Pandaaa
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

"Aprender é a única coisa que a mente nunca se cansa, nunca tem medo e nunca se arrepende” - Leonardo da Vinci

"Ter sucesso é falhar repetidamente, mas sem perder o entusiasmo"

Link to comment
Share on other sites

  • Membros Pro
12 horas atrás, Victor H. Gonzales - Panda disse:

É compatível até o fastreport 5.

O que eu disse da versão acima, é aque eu usei para o teste.

Única coisa que pode causar problemas é se você não tiver acesso a parte de Scripts, pois os danfes tem programação.

Então a versão Embarcadero do fastreport não roda os reports.

Mas não é o caso, pq como eu disse na mensagem inicial, é versão comercial 6.0...

Eu vou permanecer usando o report antigo mesmo...

Agradeço a atenção. Abs

_____________________________________

Junior - Rhovanion Tecnologia

(11) 4224.6543

Link to comment
Share on other sites

  • Moderadores
  • Solution
1 minuto atrás, Edevair Viesa Junior disse:

Mas não é o caso, pq como eu disse na mensagem inicial, é versão comercial 6.0...

Você removeu a versão do Fast que vem com o Delphi? 

Se os fontes ainda estiverem lá e com referência no library path o componente pode ter sido compilado com a versão Embarcadero do Fast. 

Pelo print e relato é o que parece estar acontecendo. 

  • Thanks 1
Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

  • Membros Pro
2 horas atrás, BigWings disse:

Você removeu a versão do Fast que vem com o Delphi? 

Se os fontes ainda estiverem lá e com referência no library path o componente pode ter sido compilado com a versão Embarcadero do Fast. 

Pelo print e relato é o que parece estar acontecendo. 

Bingoooo !!!!

@BigWings muito obrigado.... Era exatamente este o problema.... A versão da embarcadero estava instalada tb, foi desinstalar que funcionou perfeito....

Muito obrigado pela ajuda...

Peço ao moderador a fechar o tópico por favor...

  • Like 1

_____________________________________

Junior - Rhovanion Tecnologia

(11) 4224.6543

Link to comment
Share on other sites

  • Consultores

Obrigado por reportar.

Fechando. Para novas dúvidas, criar um novo tópico.

Consultor SAC ACBr

Victor H Gonzales - Pandaaa
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

"Aprender é a única coisa que a mente nunca se cansa, nunca tem medo e nunca se arrepende” - Leonardo da Vinci

"Ter sucesso é falhar repetidamente, mas sem perder o entusiasmo"

Link to comment
Share on other sites

  • Este tópico foi criado há 253 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.