Jump to content

Alexandre Felippeto Henzen

Membros Pro
  • Posts

    41
  • Joined

  • Last visited

Everything posted by Alexandre Felippeto Henzen

  1. Boa tarde, achamos melhor tratar para enviar o motivo de cancelamento sem acentuação para evitar problemas futuros. Obrigado pelo auxílio.
  2. Boa tarde, o banco Safra obriga a colocar a instrução como 3, que seria não protestar. No código do ACBrBancoSafra, ele verifica se existe uma data de protesto, e se tiver, pega a instrução que coloquei dentro do sistema, no caso a 3, porém se não tiver data, ele seta como 0. Porém, como coloquei uma instrução para não protestar, entendo que está errado precisar ter uma data de protesto para colocar a instrução que eu quero. Segue print do manual: E manual anexado também. 500 (2).pdf
  3. Boa tarde, Na máquina que roda o servidor de NFSe, não instalamos o ACBr, geramos o nosso .exe, e colocamos lá com os schemas e algumas dlls. Onde exatamente ocorre o trecho que coloca o Encoding ?
  4. Boa tarde, aqui é a Michele, preciso de uma ajuda. Ao enviar o xml de cancelamento ocorreu o erro "00000 - Erro na estrutura do arquivo XML enviado. Verifique a estrutura da tag NFSE" Percebi que esse problema ocorreu porque o cliente colocou no motivo de cancelamento a palavra 'SERVIÇO'; ao muda para 'SERVICO' a NFSe pode ser cancelada. Pelo que verifiquei no meu xml gerado está igual ao manual do provedor IPM. Entrei em contato com eles e os mesmos realizaram testes informado o caractere especial e mesmo assim a nota foi cancelada sem erro. A única coisa que percebi de diferente foi o cabeçalho do xml, o meu está como <?xml version="1.0"?> e do teste da IPM está como <?xml version="1.0" encoding="ISO-8859-1"?>, teria alguma relação com esse problema? exemplo_cancelamento.xml RETORNO_XML_COM_ERRO.xml
  5. Boa tarde, a caixa solicitou um ajuste no campo Aceite, do arquivo "Boleto.fr3", atualmente, é preenchido com "Sim" ou "Não". Porém, as alterações que eles pediram é para alterar de "Sim" para "A", e de "Não" para "N". Segue print das alterações pedidas por eles: Para corrigir, fiz a seguinte validação: Segue manual com a instrução: ESP_COD_BARRAS_SIGCB_COBRANCA_CAIXA (1).pdf Está na pagina 20 essa solicitação, no tópico 4.2.4.4. Aceite. Obrigado.
  6. Esta atualização já está disponível. Confiram e adaptem os seus fontes para as novas tags criadas no item de serviço: TribMunPrestador CodMunPrestacao SituacaoTributaria Conforme orientação do Italo, os exemplos estão atualizados para exibir como preencher estes campos.
  7. Bom dia pessoal, Tenho clientes com o mesmo problema, já conseguiram implementar as alterações? @Elias LS Tech ? Obrigado desde ja.
  8. Bom dia Italo, Acho que me expressei mal no último post... A correção implementada foi no arquivo ACBrNFSeXServicos.ini, apenas esta alteração conforme print: De Para Valeeeu!!
  9. Boa tarde Italo, Sim eu usei o Compila_RES. Realmente, o meu método emitir estava como meLoteAssincrono e o terceiro parâmetro de impressão false. Alterei para automático e foi correto!! Agora uma outra coisa Italo, porque será que os XMLs de retorno que estou tendo do componente estão com a acentuação estranha? Dentro do Delphi direto pelo object inspector na classe de retorno, ja aparece desta maneira.. Segue um exemplo em anexo..Retorno Acentuacao.xml Muito obrigado pelas ajudas Italo!! Só relembrando que é necessário corrigir no fonte o provedor da cidade Telêmaco Borba
  10. Boa tarde, Tenho um cliente tentando emitir uma NFS-e para o município de Telêmaco Borba no Paraná. Primeiro tive o seguinte retorno: "Não foi possível converter RPS para prestadores autorizados em mais de uma entidade". No Xml, na primeira linha, reparei o seguinte trecho: "<ns3:EnviarLoteRpsEnvio xmlns:ns3="http://www.betha.com.br/e-nota-contribuinte-ws">" Investigando um pouco mais, identifiquei que o município utiliza a IPM para a NFS-e, e não Betha como está configurado no componente hoje.. Clicando aqui abre o site do IPM.. Alterei no arquivo de configurações das cidades: Compilei o componente, e tive o seguinte erro ao tentar emitir: Segue em anexo o XML gerado ao tentar enviar. Alguém poderia analisar/orientar? Obrigado Envio IPM.xml
  11. Boa tarde, Então, já tenho este cadastro ok, tanto que no inicio do chamado eu reportei que o outro componente de envio de NFSe que tenho implementado, ele montou o XML com duas assinaturas e a prefeitura aceitou. Ainda estou no aguardo da resposta do e-mail da prefeitura.
  12. Bom dia @Italo Giurizzato Junior, 1. Atualizei o componente e garanti que meu cenário estava utilizando os schemas da pasta que você indicou. 2. Realmente, isto está correto no NFSeX. 3. Pelo que simulei, o ambiente de produção realmente não precisa de assinatura na nota, já o ambiente de homologação retornou o erro E504. Segue em anexo o XML de envio e retorno. 4. O Tomador foi gerado corretamente! Enviei um e-mail a prefeitura e solicitei os schemas de produção e homologação (caso sejam diferentes) assim que eles retornarem te aviso por aqui! ACBr - Curitiba - HMLG - 2.xml ACBr - Curitiba - HMLG - 2 - Retorno Prefeitura.xml
  13. Boa tarde, Segue em anexo um XML gerado pela biblioteca NFSeX, e outro gerado por uma implementação que tenho da TecnoSpeed. O XML gerado pelo NFSeX resultou no retorno de erro da prefeitura "Erro E504: O Certificado digital do prestador de serviços é obrigatório." Analisando outro emissor que tenho, que funciona normalmente, reparei algumas diferenças no XML. 1. O XML do NFSeX saiu sem o tomador. 2. O XML do NFSeX possui a assinatura apenas no lote do RPS, já o xml da TecnoSpeed (que enviou com sucesso nesta mesma nota) preencheu o tomador, e tinha uma assinatura na NFSe e no lote de RPS também. Obrigado. TecnoSpeed - Curitiba - HMLG.xml ACBr - Curitiba - HMLG.xml
  14. Opa @Italo Giurizzato Junior, Segue novo arquivo de correção. o primeiro que enviei acabou dando erro quando o XML não possui a tag tcCompNfse. Segue a correção que atende ambos os casos. ACBrNFSeXProviderABRASFv1.pas
  15. Bom dia, Segue um problema que detectei e não consegui identificar se já está resolvido ou não na versão mais recente. No método TACBrNFSeProviderABRASFv1.TratarRetornoConsultaLoteRps é avaliado uma propriedade tcCompNfse como uma tag apenas, ao invés de ser considerada um array. Isso causa problema na consulta de lote RPS, pois o componente retorna 1 nota na lista, ao invés de 2, 3, 4, etc.. Segue em anexo o arquivo que modifiquei e testei. Não sei se está nos padrões do componente mas funcionou. ACBrNFSeXProviderABRASFv1.pas
  16. Atualização: Após questionar o banco, o mesmo retornou: Assim como disseram não ter uma "lista" com os layouts disponíveis e quando utilizar qual layout. Acredito que não devem ser muitos os layouts, no entanto precisamos de uma estrutura que possibilite utilizar diferenças de layout, algo como uma propriedade para definir o tipo de layout a ser utilizado seguindo por "if's" no código com as diferenças de cada layout.. vi algo parecido no código do banco Caixa Econômica, que possui algumas versões de layout com suas diferenças.. Aqui no fórum mesmo tem um post com outras pessoas enfrentando esse problema (https://projetoacbr.com.br/forum/topic/62451-cnab-400-banco-daycoval/) sendo assim a solução dessas diferenças também faz sentido.. Aguardo um retorno. Obrigado!
  17. Estou tentando obter mais informações com o setor de validação do banco também. Qualquer outra informação atualizo este post. Obrigado
  18. Bom dia, Estou enfrentando um problema com o banco Daycoval onde aparentemente a cada cliente do banco, há alterações no layout do CNAB, cada um de acordo com um manual diferente. O banco me enviou um manual de Junho de 2021, após ter as seguintes contestações no arquivo que está sendo gerado atualmente: Contestando o motivo das divergências deste manual para os outros, o banco respondeu que o manual que passaram é referente apenas a este cliente em questão que estamos tratando: Alguma sugestão de como tratar este caso? Há possibilidade de utilizar "múltiplos layouts" para este mesmo banco a partir do preenchimento/configuração de uma propriedade de Versão de Layout ? Em anexo também, o manual enviado pelos mesmos. Manual S. 707 X 341 Jun-21.pdf
  19. Olá, Gostaria de saber se qualquer balança da marca Toledo é suportado pelo ACBRBal. Mais especificamente os seguintes modelos, são suportados? https://www.balancascia.com.br/balanca-toledo-2098c-contadora-120kg https://www.balancascia.com.br/balanca-toledo-2099-300kg-ti200-bateria Encontrei somente um tópico no fórum que não deixou claro se é QUALQUER modelo da Toledo suportado: https://www.projetoacbr.com.br/forum/topic/11824-modelos-de-balan%C3%A7as-suportados/ Muito obrigado.
  20. Boa tarde, Possuo dois módulos no sistema, um cadastro de balança onde é possível realizar a configuração da balança e testes de conexão e pesagem e um módulo de produção onde o peso da balança será utilizado de fato. No meu módulo de cadastro de balança eu consigo conectar normalmente e realizar pesagens de teste sem nenhum erro ou retorno estranho da balança. Porém no módulo de produção a pesagem da balança retorna -9 diversas vezes seguidas e depois de muitas tentativas retorna um peso válido. Ambos os módulos chamam a classe de balança, para conectar tenho a seguinte função: FACBrBAL1 := TACBrBAL.Create(nil); FACBrBAL1.OnLePeso := OnLePeso; // se houver conexão aberta, Fecha a conexão if FACBrBAL1.Ativo then FACBrBAL1.Desativar; // configura porta de comunicação FACBrBAL1.Modelo := TACBrBALModelo(GetIndexBalanca(FBalancaUtilizada.Balanca)); FACBrBAL1.Device.HandShake := TACBrHandShake(GetIndexHandShake(FBalancaUtilizada.Handshaking)); FACBrBAL1.Device.Parity := TACBrSerialParity(GetIndexParity(FBalancaUtilizada.Parity)); FACBrBAL1.Device.Stop := TACBrSerialStop(GetIndexStopBits(FBalancaUtilizada.StopBits)); FACBrBAL1.Device.Data := FBalancaUtilizada.DataBits; FACBrBAL1.Device.Baud := FBalancaUtilizada.BaudRate; FACBrBAL1.Device.Porta := FBalancaUtilizada.PortaSerial; FACBrBAL1.ArqLOG := FBalancaUtilizada.ArquivoLog; // Conecta com a balança try FACBrBAL1.Ativar; except raise EKorpMensagem.Create('Atenção! Não foi possível realizar a conexão com a balança. Verifique os parâmetros cadastrados.'); end; Função OnLePEso SetRespostaBalanca('Resposta da Balança: ' + String(resposta)); if (not FBalancaUtilizada.ByteInicial.IsNull) and (not FBalancaUtilizada.ByteFinal.IsNull) then begin if (FBalancaUtilizada.ByteInicial.ValueOrDefault >= FBalancaUtilizada.ByteFinal.ValueOrDefault) then raise EKorpMensagem.Create('Atenção! O Byte inicial não pode ser maior ou igual que o Byte final.'); tamanhoByte := FBalancaUtilizada.ByteFinal.ValueOrDefault - FBalancaUtilizada.ByteInicial.ValueOrDefault; unidadesInteiras := Trunc(Log10(FBalancaUtilizada.LeituraMaxima.Value)); palavraCapturada := Copy(String(resposta), FBalancaUtilizada.ByteInicial.ValueOrDefault, tamanhoByte); SetRespostaBalanca('Resposta da Balança:' + sLineBreak + String(resposta) + sLineBreak + 'Palavra capturada:' + sLineBreak + palavraCapturada); respostaTratada := Copy(palavraCapturada, 1, unidadesInteiras) + ',' + Copy(palavraCapturada, unidadesInteiras + 1, length(palavraCapturada)); FPeso := DecimalRoundDbl(StrToFloatDef(respostaTratada,0), FBalancaUtilizada.Precisao.ValueOrDefault); end else FPeso := peso; if not(FPeso > 0) then begin parteInteiraPeso := Trunc(FACBrBAL1.UltimoPesoLido); case parteInteiraPeso of 0: mensagem := 'Atenção! Não foi possível ler o peso da balança. Verifique os parâmetros cadastrados.'; -1: mensagem := 'Atenção! Peso instável, tente novamente.'; -2: mensagem := 'Atenção! Peso negativo.'; -9: mensagem := 'Atenção! Tempo de resposta expirado.'; -10: mensagem := 'Atenção! O peso excede a capacidade da balança.'; else mensagem := 'Atenção! Não foi possível ler o valor: [' + palavraCapturada + ']. Verifique a configuração da balança.'; end; raise EKorpMensagem.Create(mensagem); end; Função LerPeso Result := 0; if Assigned(FBalancaUtilizada) then begin FACBrBAL1.LePeso(timeOut); Result := FPeso; end; Possuo o seguinte LOG da balança onde é possível observar na pesagem de 12:05 o resultado correto feito no módulo de configuração e na pesagem de 12:07 o retorno -9 no último peso lido, essa leitura foi feita no módulo de produção. logbalanca
  21. Prezados, após analisar acabei identificando um possível problema na função LerRetorno240 do banco caixa rCedente := trim(Copy(ARetorno[0],73,30)); rAgencia := trim(Copy(ARetorno[0],53,5)); rConta := trim(Copy(ARetorno[0],59,5)); rDigitoConta := Copy(ARetorno[0],64,1); Nas linhas de rAgencia e RdigitoConta, ambas não estão levando em conta quando o código do cedente possuir 7 dígitos assim como a geração de remessa já faz
  22. Opa, tudo bem e você? só gostaria de confirmar uma informação a Remessa que seria no padrão CNAB e enviada para o banco para o mesmo fazer o registro do boleto correto? utilizando o registro online via WebService eu pulo essa etapa do CNAB e registro o boleto via WebService correto?
  23. Prezados(a), Andei verificando alguns post sobre transmissão automática de boleto, Neste tópico vi que tem uma contribuição final de um membro, porem somente para o banco da caixa, também notei que não tem nada relacionado a este projeto ou semelhante no repositório SVN, Existe algum outro projeto que atenda mais bancos ?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.