Jump to content

Search the Community

Showing results for tags 'abaco'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Categories

There are no results to display.

Forums

  • Fórum Aberto - ACBr
    • ACBr News
    • Equipamentos testados
    • Base de Conhecimento
    • Dúvidas Gerais sobre o ACBr
    • ACBrSerial
    • ACBrSAT
    • ACBrNFe
    • ACBrDFe
    • Dúvidas sobre TEF
    • ACBrMonitor PLUS
    • ACBrTXT
    • ACBrBoleto
    • ACBrDiversos
    • ACBrTCP
    • ACBrFramework
    • ACBrLIB
  • ACBr Pro
    • Dúvidas gerais
    • ACBrMonitorPLUS
    • NFe/NFCe - Nota Fiscal Eletrônica
    • DFe - Documentos Fiscais Eletrônicos
    • SAT / MFE
    • TEF
    • Boleto
    • ACBrSPED
    • ACBrTXT
    • Paf-ECF
    • Requisitos Fiscais por UF
    • ACBrLIB
  • Outros Assuntos
    • ACBr's Pub
    • Legislação Fiscal e Tributária
    • Object Pascal - Delphi & Lazarus
    • Data Base
    • Classificados
    • Dúvidas não relacionadas ao ACBr

Categories

  • ACBr Pro
    • ACBrLib - PRO
    • ACBrMonitorPLUS - PRO
    • Utilitários - PRO
    • Dia do ACBr 1a edição
    • Dia do ACBr 2a edição
  • Free Download
    • ACBrLib - DEMO
    • ACBrMonitorPLUS - DEMO
    • Demos / Testes / Utilitários
    • Apresentações - Palestras

Calendars

  • Eventos - Palestras - Webinars
  • Prazos SEFAZ
  • Community Calendar
  • ACBr Papo Pro
  • Feriados Nacionais

Blogs

  • Daniel Simoes' Blog
  • André Ferreira de Moraes
  • Moderadores ACBr
  • Notícias do ACBr

Categories

  • Suporte Pago - PRO
    • Webinars
    • Video Aulas
  • Vídeos Abertos
    • Video Aulas
    • Comunicados
    • Dia do ACBr 1a Ediçao
    • Dia do ACBr 2a Ediçao
    • Dia do ACBr 3a Ediçao
    • Equipamentos Homologados ACBr
    • TEF ACBr PayGo
  • Campanhas promocionais

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL

Found 24 results

  1. Boa tarde @Italo Giurizzato Junior, Seguem ajustes ( ACBr001.zip ) no ACBrNFSeX para Varzea Grande/MT, provedor Abaco. 1. Não estava assinando o lote * Habilitei o ConfigAssinar.LoteRps para o provedor * Anexo ( xmls_antes_e_depois.zip ) contendo xmls antes e depois da alteração, gerados no programa exemplo para validação 2. O link requer o Valor dos Serviços como parâmetro, além do número da NFSe que também não era passado * Implementei a passagem do AValorServico como string na LinkNFSe * Corrigi os links de produção e homologação no ACBrNFSeXServicos.ini * Anexo ( ACBR_001.png ) destacando o link corrigido xmls_antes_e_depois.zip ACBr001.zip
  2. Italo Erro ao validar XML NFSe Provedor Abaco Canoas - RS Hoje atualizei os fontes, mas o erro continua. Esta dando este erro na hora de transmitir, mesmo usando o Demo do ACBr [Content] Método..... : Enviar Lote Código Erro : CM01 Mensagem... : SERIAL=13869707,CNPJ=88009030000100, URI=#LOTE0005952 Documento invalido! Correção... : Documento nao pode ser validado, verifique assinatura e se arquivo nao sofreu alteracao Provedor... : Abaco Método..... : Enviar Lote Código Erro : E402 Mensagem... : Nao foi possivel validar o schema XSD e a assinatura do arquivo Correção... : Entrar em contato com suporte e informar mensagens de erro. Provedor... : Abaco 44280-nfse.xml
  3. Bom dia senhores, estou tentando fazer qualquer tipo de consulta usando o demo da nfse, aqui em rondonopolis usando o servidor da abaco ERRO: Erro Interno: 0 Erro HTTP: 0 O sistema não pode encontrar o arquivo especificado. - URL:https://www.nfserondonopolis.com.br/e-nfs_roo/servlet/aconsultarnfseporrps?wsdl - SOAPAction:http://www.e-nfs.com.br/action/ACONSULTARNFSEPORRPS.Execute se eu mandar consultar novamente o erro muda a mensagem ERRO: Erro Interno: 0 Erro HTTP: 0 O buffer do usuário não é válido para a operação solicitada. - URL:https://www.nfserondonopolis.com.br/e-nfs_roo/servlet/aconsultarnfseporrps?wsdl - SOAPAction:http://www.e-nfs.com.br/action/ACONSULTARNFSEPORRPS.Execute 11-con-nfse-rps.xml 11-con-nfse-rps-soap.xml
  4. Pessoal, fui implementar envia pelo provedor Abaco num cliente de Canoas/RS e ocorria esse erro: "Erro não especificado" Pesquisando, vi que o motivo era por estar usando como identificador da assinatura o atributo 'id', mas no processo de assinatura é procurado o atributo 'Id', com o 'i' maiúsculo. Alterei no Abaco.xml para que fosse usado 'Id' ao invés de 'id', até assinou, mas ocorreu erro porque no schema está definido como 'id'. E pelo que vi nas minhas pesquisas não adianta alterar nos schemas, porque dai o erro ocorreria no webservice. Decidi então retirar o identificador, deixando vazio no arquivo Abaco.ini Fazendo isso o envio ficou correto, não tive mais problemas. Minha dúvida: alguém mais conseguiu essa solução? Ela é correta? Se sim, então podem ajustar no provedor o arquivo Abaco.ini?
  5. Efetuei os testes de acordo com o tópico do David Bandeira no SAC: Talvez na data que ele testou, foi necessário alterar o NameSpace no arquivo Abaco.ini. Fiz os testes e não foi necessário. Mas ao enviar usando a unit ACBrNFSeWebServices.pas atual ocorre o erro: <MensagemRetorno> <Codigo>1</Codigo> <Mensagem>XML Inválido - ORA-19030: Method invalid for non-schema based XML Documents.</Mensagem> <Correcao/> </MensagemRetorno> Fiz a seguinte alteração: procedure TNFSeWebService.InicializarTagITagF; begin // Inicializa a TagI case FPLayout of LayNfseRecepcaoLote: begin case FProvedor of proAbaco: begin //Manaus if (FPConfiguracoesNFSe.Geral.CodigoMunicipio = 1302603) then FTagI := '<'+FTagGrupo+'>' //Outros else FTagI := '<' + FTagGrupo + FNameSpaceDad + '>'; end; Com isso o LOTE foi enviado com sucesso. Usei libWinCrypt com as configurações padrões. A consulta do processamento do LOTE ocorre normalmente.
  6. Prezados, A Ábaco perdeu o contrato com Cachoeiro do Itapemirim para a E&L. Até aí tudo bem. No entanto, a versão adotada será em um novo padrão da ABRASF o 2.04. A interrupção será de 16/03 a 19/03. Já voltando em 19/03 com a E&L. Estou implementando as alterações. Como não estou fazendo para Delphi, quem quiser acompanhar o andamento pode verificar no link abaixo: https://comunidade.opennfse.com.br/t/alteracao-no-provedor-do-webservice-cachoeiro-do-itapemirim/123 Depois se alguém se dispor em implementar para o ACBR fica mais fácil.
  7. Boa tarde a todos. Poderiam me dar uma ajuda, estou implementando a NFSe para o Provedor Ábaco cidade de Rondonopolis/MT, no xml exemplo que e disponibilizado no portal da cidade, o arquivo do envio do lote e assinado no lote e nos Rps. Consultando aqui no forum cheguei ao arquivo ini do provedor da Abaco, na parte do Assinar RPS e Lote, teoricamente eu devo deixar os dois ativos (1), porem quando o faço deixando ambos como valor 1, ele so assina o rps e deixa o lote sem assinatura. Alguém mais esta com o mesmo problema.
  8. Olá, atualmente os servidores de recepção da nfse de Cachoeiro de Itapemirim sofreu alteração de endereços. Não estou sabendo quais as modificações devo fazer no arquivo Abaco.ini, se alguém puder me dar um help, agradeço! esse é o endereço antigo: http://www.e-nfs.com.br/cachoeiro/servlet/arecepcionarloterps?wsdl mudou para: https://nfse.cachoeiro.es.gov.br/cachoeiro/servlet/arecepcionarloterps?wsdl preciso saber quais as sessões que modifico no Abaco.ini, se é somente em [URL_P] e [URL_H], ou em todo o arquivo modifico a url base, ou tem mais algum detalhe? Abaco.ini
  9. Boa tarde, estou implementando a NFS-e para rondonópolis, MT, gero o RPS com o valor do ISS e aliquota corretamente, mas ao receber a NFS-e da prefeitura, a nota não vem com o valor do ISS nem com a alioquota. Alguém já passou por isso? em anexo o XML do RPS e da NFS-e retornada pela prefeitura 146A-rps.xml 68A-nfse.xml
  10. Boa tarde. Para a prefeitura de Canoas - RS não é permitido a impressão da NFS-e pelo sistema do contribuinte, portanto é utilizado um link para acessar a NFS-e do sistema da prefeitura e fazer a impressão. Ao utilizar a função: LinkNFSe do componente ACBrNFSe, percebi que no arquivo Abaco.ini não estava preenchida as tags do grupo: [LinkNFSe]. Fiz o preenchimento do mesmo e encaminhei em anexo. Após preencher as tags do arquivo ini deve-se utilizar a função da seguinte forma: ACBrNFSe.LinkNFSe( Nro_Nota, StringReplace( FormatFloat( '0.00', VLR_TOTAL_NOTA ), ',', '.', [] ) + ',' + Nro_Nota + ',' + CODIGO_VERIFICACAO ); O resultado da função será: Produção: https://www.e-nfs.com.br/e-nfs_canoas/servlet/wvalidarautenticidadenfse?99999999000191,155.75,699,E12B.7FB0.974B Homologação: http://homologa.e-nfs.com.br/canoas/servlet/wvalidarautenticidadenfse?99999999000191,155.75,699,E12B.7FB0.974B lembre-se de preencher a a propriedade: ACBrNFSe.Configuracoes.Geral.Emitente.CNPJ := 99999999000191; Abaco.ini
  11. Estou transmitindo NFSe normalmente em ambiente de homologação, só que ao consultar o lote através do protocolo e numero do lote obtenho a seguinte mensagem de erro: Codigo: E403 Mensagem: Lote de RPS recebido e foram detectados erros ao processar. Correção: Recuperar a relação dos erros. A dúvida é como recuperar essa relação de erros. Alguém já passou por essa situação? Sabe o que pode ser? O provedor é Abaco, cidade de Rondonópolis/MT. Grato!
  12. Boa tarde!!! Desde o dia 17/07/2017 a Prefeitura de Varzea Grande - MT trocou o Provedor de NFS-e , que antes era "Betha", para "Ábaco". Gostaria de Saber quando sera disponibilizado as Alteracoes referentes no GitHub ? Anexo Manual e Novos Links disponibilizados pela Abaco! Arquivos Abaco.rar
  13. Olá pessoal. O provedor ABACO para emissao de NFSe possui no cabeçalho do XML a variavel "VersaoDados" do tipo alfanumerico e não do tipo convencional float 2.01 / 1.0, a Abaco utiliza "V2010" isso gera erro ao montar o xml na unidade "ACBrNFSeNotasFiscais" nessa linha abaixo FNFSeW.NFSeWClass.VersaoDados := StringToFloat(Configuracoes.Geral.ConfigXML.VersaoDados); Tive que retirar o "StringToFloat" isso resolve o problema, seria conveniente que o tipo dessa variavel fosse string.
  14. Amigos, sei que já existe um tópico sobre isso mas é de 2013 e acredito eu ainda usando trunk, inclusive postei essa dúvida lá. Mas por ser muito antiga resolvi criar esse tópico e se os moderadores acham por bem exclui-lo assim devem fazê-lo. Estou com o ACBR totalmente atualizado e ao tentar enviar NFSe para Cachoeiro de Itapemirim em modo de homologação, aparece a mensagem abaixo. Alguém sabe me dizer o que está acontecendo. "Erro ao ajustar INTERNET_OPTION_CLIENT_CERT_CONTEXT: 12406" Com o mesmo certificado eu consigo emitir NFe normalmente.
  15. Boa tarde! Compartilhando com o pessoal caso encontrem este problema: Hoje pela manhã, alguns clientes relataram que não conseguiam enviar as notas de serviço para o servidor da prefeitura de Canoas/RS. Em contato com o pessoal da prefeitura, fui informado que o endereço mudou de https para http ontem a tarde, sem divulgação no site da prefeitura. Caso tente transmitir para o endereço com https, irá retornar o erro 500. Alterei o arquivo Abaco.ini como segue: [URL_P] RecepcaoLoteRPS=http://www.e-nfs.com.br/%NomeURL_P%/servlet/arecepcionarloterps?wsdl ConsultaSitLoteRPS=http://www.e-nfs.com.br/%NomeURL_P%/servlet/aconsultarsituacaoloterps?wsdl ConsultaLoteRPS=http://www.e-nfs.com.br/%NomeURL_P%/servlet/aconsultarloterps?wsdl ConsultaNFSeRPS=http://www.e-nfs.com.br/%NomeURL_P%/servlet/aconsultarnfseporrps?wsdl ConsultaNFSe=http://www.e-nfs.com.br/%NomeURL_P%/servlet/aconsultarnfse?wsdl CancelaNFSe=http://www.e-nfs.com.br/%NomeURL_P%/servlet/acancelarnfse?wsdl E voltou a enviar normalmente as notas.
  16. Bom Dia Estou tentando transmitir uma NFSe em homologação, porém após enviar o RPS através do método Enviar, ao Consultar o Lote informando número do lote e protocolo é exibida a mensagem: Código: E403 Mensagem: Lote de RPS recebido e foram detectados erros ao processar. Correção: Recuperar a relação dos erros Como recuperar essa relação de erros, alguém sabe? Utilizo o provedor ABACO, prefeitura de Canoas/RS Agradeço desde já!
  17. Senhores, Quando estava implementando uma rotina para emissão de NFSe para o município de Rondonópolis/MT, que utiliza o provedor Ábaco, tive que alguns problemas e acabei realizando algumas alterações em relação as URLs no arquivo Abaco.ini para que funcionasse. Após as alterações está 100% funcionando! Original: [URL_P] RecepcaoLoteRPS=https://www.e-nfs.com.br/%NomeURL_P%/servlet/arecepcionarloterps?wsdl ConsultaSitLoteRPS=https://www.e-nfs.com.br/%NomeURL_P%/servlet/aconsultarloterps?wsdl ConsultaLoteRPS=https://www.e-nfs.com.br/%NomeURL_P%/servlet/aconsultarnfseporrps?wsdl ConsultaNFSeRPS=https://www.e-nfs.com.br/%NomeURL_P%/servlet/aconsultarsituacaoloterps?wsdl ConsultaNFSe=https://www.e-nfs.com.br/%NomeURL_P%/servlet/aconsultarnfse?wsdl CancelaNFSe=https://www.e-nfs.com.br/%NomeURL_P%/servlet/acancelarnfse?wsdl GerarNFSe= RecepcaoSincrono= SubstituiNFSe= [URL_H] RecepcaoLoteRPS=http://homologa.e-nfs.com.br/%NomeURL_H%/servlet/arecepcionarloterps?wsdl ConsultaSitLoteRPS=http://homologa.e-nfs.com.br/%NomeURL_H%/servlet/aconsultarloterps?wsdl ConsultaLoteRPS=http://homologa.e-nfs.com.br/%NomeURL_H%/servlet/aconsultarnfseporrps?wsdl ConsultaNFSeRPS=http://homologa.e-nfs.com.br/%NomeURL_H%/servlet/aconsultarsituacaoloterps?wsdl ConsultaNFSe=http://homologa.e-nfs.com.br/%NomeURL_H%/servlet/aconsultarnfse?wsdl CancelaNFSe=http://homologa.e-nfs.com.br/%NomeURL_H%/servlet/acancelarnfse?wsdl GerarNFSe= RecepcaoSincrono= SubstituiNFSe= Alterado para: [URL_P] RecepcaoLoteRPS=https://www.e-nfs.com.br/%NomeURL_P%/servlet/arecepcionarloterps?wsdl ConsultaSitLoteRPS=https://www.e-nfs.com.br/%NomeURL_P%/servlet/aconsultarsituacaoloterps?wsdl ConsultaLoteRPS=https://www.e-nfs.com.br/%NomeURL_P%/servlet/aconsultarloterps?wsdl ConsultaNFSeRPS=https://www.e-nfs.com.br/%NomeURL_P%/servlet/aconsultarnfseporrps?wsdl ConsultaNFSe=https://www.e-nfs.com.br/%NomeURL_P%/servlet/aconsultarnfse?wsdl CancelaNFSe=https://www.e-nfs.com.br/%NomeURL_P%/servlet/acancelarnfse?wsdl GerarNFSe= RecepcaoSincrono= SubstituiNFSe= [URL_H] RecepcaoLoteRPS=http://homologa.e-nfs.com.br/%NomeURL_H%/servlet/arecepcionarloterps?wsdl ConsultaSitLoteRPS=http://homologa.e-nfs.com.br/%NomeURL_H%/servlet/aconsultarsituacaoloterps?wsdl ConsultaLoteRPS=http://homologa.e-nfs.com.br/%NomeURL_H%/servlet/aconsultarloterps?wsdl ConsultaNFSeRPS=http://homologa.e-nfs.com.br/%NomeURL_H%/servlet/aconsultarnfseporrps?wsdl ConsultaNFSe=http://homologa.e-nfs.com.br/%NomeURL_H%/servlet/aconsultarnfse?wsdl CancelaNFSe=http://homologa.e-nfs.com.br/%NomeURL_H%/servlet/acancelarnfse?wsdl GerarNFSe= RecepcaoSincrono= SubstituiNFSe= Uma observação também é que para emitir no ambiente de homologação, deve-se alterar a chave UseSSL=0, pois o mesmo não é seguro. Em anexo estou disponibilizando o arquivo Abaco.ini alterado, caso o @Italo Jurisato Junior ou o @Juliomar Marchetti desejem alterar no repositório. Abaco.ini
  18. Pessoal estou enfrentando problemas ao enviar uma nota de teste pelo sistema DEMO de NFSE, o mesmo me retorna que o servidor não pode ser encontrado, alguém já passou por isto?. Não é problema no provedor pois acesso o portal de homologação e consigo emitir nota normalmente com os meus dados.
  19. Boa tarde, A nota fiscal de serviço para o provedor Ábaco não possui a configuração de tentativas de envio da nota fiscal. Motivo: Caso esteja lento o processamento do lote RPS, não é possível obter o retorno do site com o código de verificação. Alguem já passou por esta situação em a nota constar no site da prefeitura e não ser possivel obter o xml de resposta?
  20. Senhores, Em uma pesquisa sobre o ambiente de homologação da NFSe da cidade de Rondonópolis me deparei com a seguinte linha (nº 117) no arquivo ACBrProvedorAbaco.pas: ConfigURL.HomNomeCidade := 'roo'; Acho que o correto seria ConfigURL.HomNomeCidade := 'rondonopolis' ; Fiz testes aqui e com 'roo' não encontra o url e com 'rondonopolis' funciona normalmente. Gostaria que verificassem minha informação, e caso seja procedente, que a alteração seja efetuada. Grato, Wanderson P. Freitas
  21. Boa tarde, Esta semana o provedor Abaco realizou uma alteração no servidor exigindo que o arquivo xml fosse assinado. Ao enviar a NFSe esta gerando o seguinte erro: The external object throws an exception. Alguem sabe que erro é este?
  22. Olá. Hoje um cliente retonou uma mensagem de erro ao consultar uma NFSe: The handle is in the wrong state for the requested operation - URL:https://www.e-nfs.com.br/cachoeiro/servlet/aconsultarsituacaoloterps?wsdl - SOAPAction:http://www.e-nfs.com.braction/ACONSULTARSITUACAOLOTERPS.Execute. Achei estranho, no segundo link, o "br" não ser separado do "action" por "/". Dentro do provedor Abaco, a função GetSoap não foi alterada. Grato.
  23. Olá. Ao enviar uma NFSe com o cliente sendo a prefeitura da minha cidade, eu tenho que informar o ValorISSRetido, só que o valor de ISS é zero pois o produto não possui imposto. Quando eu transmito a NFSe, ele me retorna erro: 173 - CAMPO VALORISSRETIDO INFORMADO INCORRETAMENTERPS: 173 - CAMPO VALORISSRETIDO INFORMADO INCORRETAMENTE / Segue em anexo o XML gerado. 000000173-env-lot.xml
  24. Olá. Ao enviar uma NFSe com o cliente sendo a prefeitura da minha cidade, eu tenho que informar o ValorISSRetido, só que o valor de ISS é zero pois o produto não possui imposto. Quando eu transmito a NFSe, ele me retorna erro: 173 - CAMPO VALORISSRETIDO INFORMADO INCORRETAMENTERPS: 173 - CAMPO VALORISSRETIDO INFORMADO INCORRETAMENTE / Segue em anexo o XML gerado.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.