Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

Miro Callai

Membros
  • Content Count

    56
  • Joined

  • Last visited

Community Reputation

2 Neutral

About Miro Callai

  • Rank
    Membro
  • Birthday 01/15/1979

Contact Methods

  • Website URL
    http://www.timetecnologia.com.br

Profile Information

  • Sexo
    Masculino
  • Location
    Porto Alegre - RS - Brasil

Recent Profile Visitors

910 profile views
  1. Por favor Daniel, não faça isso. Não remova este componente, ele ajuda muito!
  2. Sim Envio o mesmo arquivo .xml da forma que foi gerado em contingênca
  3. Olá Isabelle, apesar do Post ser antigo, deixo aqui minha contribuição. Para alterar as margens em Run Time você pode fazer assim: 1º É necessário ter o Fast Report Edição Professional ou Enterprise, pois com a Edição Standart (que vem junto com o DELPHI) não é possível. 2º Codigo: frxReport1.Variables['MARGEM_ESQ'] := '0.00'; frxReport1.Variables['MARGEM_SUP'] := '0.00'; frxReport1.PrepareReport(); frxReport1.ShowReport; 3º No arquivo Report > Aba Codigo Page1.LeftMargin := <MARGEM_ESQ>; Page1.TopMargin := <
  4. Tive o problema mencionado aqui e resolvi facilmente com este código do colega Edu. É necessário declarar: USES Registry
  5. Bom dia. Se você está utilizando o DEMO, olhe a Procedure TfrmDemo_ACBrNFSe.ConfiguraComponente Nessa parte ACBrNFSe1.Configuracoes.WebServices.ProxyHost := edtProxyHost.Text; ACBrNFSe1.Configuracoes.WebServices.ProxyPort := edtProxyPorta.Text; ACBrNFSe1.Configuracoes.WebServices.ProxyUser := edtProxyUser.Text; ACBrNFSe1.Configuracoes.WebServices.ProxyPass := edtProxySenha.Text;
  6. Bom dia. Utilizo o componente ACBrDownload a bastante tempo, mas a alguns dias percebi que não consigo mais mostrar o percentual do download! Parece que o parametro Reason não entra em HR_ReadCount Parece que sai direto de HR_Connect para HR_SocketClose procedure TForm1.HookStatus(Sender: TObject; Reason: THookSocketReason; const BytesToDownload, BytesDownloaded: Integer); begin case Reason of HR_Connect : begin ProgressBar1.Position := 0; bDownload.Enabled := False; bPause.Enabled := True; bStop.Enabled
  7. No meu caso, eu estava passando as configurações de PROXY por engano. E como no meu caso não existe PROXY então o componente apresentou esse erro.
  8. Boa tarde Pessoal. Problema resolvido! O Erro na verdade era de configuração do componente. Estavam sendo passados dados errados ao componente, mais precisamente referente a PROXY, que no meu caso nem deveriam ser informadas! Graças a ajuda do Italo, foi identificado o problema. Obrigado Italo, como sempre disposto a nos ajudar.
  9. Boa tarde Italo. Se não for abusar da tua ajuda, se eu te enviar um certificado, tu poderia fazer um teste ai pra termos certeza de que o problema é aqui? Pois testei em 2 Computadores, que recém foram formatados e, apenas instalamos o Delphi e demais ferramentas para desenvolvimento e nada mais, e inclusive testei usando operadoras de internet diferentes ,e em ambos os computadores conseguimos usar a o ACBrNFe normalmente e temos o mesmo erro na NFSe.
  10. Bom dia Italo, as 2 opções referentes a revogação já estavam desmarcadas, fiz a alteração para SSL 3.0 Mas o erro continua.
  11. Boa Tarde Italo. Sim, instalei, e não funcionou também. O Xml esta certinho, inclusive validei pelo Portal da Nota Legal (Porto Alegre) e foi aprovado e conseguentemente gerou Nota Fiscal. Resumindo o problema esta apenas quando o Componente tenta enviar, aqueles espaços entre os caracteres da assinatura que mencionei aparecem apenas na exceção que o Delphi levanta. Na verdade, não apenas quando tenta enviar, mas qualquer procedimento que faça conexão com o Webservice, resulta no mesmo erro!
  12. Bom dia Italo, se eu te enviar um certificado digital daqui , você teria como fazer um teste ai? Pois ainda estou com o mesmo erro.
  13. Italo, boa noite. Eu achei essas 2 informações que talvez ajudem a me ajudar. 1º Salvei o log do Delphi e no final do arquivo notei que a mensagem de erro tem mais informações do que eu postei aqui. A mensagem completa passa a impressão que ao montar a TAG <X509Data> traz espaços em branco entre os caracteres. 'Erro: Requisição não enviada. Erro: 12152 - k M k 4 n P V J L z i g k Q Q 6 h Z y 5 C L J J r R k i Z 7 t P B b q J + 1 H G 9 d V N V 7 / m f q i p 9 g P p p C 2 X 8 v c z 4 N B 8 I r O C Q C p y G 7 0 j J 0 T 7 g A v / V j e o 4 p H a l
  14. Boa tarde Italo, vou seguir suas recomendações. Mas se eu não estou enganado, caso algumas das configurações citadas estive atrapalhando o envio, não teria de ocorrer o mesmo com a NFe?
×
×
  • Create New...