Jump to content

click.png

click.png

click.png

click.png

click.png

click.png

click.png click.png click.png

click.png

click.png

click.png

click.png

click.png

click.png

Abimael

Membros
  • Posts

    15
  • Joined

  • Last visited

1 Follower

Contact Methods

  • Website URL
    lojafacil.com.br

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Abimael's Achievements

Apprentice

Apprentice (3/14)

  • First Post
  • Collaborator Rare
  • Conversation Starter
  • Week One Done
  • One Month Later

Recent Badges

11

Reputation

  1. Olá a todos, estou com uma dúvida referente a informação no xml quando cliente for simples nacional com excesso de sublimite. Na NF-e já fiz as devidas alterações informado no CRT o valor 2, e esta saindo com os dados corretamente. Porém dei uma pesquisada e fiquei meio confuso quanto a informar isso no SAT. Pois olhando o fonte do ACBr pelo que entendi o próprio SAT que identifica a situação do cRegTrib, e informa isso no xml. Sendo assim queria saber se alguém poderia me informar se quando for SAT devo ou não informar o cRegTrib = 2 quando for SN com excesso de sublimite.
  2. Publicada versão 1.61 da NT 2016.002 documentando correções de erros implementadas pelas SEFAZ Autorizadoras. Fonte: http://www.nfe.fazenda.gov.br/portal/informe.aspx?ehCTG=false#518
  3. Espero que sim Felipe, realmente pelo que eles falaram houve outros casos parecidos. Bem nos resta só esperar agora. Se quiser fechar o tópico pode fechar. Obrigado
  4. Eu testei em 3 maquinas diferentes e nestas máquinas, mesmo instalando os drives e o gerenciador do certificado, não aparecia o certificado pra selecionar nestes 3 computadores testado, porém no gerenciador do certificado aparecia, dava pra realizar teste pelo gerenciador normalmente, mas na aba conteúdo das opções de internet onde vejo os certificados instalados não aparecia. Entrando em contato com o suporte nível 2 da certisign foi informado que o certificado estava corrompido e teria que comprar um novo, porém ao colocar o certificado na máquina da cliente novamente, não sei se é por que la estava instalado anteriormente ele aparecia na lista de certificados e abria o site do ECac normal. Entrado em contato com o suporte da certisign novamente eles verificaram e informaram que o certificado fazia parte de um lote de 2016/2017 que estava com problema mesmo e eles mesmo vão enviar um novo certificado. Cada uma né, bom vamos ver o novo se dará tudo certo, espero que sim! Pra caso alguém venha a ter o mesmo problema, o certificado era um modelo A3, utilizando o leitor de cartão PC USB-TRGemalto, o cartão é aquele cinza que é gerenciado pelo AWP Manager - Oberthur - Gerenciador Criptográfico.
  5. Boa tarde pessoal, Estou tendo um problema na emissão de NF-e referente ao certificado digital. Meu cliente usa um certificado A3, com a leitora de cartão. Estou usando a Capicom.dll para comunicar com o certificado, porém ao selecionar o certificado apresentava a mensagem de erro "Tipo de provedor inválido especificado.". Eu verifique que isso se deve ao certificado estar configurado como CNG e não CSP. Eu tentei mudar pra usar o ACBrDFeWinCrypt ao invés da Capicom.dll de acordo com o tópico: Configurei tudo corretamente, e testei na minha máquina com um certificado A1 e transmite normalmente, porém com o certificado A3 do cliente não vai, apresenta sempre o erro: "Falha em obter Provedor de Criptografia do Certificado. Erro:80090014". Procurando aqui no fórum achei o tópico Porém mesmo com os fontes todos atualizados apresenta a mesma mensagem de erro. Como não da pra debugar, fui colocando uns showmessage, vi que ele identifica que é um certificado CNG corretamente, tanto que chama as funções referente ao CNG contidas no pas ACBrDFeWinCrypt , porém ele para na função "TDFeWinCrypt.CalcHash". Especificamente na seguinte parte: // TODO: Adicionar suporte a certificados CNG // Obtendo o Contexto do Provedor de Criptografia do Certificado // if CryptAcquireCertificatePrivateKey( FpCertContext, 0, Nil, mCryptProviderCert, dwKeySpec, pfCallerFreeProv) then begin ...... Nessa parte ele pula para o Else e apresenta o erro. Queria saber se realmente nao tem implementação pra certificados do tipo CNG. Ou se alguém tem uma outra solução como por exemplo achei um link que ele muda o tipo de CNG para CSP, porém parece ser especifico pra outro modelo de token, e o da minha cliente não funciona: http://conhecimento.alterdata.com.br/ar/kblive.php?action=showEntry&data=1971
  6. Aqui em produção passou normal informando Cobr.Fat.vDesc := 0.001; E baixei o schemas do portal nfe: http://www.nfe.fazenda.gov.br/portal/exibirArquivo.aspx?conteudo=CoNA9VIgZ3E= Porém em homologação continua a rejeição 905 Mesmo informando os grupos corretamente <cobr> <fat> <nFat>6040001</nFat> <vOrig>30.00</vOrig> <vDesc>0.00</vDesc> <vLiq>30.00</vLiq> </fat> <dup> <nDup>001</nDup> <dVenc>2018-10-03</dVenc> <vDup>10.00</vDup> </dup> <dup> <nDup>002</nDup> <dVenc>2018-11-05</dVenc> <vDup>10.00</vDup> </dup> <dup> <nDup>003</nDup> <dVenc>2018-12-03</dVenc> <vDup>10.00</vDup> </dup> </cobr> <pag> <detPag> <indPag>1</indPag> <tPag>15</tPag> <vPag>10.00</vPag> </detPag> <detPag> <indPag>1</indPag> <tPag>15</tPag> <vPag>10.00</vPag> </detPag> <detPag> <indPag>1</indPag> <tPag>15</tPag> <vPag>10.00</vPag> </detPag> </pag>
  7. Sandro, eu estava com o mesmo problema, mudando pro valor vDesc := 0.001. Ele envia a tag. não sei se é algo no AcBr, só sei que assim funciona! Não esqueça de atualizar a schemas também.
  8. Publicada versão 1.60 da NT 2016.002 e pacote de schemas XML correspondente A versão 1.60 da NT 2016.002 posterga o prazo de desativação da versão 3.10 em 30 dias, define novos prazos para validação do QR-Code da NFC-e, entre outras alterações. http://www.nfe.fazenda.gov.br/portal/exibirArquivo.aspx?conteudo=Y6Lj7G0uHwc=
  9. Boa tarde pessoal, não sei se esta com essa dificuldade em outros estados, em SP não estou, mas para o Acre, quando emito uma NFC-e, não consigo consultar pela chave de acesso no site http://sefaznet.ac.gov.br/nfce/consulta.xhtml. Estou usando o layout 3.10, O mais estranho é que uma NFC-e emitida em 2017 ele consulta normalmente , a nota que acabei de fazer é a 307 sempre que consulta aparece como "Nota Inexistente", agora a nota 4 emitida em 2017 aparece normalmente. eu comparei as 2 no diffChecker, https://www.diffchecker.com/diff mas não achei nada que esteja muito diferente, apenas os padrões que muda a cada nota. Alguém tem alguma sugestão? Ou sabe informar se é alguma coisa do site, preferi perguntar aqui primeiro por que geralmente a sefaz nunca tem uma resposta, ou demoram pra responder. O XML vem com retorno de numero de protocolo normalmente 12180415177582000153650010000003071000003070-nfe.xml 12171115177582000153650010000000041000000048-nfe.xml
  10. Ainda não tinha visto, muito obrigado. Vou dar uma lida. Eu fiquei pesquisando direto pelo nome da função aqui no fórum, nem pensei em pesquisar pelo refactoring do .pas. Obrgiado
  11. Foi modificado o arquivo pcnAuxiliar.pas onde eu usava a função GerarChave(...) pra gerar a chave de acesso da NF-e, queria saber sobre a mudança pois não encontrei nada nos comentários do commit, a Alteração foi feita no dia 16/02/2018 da revision 14691 apensa indicando que foi comentado algumas funções em duplicidade, no mesmo dia na revision 14699 foi retirado essas funções do código incluso essa GerarChave(..), eu fui dar um update nos fontes pra adequar a questão da validação GTIN, e começou a dar erro referente a esta função que eu uso. Gostaria de saber caso tenho feito alguma função nova ou algo do tipo
  12. Sempre Válido cara, me ajudou muito.. Estou desde manhã tentando arrumar isso. Tinha até me esquecido da schemas, deu certinho aqui valeu mesmo.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.