Jump to content

Rafael jorge

Membros
  • Posts

    248
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by Rafael jorge

  1. Estou com esse mesmo problema, hoje foi o dia inteiro assim. Ja olhei tudo e so da esse erro.
  2. Coloquei um produto adicional quando tem acréscimo chamado acres. de pag. isso solucionou temporariamente pros clientes. mas queria saber a forma correta de colocar esse acréscimo.
  3. Nosso sistema de PDV tem acréscimo quando determinada forma de pagamento é selecionado. Entao quando emitimos cupom da erro dizendo que o valor informado passa do calculado sem troco informado. ai tentei colocar o valor em voutros dessa forma with nfe.NotasFiscais[0].NFe do begin Total.ICMSTot.vBC := ICMSTotalBC; total.ICMSTot.vICMS := icmstotal; Total.ICMSTot.vProd := totalprodutos; Total.ICMSTot.vNF := (totalprodutos + acrescimo) - totalDescontos; total.ICMSTot.vDesc := totalDescontos; total.ICMSTot.vIPI := totalipi; total.icmstot.vPIS := totalpis; total.ICMSTot.vCOFINS := totalCofins; Total.ICMSTot.vTotTrib := icmstotal; total.ICMSTot.vOutro := acrescimo end; so que agora esta dando o erro "rejeição : total do voutro difere do somatório dos itens" nao achei onde colocar acréscimo no nfce. nao sei se tenho que lançar um item com o nome de acréscimo e o valor.. Gostaria de so acrescentar no total. mas nao to sabendo como resolver.
  4. Homologado com sucesso! a bronca toda era que na hora de imprimir o boleto tinha que ter 9 digitos na conta bancaria + digito. a conta do cliente nao tinha 8 dígitos. o que eu coloquei zeros a direita ate completar 8 digitos + 1 digito isso fez com que a linha digital saise sempre errada. e na hora de pagar o boleto nao identificava o boleto. entao registrava normalmente (na geração da remessa ele ajustava o tamanho) ja no boleto nao. fazendo o erro na hora de pagar o boleto com a linha digitavel errado. tudo corrigido e homologado.
  5. Apos muito tempo o safra me respondeu. A remessa esta ok. tanto que chegava a registrar. ja o boleto nao pagava. pois tinha erros no boleto em si. me mandaram isso: vou fazer os ajustes e ver no que da.
  6. é. o cliente tentou pagar o boleto e o banco nao aceitou o pagamento. mesmo usando a unit personalizada. :(
  7. Usando a unit de @windsoft o cliente registou os boletos e apareceu no gerenciador do banco. só que ele ta meio desiludido do banco safra, nao por esse problema do boleto mas por outras coisas. ai nao deu continuidade aos testes. falei com ele hoje. e ele vai quitar um boleto de teste hoje. e ver se com essa remessa foi tudo ok.
  8. Vou baixar pra testar. ta comentado as mudanças que tu fez? so pra eu dar uma olhada nos fontes?
  9. O erro é que o banco da a mensagem que o boleto nao é reconhecido ou nao registrado. so que ta la registrado no site do safra.
  10. Estou enviado remessas pro banco safra, estava funcionando, ai deu uma bronca. que foi resolvida, detalhes nesse link: Ai resolvido com a ajuda de voces. ai agora depois de um tempo do nada. as remessas sao aceitas, mas na hora de pagar nao conseguem pois o banco nao reconhece. em anexo a remessa que foi enviada e nao deu erro nenhum mas também nao tem como pagar. REMESSA_SAFRA_86.txt
  11. vou fazer isso e ajudar :) ai posto aqui as mudanças que eu fiz.
  12. Agora tô com uma dúvida. Como imprimo esse evento? Pois quando rodo o comando imprimirevento ele mostra na tela uma carta de correção com as infos zeradas.
  13. cometi um erro super basico. esqueci de atualizar os schemas de cte. apos atualizar. esta tudo funcionando. obrigado.
  14. Estou enviando o desacordo, so que esta dando o erro " 1824 element http://www.portalfiscal.inf.br/cte descevento "prestacao de servico em desacordo" is not a valid value of the local atomic type. Tentei alimentar o descEvento mas ele é somente de leitura.
  15. resolvi. o banco aceitou a remessa. mas mesmo assim ainda to tendo que em vez de passar 0029 na agencia e zero no digito. eu to tendo que passar 0290 na agencia e zero no digito. passando do jeito correto fica 00020 passando do jeito errado (0290) fica assim a agencia ao alimentar o componente : 00290 (como deve ser)
  16. na rotina de remessa modifiquei a minha rotina do meu sistema que alimenta a remessa para na agencia preencher a a gencia + digito. if acbr.Banco.TipoCobranca = cobBancoSafra then acbr.Cedente.Agencia := campocdc('conta_bancaria','codigo_agencia','codigo = '+banco.tostring, conexao, ultimo_erro)+ campocdc('conta_bancaria','digito_agencia','codigo = '+banco.tostring, conexao,ultimo_erro); obs: a rotina campocdc eu passo a tablea, o campo e o codigo do banco para pegar assim a agencia e o digito no banco de dados. desse jeito acho que vai funcionar.
  17. eu tive que deixar a agencia 0290 a agencia sao 4 digitos. a agencia nao tem digito verificador mas como é obrigado botei 0 a agencia do cliente é 0029 com digito 0 se eu alimentar o componente com 0029 na agencia ele converte para 0002 por isso tive que colocar 0290 na agencia. pelo que eu vi nos fontes ele formata pra 5 posicoes. a agencia, quando deveria ser 4 + digito verificador e nao 5 na agencia sem digito. modifiquei pra 0290 em vez de 0029 e o cliente reenviou. agora to esperando. o erro original era " posições de agência e conta no detalhe do arquivo estão fora de local das posições 18 a 31"
  18. Boa tarde, estou tento problemas com o banco safra. a ultima remessa que foi enviada foi negada. so que ja tinha enviado 64 remessas e todas passaram. a ultima que foi aceita, foi dia 5 desse mes. nao foi mudado nada. e pelo que eu to vendo os dados estao de acordo com o layouts, tanto os que foram aceitos quantos os que foram negados. estou anexando o ultimo que funcionou e o primeiro que deu negacao. tambem notei uma coisa. no caso da conta usada a agencia é a 0029 e nao tem digito ai eu passo 0. mas quando eu alimento o sistema com agencia 0029 ele automaticamente muda pra 0002 entao tive que cadastrar a conta como 0290 pra no componente tratar a agencia como 0029 a remessa 64 foi a que passou. a 65 foi a rejeitada. REMESSA_SAFRA_64.txt REMESSA_SAFRA_65.txt
  19. Troquei em todos os lugares do sistema onde eu alimentava o cNF e achei onde estava colocando o numero da nota no cNF (eu tenho uma classe que so passo os parametros para alimentar o cabecario, itens, calculos e tudo da nfce). mas tenho um form em especial que ele pega os pedidos joga pro controle do PDV e ele alimenta o nfce. e nessa tela ele colocar o numero da nota no cNF. corrigi e pronto. todas as telas que geram NFC-e no meu sistema estao 100% novamente. Fica aqui de dica pra quem tiver o mesmo problema. lembrando que tudo isso gracao ao que foi postado aqui: https://www.projetoacbr.com.br/forum/topic/51985-c%C3%B3digo-num%C3%A9rico-inv%C3%A1lido-chave-n%C3%A3o-gerada/
  20. Ate agora nao consequi resolver. esta sempre dando o erro de codigo numerico invalido, chave nao gerada. mesmo passando o cnf diferente do nnf. agora esse problema esta apena no nfc-e, mesmo eu fazendo o comando pra gerar cNF randomicamente sem usar o mesmo numero da nota esta dando isso. ja o conhecimento eletronico, manifesto e notas fiscais eu ja alterei e esta 100% funcionando so o NFC-e que nao vai.
  21. usei a rotina do GerarCodigoDFE no cnf na nota (nfe) e aparentemente esta tudo ok. vou mandar pra produção. mas pelos testes aqui esta tudo ok. so o nfce que continua dando erro. vou dar uma aprofundada e ver o que pode ser. GerarCodigoDFe
  22. Verifiquei agora. e também ao emitir nfe esta dando o mesmo erro. eu sempre coloquei o mesmo numero na nNF e cNF tanto no nfce quanto na nfe. tentei gerar um numero aleatório mas continua dando erro
  23. Estou gerando nfc-e e quando eu rodo o comando NFE.WebServices.Enviar.Executar ele me retorna o erro "lote nao pode ser enviado. erro: código numérico inválido, chave não gerada.' ai achei aqui mesmo no forum essa solucção https://www.projetoacbr.com.br/forum/topic/51985-c%C3%B3digo-num%C3%A9rico-inv%C3%A1lido-chave-n%C3%A3o-gerada/ Só que ja tentei de tudo e sempre da erro. no meu sistema estou gerando a codigo da nota e o numero da nota assim: num := NFCEgeranumero(empresa, conexao, erro); nfe.NotasFiscais[0].NFe.Ide.nNF := strtointdef(num,1); nfe.NotasFiscais[0].NFe.Ide.cNF := GerarCodigoDFe(nfe.NotasFiscais.Items[0].NFe.ide.nNF); e na hora de gerar o lote estou fazendo assim: NFE.WebServices.Enviar.Lote := nfe.NotasFiscais[0].NFe.Ide.cNF.tostring; nao sei mais o que fazer. estou meio perdido nisso.
  24. Resolvi. e que eu estava somando o valor do icms tambem no total da nota. quando so era pra somar os produtos + ipi + ipi devolvido (Certo) eu tava somando produtos + ipi + ipi devolvido + icms (Errado) ai agora ta ok.
  25. o cliente reclamou justamente que nao tava indo o ipi na nota (danfe) e que tinha que constar la. por isso coloquei. vou verificar.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.