Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

rodrigopandini

Membros
  • Content Count

    23
  • Joined

  • Last visited

Community Reputation

1 Neutral

About rodrigopandini

  • Rank
    Novato

Profile Information

  • Sexo
    Indefinido
  • Location
    none

Recent Profile Visitors

768 profile views
  1. @[email protected]@, boa tarde. Aproveitando que você está testando a questão da logo no DANFe, gostaria de saber duas coisas. 1 - Acredito que a propriedade ACBrNFe1.DANFE referencia o componente danfe do Fortes ACBrNFeDANFeRL1 no seu projeto, certo? Então neste caso, não entendi o porquê você está definindo as propriedade nos dois componentes, sendo que são o mesmo objeto. 2 - No DANFe do FortesReport, a propriedade ExpandirLogoMarca funciona corretamente? A imagem ocupa o espaço todo destinado a ela? Se sim, qual as dimensões da imagem que você está testando. Grato,
  2. Pessoal, boa tarde. Gostaria de saber se a propriedade ExpandirLogoMarca para o DANFe no FastReport (Trunk2) funciona? if FilesExists(ExtractFilePath(Application.ExeName) + 'Logos\logo_danfe.jpg') then begin ACBrNFe1.DANFE.ExpandirLogoMarca := true; ACBrNFe1.DANFE.Logo := ExtractFilePath(Application.ExeName) + 'Logos\logo_danfe.jpg'; end; Estou usando a imagem da logo com o endereço do emissor (339 x 114), portanto ela vai ocupar todo o espaço. Quando faço o teste, a imagem está muito pequena e ocupa menos da metade do espaço. Se, no caso, a propriedade não funciona para
  3. O meu caso é o mesmo do @fagner. Estou usando Delphi7, com o FastReport versão 4.12. Só está funcionando com o DANFe do FastReport da pasta obsoletos. Uso o DANFeRetrato_Basic.fr3: ACBrNFe1.Configuracoes.Arquivos.PathSchemas := ExtractFilePath(Application.ExeName) + 'Schemas\NFe'; ACBrNFeDANFEFR1.FastFile := ExtractFilePath(Application.ExeName) + 'Reports\NFe\DANFeRetrato_Basic.fr3'; ACBrNFeDANFEFR1.FastFileEvento := ExtractFilePath(Application.ExeName) + 'Reports\NFe\EVENTOS.fr3'; Ao tentar usar com os novos reports, está dando um erro meio genérico (confere a imagem) no
  4. Isaque, boa tarde. Não está desatualizado. Você pode verificar na imagem dos posts anteriores. Mas como postei no post anterior, a solução do Michel resolveu o problema. Aparentemente na criação do arquivo .INI do instalador ainda estão sendo definidas as opção para o componente GNRe. Até.
  5. Obrigado Michel. Defini para zero as linhas referentes a GNRe. ACBr_GNRE.dpk=0 ACBr_GNREGuiaFR.dpk=0 ACBr_GNREGuiaRL.dpk=0 Resolveu os problemas da instalação. Grato,
  6. Bom dia Italo, A última revisão é de agora a pouco: Excluí todos os arquivo e baixei novamente. O erro ainda persiste.
  7. Pessoal estou o mesmo problema: ACBr_GNRE.dpk(101) Fatal: File not found: 'ACBrGNRE2.dcu' Compilation failure Erro ao compilar o pacote "ACBr_GNRE.dpk". Acredito que a opção do GNRe foi removida do instalador nas últimas atualizações, porém o erro ainda continua. Então não tem como desmarcá-la no instalador. Como devo proceder? (Confira a imagem em anexo do instalador)
  8. @wllfl Não sei se é este o seu caso, mas também tive problemas ao tentar instalar os componentes do ACBr com o Fast Report as primeiras vezes com o Delphi 7. O que acontecia era o seguinte: na minha Library Path eu tinha definido o caminho para os componentes do Fast Report (e dos outros geradores de relatórios) com o uso da constante $(DELPHI), ficava assim: $(DELPHI)\Reports\Fast\FR4\LibD7 Aparentemente o Instalador do ACBr não reconhece o valor da constante $(DELPHI) e por isso dava erro na compilação e instalação dos componentes do ACBr. Então eu troquei os valores deixando com o caminho
  9. Alguém conseguiu ver essa questão? Estou pensando em alterar na mão o layout do DANFe do Fast Report, mas não sei se há alguma medida que devo seguir. Alguém sabe me informar as regras para as dimensões de cada campo no layout?
  10. Pessoal, bom dia. Estou com problema na impressão da logo no DANFe com Fast Report. Não importa como eu configuro a logo no componente, ela está sempre imprimindo com metade do campo no danfe e ainda fica os dados da empresa em texto. Coloquei ela para imprimir como expandida, mas ela não expande para o campo inteiro. Segue abaixo uma imagem de exemplo de como está ficando a exibição da impressão no preview do Fast (o pdf está do mesmo jeito também) : Exemplo do trecho de código onde defino as configurações da logo. ACBrNfe1.DANFE.Logo := 'caminho_logomarca.jpg'; ACBrNfe1.DANFE.Expand
  11. @windsoft Obrigado pelo retorno. Era isso mesmo que estava errado. Corrigi aqui e imprimiu a forma de pagamente correta no DANFE. Valeu.
  12. Bom dia amigos, Tenho uma dúvida quanto a forma de pagamento impressa no DANFE com FastReport. Emito uma nota com forma de pagamento a prazo parcelado em duas vezes. No campo Fatura aparece a mensagem "Pagamento À Vista" no canto superior direito. Logo abaixo vem a relação das duas Duplicatas da nota. Gostaria de saber se isso está correto ou tem alguma coisa que estou fazendo errado. (Confiram na imagem em anexo) Obrigado desde já.
  13. Obrigado Juliana. Vou seguir sua orientação. Por acaso você sabe me informar aonde está escrito isto na legislação? Até,
  14. No validador de registros PAF-ECF do ACBr, seguindo a ER 02.02, ao gerar os registros do PAF, está dando erro identificação do CPF/CNPJ do adquirente - registro R04. Como é cupom fiscal então não há necessidade de identificação do cliente (nome - cpf/cnpj), então estou movendo branco para os dois campos. Estou na dúvida se isto está correto ou não. Pelo exemplo do ACBr, ele sempre mandar gerar um nome e um cpf aleatório para estes campos. Como devo proceder então? Segue imagem em anexo. Grato,
×
×
  • Create New...