Jump to content

Search the Community

Showing results for tags 'sefazmg'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Categories

There are no results to display.

Forums

  • Fórum Aberto - ACBr
    • ACBr News
    • Equipamentos testados
    • Base de Conhecimento
    • Dúvidas Gerais sobre o ACBr
    • ACBrSerial
    • ACBrSAT
    • ACBrNFe
    • ACBrMonitor PLUS
    • ACBrDFe
    • ACBrTEFD e Dúvidas sobre TEF
    • ACBrTXT
    • ACBrBoleto
    • ACBrDiversos
    • ACBrTCP
    • ACBrFramework
    • ACBrLIB
    • Dia do ACBr
  • Suporte Pago - SAC
    • Dúvidas gerais
    • ACBrMonitorPLUS
    • NFe/NFCe - Nota Fiscal Eletrônica
    • DFe - Documentos Fiscais Eletrônicos
    • SAT / MFE
    • TEF
    • Boleto
    • ACBrSPED
    • ACBrTXT
    • Paf-ECF
    • Requisitos Fiscais por UF
    • ACBrLIB
  • Outros Assuntos
    • ACBr's Pub
    • Legislação Fiscal e Tributária
    • Object Pascal - Delphi & Lazarus
    • Data Base
    • Classificados
    • Dúvidas não relacionadas ao ACBr

Categories

  • ACBrLib
  • Suporte Pago - SAC
    • ACBrMonitorPLUS - SAC
    • Utilitários - SAC
    • Dia do ACBr 1a edição
    • Dia do ACBr 2a edição
  • Free Download
    • ACBrMonitorPLUS
    • Demos / Testes / Utilitários
    • Apresentações - Palestras

Calendars

  • Eventos - Palestras - Webinars
  • Prazos SEFAZ
  • Community Calendar
  • Feriados Nacionais

Blogs

  • Daniel Simoes' Blog
  • André Ferreira de Moraes
  • Moderadores ACBr
  • Teste de Blog
  • Notícias do ACBr

Categories

  • Suporte Pago - SAC
    • Webinars
    • Video Aulas
    • Palestras - Dia do ACBr 2a Ediçao
  • Vídeos Abertos
    • Video Aulas
    • Comunicados
    • Dia do ACBr 2a Ediçao
    • Dia do ACBr 1a Ediçao
  • Campanhas promocionais

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Skype


Localização


Interesses


CNPJ da Empresa


CPF

Found 3 results

  1. Olá, enfrentei um problema ao efetuar a consulta de status dos servidores da Sefaz para o estado de Minas Gerais (MG). O contexto é o seguinte: Efetuei dois testes de consulta de status dos servidores esperando o retorno 107 (cStat), um voltado para o MG e o outro para RJ. As URLs utilizadas foram as disponibilizadas no arquivo NFeServicos.ini, sendo para o MG a url https://nfe.fazenda.mg.gov.br/nfe2/services/NFeStatusServico4 e para o RJ a url www.fazenda.rj.gov.br/nfce/consulta. Percebi que ao efetuar os testes com o estado de MG, havia retorno da Sefaz porém os valores não estavam sendo setados, e para o RJ sim. Para ficar mais claro o "setado", estou me referindo a unit pcnRetConsStatServ, para a função LerXml e para a função rCampo contida na unit pcnLeitor: function TRetConsStatServ.LerXml: Boolean; var ok: Boolean; begin Result := False; try Leitor.Grupo := Leitor.Arquivo; if leitor.rExtrai(1, 'retConsStatServ' + FtagGrupoMsg) <> '' then begin Fversao := Leitor.rAtributo('versao', 'retConsStatServ' + FtagGrupoMsg); FtpAmb := StrToTpAmb(ok, Leitor.rCampo(tcStr, 'tpAmb')); FverAplic := Leitor.rCampo(tcStr, 'verAplic'); FcStat := Leitor.rCampo(tcInt, 'cStat'); FxMotivo := Leitor.rCampo(tcStr, 'xMotivo'); FcUF := Leitor.rCampo(tcInt, 'cUF'); FdhRecbto := Leitor.rCampo(tcDatHor, 'dhRecbto'); FtMed := Leitor.rCampo(tcInt, 'tMed'); FdhRetorno := Leitor.rCampo(tcDatHor, 'dhRetorno'); FxObs := Leitor.rCampo(tcStr, 'xObs'); Result := True; end; except Result := False; end; end; A estrutura de retorno é a seguinte: MG <retConsStatServ xmlns="http://www.portalfiscal.inf.br/nfe" versao="4.00"> <tpAmb xmlns="http://www.portalfiscal.inf.br/nfe">1 </tpAmb> <verAplic xmlns="http://www.portalfiscal.inf.br/nfe">W-1.4.23 </verAplic> <cStat xmlns="http://www.portalfiscal.inf.br/nfe">107 </cStat> <xMotivo xmlns="http://www.portalfiscal.inf.br/nfe">Serviço em Operação </xMotivo> <cUF xmlns="http://www.portalfiscal.inf.br/nfe">31 </cUF> <dhRecbto xmlns="http://www.portalfiscal.inf.br/nfe">2019-10-02T12:11:19-03:00 </dhRecbto> <tMed xmlns="http://www.portalfiscal.inf.br/nfe">0 </tMed> <dhRetorno xmlns="http://www.portalfiscal.inf.br/nfe">2019-10-02T12:11:19-03:00 </dhRetorno> </retConsStatServ> RJ <retConsStatServ versao="4.00" xmlns="http://www.portalfiscal.inf.br/nfe"> <tpAmb>2</tpAmb> <verAplic>SVRSnfce201805211008</verAplic> <cStat>107</cStat> <xMotivo>Servico em Operacao</xMotivo> <cUF>33</cUF> <dhRecbto>2019-10-02T12:06:49-03:00</dhRecbto> <tMed>1</tMed> </retConsStatServ> O problema é devido a diferente estrutura de retorno para cada estado, pois a função rCampo espera que a tag inicial, tag de abertura seja a tag padrão (<tpAmb>, <verAplic>, <cStat>) sem nada além. Devido a isso, quando é feito a operação para o retorno de MG, os valores das tags não são encontrados, pois além da tag inicial também há a tag/url xmlns="http://www.portalfiscal.inf.br/nfe". Para resolver o problema precisei comentar o sinal de maior ">" para que não ficasse "limitado" somente as tags padrões. Antes: inicio := pos('<' + Tag + '>', UpperCase(FGrupo)); Depois inicio := pos('<' + Tag {+ '>'}, UpperCase(FGrupo)); A partir dai conseguir prosseguir. Essa seria a melhor abordagem a ser tomada? Seria realmente a correção definitiva ? Agradeço e espero que fique claro. Obrigado.
  2. bom dia! esta me retornando erro "Código de Hash on QR-Code difere do calculado" na NFC-e em produção, este é um cliente filial, na matriz esta emitindo sem erros. em contato com a SEFAZ / MG ela me retornou o seguinte email: "De acordo com o suporte responsável, o campo qrcode no arquivo xml enviado pelo contribuinte realmente está fora dos padrões previstos no Manual de Especificações Técnicas do DANFE NFC e QRCode (anexo). Favor repassar ao contribuinte e solicitar que ele observe as instruções contidas nesse manual (especialmente a partir da página 23) para a correta geração desse campo" segue anexo xml de retorno. desde já agradeço a ajuda. 31190516994189000204650010000015179000015176-nfe.xml 20190517105449-pro-lot.xml
  3. Boa tarde, Estou tentando enviar um CTe 3.0 de subcontratação na SEFAZ de MG. Esta me retornando sempre o erro 999 na função ACBrCTe.Enviar(); O mesmo XML se eu enviar pela SVC na versão 3.0. O mesmo é autorizado sem problemas. Alguém sabe me dizer se na sefaz de MG esta com algum problema. Entrei em contato com eles, e eles não conseguiram verificar o problema. Em anexo o xml que estou tentando enviar. Obs: já alterei a tag chave para chCTe. Att. 31170303341645000186575650000003921837016549-cte.xml
×
×
  • Create New...