Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

ACBrMonitorPlus ConsultarNFe não atualiza o XML


  • Este tópico foi criado há 2398 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Estou usando o ACBrMonitorPlus e no metodo ConsultarNFe estou passando como parametro o caminho do arquivo XML, e não a chave de acesso.

Ele consulta e retorna o cStat 100 que está autorizada, mas não está atualizando o XML colocando as tags com o cStat dentro do XML.

Não teria que atualizar o XML?

Link to comment
Share on other sites

  • Consultores

Bom dia Felipe,

O caminho do XML que você esta passando como parâmetro contem o nome do XML também?

Se sim, esse XML esta assinado, mas sem o protocolo de autorização?

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Membros Pro

Olá Italo,

Eu estou gerando um arquivo "Consulta.xml" com o conteudo do arquivo XML sem o protocolo de autorizacao.

E chamo a funcao NFe.ConsultarNFe("Consulta.xml").

Retorna OK com o cStat 100 no arquivo INI de resposta, mas dentro do Consulta.XML não gera as tags de protocolo

Link to comment
Share on other sites

  • Consultores

Felipe,

Você poderia postar em anexo esse XML?

Alem de tirar o protocolo de autorização para realizar esse teste você também esta alterando o nome do arquivo XML?

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Membros Pro

na verdade eu não estou tirando o protocolo para testar, eu acabei de gerar um XML e nem fiz a consulta dele, só gerei o XML e transmiti.

Na pasta \salvas gerou o arquivo "35151004756933000164550010000015011751248667-nfe.xml  e nele já está sem o protocolo, ou seja, quando envia a nota não está gerando o protocolo no XML, nem no envio.

 

Aí eu gerei outro arquivo Consulta.xml contendo exatamente o mesmo conteudo desse arquivo anexo.

e mando NFe.ConsultarNfe(Consulta.XML) e ele não atualiza o Consulta.XML com o protocolo.

 

aí no seu MonitorPlus quando vc envia uma nota e olha na pasta SALVAS o XML está com o protocolo dentro?

35151004756933000164550010000015011751248667-nfe.xml

Link to comment
Share on other sites

  • Consultores

Boa tarde Felipe,

A equipe ACBr esta investigando esse problema.

A principio o consultar é para realizar uma consulta simples a SEFAZ e retornar a informação se a nota esta autorizada ou não, se sim, o protocolo de autorização.

Mas se antes de realizar essa consulta ou como você usa o Monitor for informado o caminho + nome do xml da nota que esta sem o protocolo de autorização o consultar alem de realizar a consulta atualiza o XML acrescentando o protocolo de autorização.

Aconselho a não alterar o nome do XML e nem coloca-lo em outra pasta que não seja as configuradas, pois isso pode fazer com que essa atualização não seja realizada.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Membros Pro

O estranho é que no ACBrNFeMonitorCapicom e OpenSSL funciona.

E quando envia a NF-e (mesmo sem fazer a consulta, somente o envio) o XML está ficando sem o protocolo na pasta \Salvas mesmo, ou seja, nesse caso eu nem troquei o arquivo XML de lugar, está na própria pasta que o ACBrMonitoPlus gera o arquivo, que é na pasta \Salvas

Link to comment
Share on other sites

  • Consultores

Felipe,

O ACBrMonitor Plus não se utiliza dos mesmos componentes que são utilizados pelo ACBrNFeMonitor.

Foi feito um Refactoring em todos os componentes e o ACBrMonitor Plus se utiliza das novas verões dos componentes.

É bem provável que no Refactoring algo esteja errado provocando esse problema.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Membros Pro

Boa tarde, tem alguma novidade sobre isso?! No estado do RJ estou com problema em todos os meus clientes!

Pq se uso o ACBrNFeMonitorCAPICOM dá erro pq mudou o endereço do WS, se uso o Plus dá mensagem de NAO CONSTA NA BASE DA SEFAZ em vermelho no DANFE em PDF.

 

Obrigado

Link to comment
Share on other sites

  • Consultores

Esqueceram de mim?

Bom dia!

existem diversos commit nesses últimos dias com  o intuito de corrigir possíveis problemas!

acho que deveria pegar a última versão gerada e refazer os testes!

acho que já está corrigido seu problema!

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • Membros Pro

Negativo, testei com a versão 1.10.4 e continua o problema.

Estou testando inclusive pelo botão CONSULTAR NFE da aba TESTES.

Isso só acontece comigo? Não tem mais ninguém com esse problema? Acho estranho só eu precisar dessa funcionalidade, pq com esse problema não consigo imprimir nenhum DANFE, pq fica saindo a mensagem "NAO CONSTA NA BASE DA SEFAZ".

Link to comment
Share on other sites

Ola.  não sei ajuda.. mas comigo ocorre no AcbrNfeMonitor isso.. as vezes gero e envio e por algum motivo a secretaria recebe e autoriza mais por algum motivo nao retorna... erro de operacao do usuario que fecha o programa antes de ter o retorno por exemplo..

 

Bom ai faco a consulta , retorna AUTORIZADA, mas nao salva a autorizacao no XML...

Faço o seguinte procedimento. Fecho o ACBR e Abro novamente. faço a consulta e ele salva o reotnro autorizado.

Ja me acostumei com isso.. quando o cliente consulta autorizado e imprime e nao sai a autorizacao.. ja passo esse procedimento. 

sempre funcionou.. agora no PLUS nao sei se isso tambem resolve.. O correto seria consultar e ja salvar

 

Nilton Bonilha - São Paulo - SP

xHarbour.

LOGOSFW.jpg.aed61309847a9f4c30e8328f9c17

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.