Jump to content

click.png

click.png

click.png

click.png click.png click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

  • Este tópico foi criado há 1901 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Bom dia,

Estava revisando umas rotinas minhas, quando me deparei com erro no XML de retorno da SEFAZ quando a NFe é denegada.

Fiz várias tentativas, inclusive consultei novamente o XML para baixar outro XML e continua com o mesmo erro.

Ele não abre corretamente, abri o mesmo no NotePad++, mas não consegui identificar o que pode estar acontecendo.

Estou com o pacote totalmente atualizado e uso Delphi 10 Seattle.

Tentando consultar a mesma NFe pelo aplicativo de testes, o mesmo retorna "Caractere inválido encontrado no texto".

Segue todos os arquivos envolvidos nos testes.

Erro Demo.png

35160703857918000140550000000003631565642605-sit-soap.xml

35160703857918000140550000000003631565642605-sit.xml

35160703857918000140550000000003631565642605-nfe.xml

Link to comment
Share on other sites

Como o XML vem com a Tag de definição de UTF-8, espera-se que seu conteúdo seja todo em UTF-8, mas esse caracter ai é visível em formato ANSI, tanto que se abir o XML no Notepad++ por exemplo e fazer a conversão para ANSI e depois de volta para UTF-8 o caracter é traduzido.

A meu ver é um erro no retorno da SEFAZ, e talvez nesse caso seja necessário uma consulta a eles para a correção do problema.

Consultor SAC ACBr

Celso Marigo Junior

Conheça o Portal do Projeto ACBr
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

 

Link to comment
Share on other sites

  • Membros Pro
1 hora atrás, Celso disse:

Como o XML vem com a Tag de definição de UTF-8, espera-se que seu conteúdo seja todo em UTF-8, mas esse caracter ai é visível em formato ANSI, tanto que se abir o XML no Notepad++ por exemplo e fazer a conversão para ANSI e depois de volta para UTF-8 o caracter é traduzido.

A meu ver é um erro no retorno da SEFAZ, e talvez nesse caso seja necessário uma consulta a eles para a correção do problema.

Exatamente isso.

Acabei de abrir uma consulta na SEFAZ de SP e assim que obter um retorno, posto o resultado.

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.