Jump to content

chamada diadoacbr

Assista tectoy.png

[NFS-E - Erro na impressão]


L1p3br
  • Este tópico foi criado há 3450 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Olá.

Galera, estou fazendo alguns testes ainda com o programa para implementar no meus projetos. O problema que está acontecendo comigo é que na impressão do NFS-E, dá essa mensagem de erro:

Ancestor for 'QRNFSe' not found 

Eu já tentei reinstalar tudo e instalar novamente, mas continua o erro. O componente TACBrNFSeDANFSeQR está aparecendo normalmente, executo o projeto normalmente também, porém o erro acontece somente na hora de gerar a impressão, especificamente no comando:
ACBrNFSe1.NotasFiscais.Imprimir;

Podem me dar uma luz, em que parte que eu fiz titica? rsrs

Link to comment
Share on other sites

  • Consultores

Bom dia,

Essa mensagem de erro: Ancestor for 'QRNFSe' not found aparece porque o Delphi abre somente o fonte que contem o erro, se ele depende de um fonte PAI ocorre esse erro, até ai tudo bem.

O fonte que ele abre deve ser o ACBrNFSeDANFSeQRRetrato, é nele que contem o erro, qual é a linha deste fonte que ele aponta como errada?

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

Olá Italo, muito obrigado por responder.

Como disse acima, ele dá o erro exatamente nessa parte:

fqrDANFSeQRRetrato := TfqrDANFSeQRRetrato.Create(Self);
Que é na unit:
ACBrNFSeDANFSeQRClass
Ele faz o procedimento abaixo e mostra a mensagem de erro:
procedure TACBrNFSeDANFSeClass.Notification(AComponent: TComponent;

  Operation: TOperation);

begin

 inherited Notification(AComponent, Operation);


 if (Operation = opRemove) and (FACBrNFSe <> nil) and (AComponent is TACBrNFSe)

  then FACBrNFSe := nil;

end;

Link to comment
Share on other sites

Italo, eu declarei a Unit ACBrNFSeDANFSeQRRetrato no projeto, so de clicar nela (CTRL + Click nela) ele já da uma mensagem falando o erro "Ancestor for 'QRNFSe' not found". Mas a unit abre normalmente e após ter feito 1x, não dá mais o erro. Bizarro rsrs

Link to comment
Share on other sites

  • 2 months later...

Isso já ocorreu comigo uma vez por que no momento da emissão por que a NFSe o protocolo não estava recebendo a código de verificação mais isso foi um erro do site. Seria bom tivesse um tratamento quando este erro ocorre-se. Ex. se não recebe-se a o codigo de verificação ele emiti-se um erro para não imprimir!

"E que George Bush beba o sangue de cada homem, criança e mulher no Iraque.

E que vocês destruam o país deles para que daqui a mil anos nenhuma lagartixa consiga viver no deserto! " Borat

Link to comment
Share on other sites

  • 9 months later...

Pessoal estou com err namesma Linha só que da o erro:

Error reading qrb_1_CAbecalho.transparentBand property.. o meu problema, é q na versao que instalei do quick report é a que vem no Delphi 7, e acredito que não tenha essa propriedade transparentBand.. alguém pode me ajudar a resolver esse problema???

Link to comment
Share on other sites

se alguém puder me ajduar..  to quebrando a cabeça com isso faz um tempo.. se alguém souber como resolver e puder me mandar um email [email protected]  eu tentei instalar uma outra versao do quick report, mas deram alguns problemas durante a instalação .. mas acredito piamente que o problema é a versao do quick..  Aguardo uma ajuda RSRS Valew

Link to comment
Share on other sites

Seguinte velho , dentro da pasta dos fontes do Danfse , vc tem la os fontes pra substituir na compilacao ... so copia eles e sobrepor . ai vc consegue compilar.

Adilson não entendi... substitur quais fonts???  o problema não é o quick report?? é no ACBRNFSE mesmo???

 

copier o fonte da onde e sobrepor na onde?? não entendi o pocedimento. pode me detalhar um pouco mais??

 

Grato!

Edited by netsolutions
Link to comment
Share on other sites

Pessoal, só mais uma Dúvida, não sei se aqui é o Lugar certo pra essa questão, mas acho que vcs podem me ajudar... 

 

o Componente ACBRNFSE  funciona com o "Acessor Publico"???   eu testei com o GINFES, e funcionou perfeitamente.. agora queria saber se para o Acessor public tbm ele ja é adaptado.. Grato!

Link to comment
Share on other sites

Flw velhão . No caso pros provedores que roda são os listados abaixo . Somente os que utilizam o padrao ABRASF .

 

12/12/2012  15:56            26.513 ACBrProvedorAbaco.pas
26/11/2012  08:25            22.964 ACBrProvedorBetha.pas
28/12/2012  14:53            25.717 ACBrProvedorBetim.pas
18/12/2012  17:07            27.304 ACBrProvedorBHISS.pas
12/12/2012  15:56            25.982 ACBrProvedorDigifred.pas
12/12/2012  15:56            23.855 ACBrProvedorEquiplano.pas
12/12/2012  15:56            27.336 ACBrProvedorfintelISS.pas
12/12/2012  15:56            24.336 ACBrProvedorfISSLex.pas
12/12/2012  15:56            26.360 ACBrProvedorGinfesV3.pas
14/12/2012  18:14            23.771 ACBrProvedorGoiania.pas
12/12/2012  15:56            37.505 ACBrProvedorGovBR.pas
14/12/2012  18:14            22.148 ACBrProvedorISSCuritiba.pas
12/12/2012  15:56            25.203 ACBrProvedorISSIntel.pas
10/01/2013  15:52            29.037 ACBrProvedorISSNet.pas
12/12/2012  15:56            25.944 ACBrProvedorProdemge.pas
12/12/2012  15:56            23.395 ACBrProvedorPublica.pas
12/12/2012  15:56            25.423 ACBrProvedorRecife.pas
12/12/2012  15:56            24.476 ACBrProvedorRJ.pas
12/12/2012  15:56            26.975 ACBrProvedorSaatri.pas
14/12/2012  18:14            30.059 ACBrProvedorSimplISS.pas
12/12/2012  15:56            25.418 ACBrProvedorThema.pas
12/12/2012  15:56            24.605 ACBrProvedorTiplan.pas
10/01/2013  15:52            35.309 ACBrProvedorWebISS.pas
 

Edited by adilsonpazzini
Link to comment
Share on other sites

 tenho mais uma Dúvida...

 

tem as tags

 

servico.codigomunicipio

 

Servico.MunicipioIncidencia

 

no servico.codigomunicipio  inform o coidgo do municipio da Prestadora de service e na Servico.MunicipioIncidencia informo

o codigo do municipio do tomador??  é isso mesmo??

 

Alguém ai podendo me dar uma forcinha??

Link to comment
Share on other sites


Boa Tarde.. estou tendo um Problema na geracao do Arquivo e na impressao do RPS para o GINFES

 
o problema é a ALIQUOTA.. quando faço pelo site da prefeitura.. o Valor da aliquota impresso no RPS é 2,00
 
quando gero o xml para transmitir através do meu sistema.. passo o valor
 
2,00 .. porem no XML está gerando    2.0000
 
se eu mando o xml com esse valor de aliquota ele me retorna erro que a aliquota nao está cadastrada.. entao peguei o valor e dividi por 100
 
ficou  0.0200  no xml.. só que se passo assim.. na impressao do RPS está saindo  0,02 ....
 
vocês sabem como devo proceder nessa situação??  
 
grato!
Link to comment
Share on other sites

  • Consultores

Boa tarde netsolutions,

 

Fiz uma alteração na impressão do DANFSE (versão Quick Report) de tal forma que se a aliquota for menor que 1 a mesma será multiplicada por 100 caso contario não.

 

Favor atualizar os fontes e testar novamente.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Este tópico foi criado há 3450 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.