Jump to content
Notícias do ACBr

click.png

click.png

click.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

click.png

click.png

click.png

click.png

click.png

click.png

Communication error 2


Go to solution Solved by Sirtoli,
  • Este tópico foi criado há 1098 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Olá a todos, após atualização nfe 4.0 está dando este erro, não sei se é a versão do acbrmonitor que estou utilizando 1.2.0.10 , o alguma configuração faltando, pelo que  entendi está ocorrendo uma falha na comunicação com a impressora, utilizo bematech mp-4200 , se utilizar a o demodanfescpos funciona normalmente, mas quando dou criar e enviar pelo acbrnfedemo ocorre o erro na impressão automatica que dever chamar o demodanfescpos.

uso o delphi xe2 e windows 7 64, se alguém puder me ajudar agradeço.

communication erro2.jpg

Link to comment
Share on other sites

  • Consultores

Boa tarde, chegou a testar passando direto o comando para impressão, para ver se o problema é na impressão? ex: NFe.ImprimirDanfe(Path_XML)?

Se na versão anterior está funcionando, anexe o arquivo ACBrMonitor.ini para análise... 

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

Obrigado pela atenção José, em anexo acbrmonitor.ini do modelo antigo que está funcionando e código de envio do atual, bem como xml atual que está dando erro, quanto ao teste de impressão direta , não sei como fazer dentro do acbrnfe_demo se puder me passa comando de impressão

agradeço, tentei o NFe.ImprimirDanfe que você pediu mas não é reconhecido dentro do acbrnfe_demo, preciso imprimir logo após os comandos acima se for imprimir

depois funciona tipo criar e enviar e dá o erro dai eu abro o acbrdanfescpos ele imprime normal mas a impressão tem de sair automaticamente logo após o criar e enviar

para ficar prático, os cliente já estão acostumados assim e achar ruim ter de buscar o xml para imprimir.

codigo envio.jpg

ACBrMonitor.ini

41180778949195000108650010000637591000637591-nfe.xml

Link to comment
Share on other sites

  • Consultores

Boa tarde, conforme o Italo citou... o que você utiliza? o ACBrMonitor ou o componente ACBr em Delphi? O comando que eu te passei é do ACBrMonitor... Se você desenvolve em Delphi é outra coisa, precisa verificar os métodos nos demos conforme o componente que deseja utilizar...

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

Então , eu sempre achei que um um dependia do outro para funcionar.

eu utilizo os componentes acbr, neste caso o que pode estar dando errado? pelo demo acbrnfe_demo já está configurado corretamente

para imprimir a nfce quando da criar e enviar ou não?

Link to comment
Share on other sites

  • Solution

Bom dia, boas noticias para começar o dia achei o erro,  no componente posprinter estava setada porta COM9 fixo, vou tratar a porta localizando a COM disponível , 

obrigado pela atenção de vocês.

  • Like 1
Link to comment
Share on other sites

  • Este tópico foi criado há 1098 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.