Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

click.png

click.png

click.png

eSocial S-1000 O ambiente informado no evento é incompatível com a url utilizada


  • Este tópico foi criado há 1061 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Olá,

Meu cliente está tentando enviar um evento S-1000 e está ocorrendo o seguinte erro:

Código da ocorrência: 638
Descrição do erro...: O ambiente informado no evento é incompatível com a url utilizada.

Alguém sabe dizer o que é isso?

Desde já, obrigado.

 

20180725161220-env-lot.xml

20180725161227-rec.xml

1113122960000002018072516121800004-S-1000-0.xml

eSocial-ped-sit.xml

eSocial-sit.xml

evtInfoEmpregador.xml

Link to comment
Share on other sites

@Italo Jurisato Junior, você sabe o motivo deste erro?

Código da ocorrência: 638
Descrição do erro...: O ambiente informado no evento é incompatível com a url utilizada.

Pode me ajudar?

 

eSocial-sit.xml

eSocial-ped-sit.xml

20180803170031-rec.xml

20180803170027-env-lot.xml

1246856450000002018080317002400001-S-1000-0.xml

evtInfoEmpregador.xml

Em 27/07/2018 at 07:54, Patrick Alves disse:

Bom dia!

Verifique se está sendo configurado corretamente a propriedade Configuracoes.WebServices.Ambiente. Parece que está enviando o xml montado para o ambiente de produção para o webservice de homologação.

 

 

Se você abrir o XML verá que a url está correta e a TAG relativa ao ambiente também está preenchida corretamente.

 

Link to comment
Share on other sites

  • Consultores

Bom dia Anderson,

Uma coisa é você configurar o componente no que diz respeito ao Tipo de Ambiente e outra é você alimentar o componente.

Configuração:

ACBreSocial1.Configuracoes.WebServices.Ambiente := taProducao; // ou taHomologacao

Alimentar o componente:

// taProducao, taProducaoRestrita (equivale ao taHomologacao)
IdeEvento.TpAmb := taProducaoRestrita;
 

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • 3 weeks later...

IdeEvento.TpAmb  aceita "1" e "2", para Produção  e Produção Restrita.

Para ACBreSocial1.Configuracoes.WebServices.Ambiente, são '0' e '1' para taProducao e taHomologacao, pois esta usando o rgTipoAmb.ItemIndex, o que causa confusão.

Mude a linha para IdeEvento.TpAmb := taProducaoRestrita; como Ítalo citou acima que funcionará, pois voce está gravando '1' em TmAmb no XML.

<ideEvento>
<tpAmb>1</tpAmb>

O ideal seria voce  ajustar o programa de exemplo para usar uma função que retornasse de acordo com rgTipoAmb.ItemIndex para determinar IdeEvento.TpAmb, ao invés de atribuir manualmente em cada evento como está no programa Exemplo atual.

Link to comment
Share on other sites

Em 06/08/2018 at 11:26, Italo Jurisato Junior disse:

Bom dia Anderson,

Uma coisa é você configurar o componente no que diz respeito ao Tipo de Ambiente e outra é você alimentar o componente.

Configuração:

ACBreSocial1.Configuracoes.WebServices.Ambiente := taProducao; // ou taHomologacao

Alimentar o componente:

// taProducao, taProducaoRestrita (equivale ao taHomologacao)
IdeEvento.TpAmb := taProducaoRestrita;
 

@Italo Jurisato Junior, desculpe tomar seu tempo.
Verifiquei a procedure LerConfiguracao e vi que estava fixo o envio para o ambiente de testes.
Corrigi e deu tudo certo.
Me perdoe a perda de tempo.

Obrigado.

 

  • Like 2
Link to comment
Share on other sites

  • Este tópico foi criado há 1061 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.