Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

Erro ao montar Tributação PIS e COFINS - versão 1.2.0.46


abrahaofv
Go to solution Solved by Italo Giurizzato Junior,
  • Este tópico foi criado há 1161 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa tarde.

Estou com um erro na montagem do XML quando o produto possui PIS e COFINS. Após eu atualizar a versão do acbrmonitorplus não está gerando as tags [PIS001] e [COFINS001] . Ocorre o erro: 

Erro(s) nas Regras de negócios da nota: 115
602-Rejeição: Total do PIS difere do somatório dos itens sujeitos ao ICMS
603-Rejeição: Total da COFINS difere do somatório dos itens sujeitos ao ICMS

Segue os arquivos ENT.ini, o xml gerado e minhas configurações.

ENT.ini 33190323172561000173650110000001151000001152-nfe.xml ACBrMonitor.ini

Edited by abrahaofv
complementando informações
Link to comment
Share on other sites

  • Moderadores

Boa tarde.


[ICMS001]
orig=0
CST=60
vBCSTRet=0
vICMSSTRet=0
vBCSTDest=0
vICMSSTDest=0

[PIS001]
CST=1
vBC=10
pPIS=0.65
qBCProd=0
vAliqProd=0
vPIS=0.06

[COFINS001]
CST=1
vBC=10
pCOFINS=3
qBCProd=0
vAliqProd=0
vCOFINS=0.3
 

tem algo errado .. ai.. 

no icms nao foi informanda nada.. e é isso que ele esta reclamando..

fale com seu contador, para ver como tem de preencher essa nota..

 

  • Like 1
Link to comment
Share on other sites

2 minutos atrás, Amarildo de Matos disse:

Boa tarde.


[ICMS001]
orig=0
CST=60
vBCSTRet=0
vICMSSTRet=0
vBCSTDest=0
vICMSSTDest=0

[PIS001]
CST=1
vBC=10
pPIS=0.65
qBCProd=0
vAliqProd=0
vPIS=0.06

[COFINS001]
CST=1
vBC=10
pCOFINS=3
qBCProd=0
vAliqProd=0
vCOFINS=0.3
 

tem algo errado .. ai.. 

no icms nao foi informanda nada.. e é isso que ele esta reclamando..

fale com seu contador, para ver como tem de preencher essa nota..

 

Ok, mais o PIS e o COFINS não deveriam ir para o XML ? Não estão indo. Dai da erro pq nos totalizadores do XML está os valores de pis e cofins mais as tags não foram adicionadas. Veja o XML.

 

<total>
<ICMSTot>
<vBC>0.00</vBC>
<vICMS>0.00</vICMS>
<vICMSDeson>0.00</vICMSDeson>
<vFCP>0.00</vFCP>
<vBCST>0.00</vBCST>
<vST>0.00</vST>
<vFCPST>0.00</vFCPST>
<vFCPSTRet>0.00</vFCPSTRet>
<vProd>10.00</vProd>
<vFrete>0.00</vFrete>
<vSeg>0.00</vSeg>
<vDesc>0.00</vDesc>
<vII>0.00</vII>
<vIPI>0.00</vIPI>
<vIPIDevol>0.00</vIPIDevol>
<vPIS>0.06</vPIS>
vCOFINS>0.30</vCOFINS>
<<vOutro>0.00</vOutro>
<vNF>10.00</vNF>
<vTotTrib>1.62</vTotTrib>
</ICMSTot>
</total>
Link to comment
Share on other sites

8 minutos atrás, Amarildo de Matos disse:

Tem como mandar um ent.ini e o xml ja autoriazdo , que dava certo antes?

para analise

oK. Vou pegar aqui.

Enquanto isso, fiz um teste aqui colocando valores de tributação do ICMS. O erro também ocorreu. Não gerou as tags de PIS e COFINS no arquivo XML.

 

ENT.ini 33190323172561000173650110000001181000001189-nfe.xml

Link to comment
Share on other sites

  • Administradores

Obrigado por reportar.

Fechando. Para novas dúvidas, criar um novo tópico.

Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

  • Este tópico foi criado há 1161 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.