Jump to content

dev botao

erro ao gerar gnre


rodrigoogioni
Go to solution Solved by rodrigoogioni,
  • Este tópico foi criado há 1621 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa tarde a todos,

De uns dias para ca quando vou  gerar uma gnre, da o seguinte mensagem de erro

Cannot open file "C:\Sistema\Backup\Documentos\GNRE\TXT\000000000000000000000000000000000000000000000000-gnre.txt". O sistema não pode encontrar o arquivo especificado
Ja atualizei os fonte, mas contiua o mesmo erro.

O que pode estar acontecendo?

Grato

Link to comment
Share on other sites

  • Moderadores
1 hora atrás, rodrigoogioni disse:

Boa tarde a todos,

De uns dias para ca quando vou  gerar uma gnre, da o seguinte mensagem de erro

Cannot open file "C:\Sistema\Backup\Documentos\GNRE\TXT\000000000000000000000000000000000000000000000000-gnre.txt". O sistema não pode encontrar o arquivo especificado
Ja atualizei os fonte, mas contiua o mesmo erro.

O que pode estar acontecendo?

Grato

Chegou a depurar na geração e ver onde está indo e onde o erro ocorre?

  • Like 1
Consultor SAC ACBr Juliomar Marchetti
 

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
 

 

Link to comment
Share on other sites

2 minutos atrás, Juliomar Marchetti disse:

Chegou a depurar na geração e ver onde está indo e onde o erro ocorre?

Boa tarde, sim

O acbrgnre gera um txt. E depois carrego esse txt e ai ele gera a impressão.

Pelo que parece nao esta gerando mais esse txt.

Vi algum post indicando que tinha que carrregar pelo xml.

Tentei mas nao deu certo

Essa informação procede?

 

Grato

 

Link to comment
Share on other sites

15 horas atrás, Juliomar Marchetti disse:

Chegou a depurar na geração e ver onde está indo e onde o erro ocorre?

Nessa Função SalvarTXT na unit AcbrGNREWebServices não esta gerando o txt quando passa pela linha

 

if SameText(Copy(SL.Strings, 1, 1), '1') then

nessa linha ao inves de 1 esta 0

 

no resultado aparece a seguinte mensagem:

703Falha na validacao do retorno da UF: O caractere '&' dever ser colocado no XML apenas utilizando a sequencia de 'escape' '&' 9191409407900010bbc7d4a39e531aa3d47be95f622b771ec7567a20526e306d18c61d481ce99a0

 

Será que pode ser isso?

Grato

 

 

Link to comment
Share on other sites

21 minutos atrás, lucastonussi disse:

Bom dia 

Verifica esse tópico....

 

Bom dia,

Obrigado pela resposta.

fiz da seguinte forma:

if fileexists(ExtractFilePath(Application.ExeName) + 'Backup\Documentos\GNRE\' + dm.ACBrGNRE1.WebServices.Retorno.GNRERetorno.numeroRecibo + '-pro-rec.xml') then begin
     dm.ACBrGNRE1.GuiasRetorno.Clear;
     dm.ACBrGNRE1.GuiasRetorno.LoadFromFile(ExtractFilePath(Application.ExeName) + 'Backup\Documentos\GNRE\' + dm.ACBrGNRE1.WebServices.Retorno.GNRERetorno.numeroRecibo + '-pro-rec.xml');
     dm.ACBrGNRE1.GuiasRetorno.Imprimir;
     dm.ACBrGNRE1.GuiasRetorno.ImprimirPDF;
     end;

mas imprime a representação numerica do codigo de barras com todos os numeros zero.

o que vc acha que estou fazendo errado?

Grato

 

 

 

 

 

gnre-xml.PNG

Link to comment
Share on other sites

  • Consultores

Bom dia Rodrigo,

Já tentou configurar o componente para a versão 2.00 do GNRE?

Lembre-se que nessa versão o webservice retorna através da consulta o XML com as informações da guia.

E é este XML que devemos carregar para imprimir a guia.

Consultor SAC ACBr

Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Araraquara - A era dos Trólebus

Link to comment
Share on other sites

41 minutos atrás, Italo Jurisato Junior disse:

Bom dia Rodrigo,

Já tentou configurar o componente para a versão 2.00 do GNRE?

Lembre-se que nessa versão o webservice retorna através da consulta o XML com as informações da guia.

E é este XML que devemos carregar para imprimir a guia.

Vou tentar e ja retorno

Link to comment
Share on other sites

1 hora atrás, Italo Jurisato Junior disse:

Bom dia Rodrigo,

Já tentou configurar o componente para a versão 2.00 do GNRE?

Lembre-se que nessa versão o webservice retorna através da consulta o XML com as informações da guia.

E é este XML que devemos carregar para imprimir a guia.

Bom dia Italo.

Atualizei o Acbr e tentei emitir com a versao 2.0 e retorna a sequenite mensagem:

Lote processado com pendencias.

Dai vou no arquivo -pro-rec.xml e nos motivos tem essa mensagem

-<ns1:motivo>

<ns1:codigo>288</ns1:codigo>

<ns1:descricao>UF favorecida nao esta com a versao '2.00' do XML de dados habilitada.</ns1:descricao>

<ns1:campo>ufFavorecida</ns1:campo>

</ns1:motivo>

 

Não sei, mas o que parece pela mensagem é que no estado não esta liberado é isso?

 

Grato

e voltando para a versao 1.0 continua o mesmo problema.

Link to comment
Share on other sites

Consultando o site http://www.gnre.pe.gov.br/gnre/portal/consultarTabelas.jsp o estado do RS não esta habilitado para a versao 2.0.

Na versão 1.0 anteriormente estava gerando o TXT e ai era gerado a impressão da GNRE.

Em algum momento acredito que alguem tenha alterado o componente e não esta funcionando mais a geração do TXT na versao 1.0.

Teria como voltar a funcionar na versao 1.0?

Enviei um email para SEFAZ do RS cobrando uma posição de quando vai ser disponibilizado a versão 2.0 mas enquanto

essa questão nao se resolve, todos os clientes não estao conseguindo gerar pelo sistema. 

Se tiver um meio de voltar a gerar o txt, pelo menos esses clientes não ficariam sem gerar.

Grato

Link to comment
Share on other sites

  • Consultores

Boa tarde Rodrigo,

É para estar funcionando a versão 1.00 também.

Após enviar na versão 1.00 e realizar a consulta o TXT que contem os dados para imprimir a guia não é salvo em disco?

Consultor SAC ACBr

Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Araraquara - A era dos Trólebus

Link to comment
Share on other sites

42 minutos atrás, Italo Jurisato Junior disse:

Boa tarde Rodrigo,

É para estar funcionando a versão 1.00 também.

Após enviar na versão 1.00 e realizar a consulta o TXT que contem os dados para imprimir a guia não é salvo em disco?

Isso, antes salvava um arquivo txt onde eu carregava no componente e imprimia.

Agora esse txt nao salva mais em disco. e aparece a mensagem:

Cannot open file "C:\Sistema\Backup\Documentos\GNRE\TXT\000000000000000000000000000000000000000000000000-gnre.txt". O sistema não pode encontrar o arquivo especificado

Grato

Link to comment
Share on other sites

Boa tarde a todos!

Enviei e-mails para SEFAZ-RS e GNRE, e obtive a seguinte resposta:

Prezados(as) Senhores(as), 

Tendo em vista que alguns estados e muitas empresas, não estão com suas versões devidamente testados e implantados, resolvemos alterar o prazo final da versão 1.0 para 30/04/2020,  portanto as duas versões continuarão sendo aceitas até 30/04/2019.

Equipe GNRE/PE

O problema é que continuo sem conseguir gerar com a versao 1.0.

Alguem esta conseguindo gerar?

Grato

Link to comment
Share on other sites

Boa tarde a todos.

Descobri uma informação importante.

Ao gerar a gnre, passo no arquivo a Inscrição Estadual apenas.

Quando envio a gnre para algum cliente que tenha a letra "&" no nome aparece a mensagem

703Falha na validacao do retorno da UF: O caractere '&' dever ser colocado no XML apenas utilizando a sequencia de 'escape' '&amp;amp;' 9191409407900010bbc7d4a39e531aa3d47be95f622b771ec7567a20526e306d18c61d481ce99a0

no resultado e não imprime a gnre.

Quando faço para outro cliente que não tem um "&" imprime normalmente.

So não sei como consertar isso no componente.

Alguem tem alguma ideia?

Grato

 

Link to comment
Share on other sites

  • Consultores

Bom dia Rodrigo,

Primeiramente, muito obrigado pelas informações.

Vou analisar o problema referente ao arquivo TXT da versão 1.00

E essa questão do E comercial.

  • Like 1
Consultor SAC ACBr

Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Araraquara - A era dos Trólebus

Link to comment
Share on other sites

2 horas atrás, Italo Jurisato Junior disse:

Bom dia Rodrigo,

Primeiramente, muito obrigado pelas informações.

Vou analisar o problema referente ao arquivo TXT da versão 1.00

E essa questão do E comercial.

Se precisar da I.E do cliente que tem "&" no nome pra testes me avisa que lhe passo.

Grato 

  • Like 1
Link to comment
Share on other sites

8 hours ago, Italo Jurisato Junior said:

Bom dia Rodrigo,

Primeiramente, muito obrigado pelas informações.

Vou analisar o problema referente ao arquivo TXT da versão 1.00

E essa questão do E comercial.

 

Boa tarde, Italo. 

Este problema do & parece ser entre o webservice da GNRE PE e a SEFAZ de destino.

Estou recebendo a mesma mensagem para uma GNRE da PB. Começou esta semana, sem nenhuma publicação de versão. Como não estou usando o ACBr neste executável, pode ser alguma confusão entre as SEFAZ.

Estou usando outro fonte gerado pelo wsdl importer. Provavelmente migrando para a emissão da GNRE pelo ACBr no próximo ano.

Já revisei o XML de envio e não possui qualquer &.

 

  • Like 1
Link to comment
Share on other sites

16 minutos atrás, valdir disse:

 

Boa tarde, Italo. 

Este problema do & parece ser entre o webservice da GNRE PE e a SEFAZ de destino.

Estou recebendo a mesma mensagem para uma GNRE da PB. Começou esta semana, sem nenhuma publicação de versão. Como não estou usando o ACBr neste executável, pode ser alguma confusão entre as SEFAZ.

Estou usando outro fonte gerado pelo wsdl importer. Provavelmente migrando para a emissão da GNRE pelo ACBr no próximo ano.

Já revisei o XML de envio e não possui qualquer &.

 

Boa tarde,

Fucei os fontes do acbrgnre de ponta cabeça e também nao achei nada, no xml realmente nao tem.

A uns dois dias atras enviei um email para o suporte do GNRE contando o caso, mas até agora não responderam.

Pior que tenho um cliente que emite GNRE apenas para um cliente, e justamente nesse cliente tem o bendito "&".

Para compensar toda nota tenho que ir la e fazer a GNRE para o clinte.

Mas é um tempo disperdiçado.

Grato

Link to comment
Share on other sites

  • Este tópico foi criado há 1621 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.