Jump to content

chamada diadoacbr

Assista tectoy.png

Erro Interno: 183


douglaswf
Go to solution Solved by BigWings,
  • Este tópico foi criado há 514 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Boa tarde!
Estou enfrentando um problema agora que diz uma recompilação de uma rotina de validação de XMLs. A minha rotina valida os xmls recebidos de fornecedores em lote, chamando o método "ACBrNfe.WebServices.Consulta.Executar".

Porém esse erro fica horas sem acontecer, de repente começa a dar erros em sequencia, e depois volta ao normal. Mesmo se eu parar o serviço e iniciar novamente, naquele momento fica dando erro.  Se eu volto meu executável antigo, compilado a uns 2 meses atrás, não tenho problemas.

Erro ACBrNfe.WebServices.Consulta.Executar: 
Erro Interno: 183
Erro HTTP: 0
URL: https://nfe.sefazrs.rs.gov.br/ws/NfeConsulta/NfeConsulta4.asmx
Erro: 183 - 
 

Alguém já enfrentou esse retorno?

 

Att,

Douglas

 

Link to comment
Share on other sites

  • 3 weeks later...
  • Consultores

Esse erro é direto ou intermitente?

já pensaram em trocar DNS ?

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • Membros Pro
19 horas atrás, CHARLESSPOT disse:

Ola 

 

Boa Noite eu tb tiver o msm problema hoje sefaz MG. XML ok 

 

Retorno:0 - 
Erro:
Erro Interno: 183
Erro HTTP: 0
URL: https://nfe.fazenda.mg.gov.br/nfe2/services/NFeAutorizacao4
Erro: 183 -

Eu venho recebendo esse erro a vários dias. Consegui contornar criando o componente em tempo de execução, já que ele roda em um serviço do windows em segundo plano. Notei que ele não acontece direto. Na consulta anterior dá um erro de DNS, e na seguinte, começa a dar esse 183, e não para mais, mesmo consultado outros documentos em outros estados.

image.thumb.png.dce4d305b2b9284334e974f6d2f97c02.png

 

Quanto a trocar o DNS, uso servidores no AWS e na Azure (Microsoft). Então não mudei porque não creio que eles devem ter um bom DNS né? rs....

 

 

 

 

 

 

 

Link to comment
Share on other sites

  • Consultores

Há uma dica que alguém informou se tu consultar o mesmo NSU duas vezes seguidas eles bloqueiam por 1 hora.

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • Membros Pro
1 minuto atrás, Juliomar Marchetti disse:

Há uma dica que alguém informou se tu consultar o mesmo NSU duas vezes seguidas eles bloqueiam por 1 hora.

Essa consulta que retorna o erro 183 é a "ACBrNfe.WebServices.Consulta.Executar". Não está confundindo com o DistribuiçãoDFE?

Mas respondendo a questão do tempo, detalhe é que depois que dá o primeiro erro de DNS (aquele 12007), começa a dar 183 em qualquer chave que consultar. não funciona mais nada até destruir o componente e recriar...

 

Link to comment
Share on other sites

  • Moderadores
5 minutos atrás, douglaswf disse:

Essa consulta que retorna o erro 183 é a "ACBrNfe.WebServices.Consulta.Executar". Não está confundindo com o DistribuiçãoDFE?

Qualquer serviço se executado em loop recebendo o mesmo retorno pode causar rejeição por consumo indevido.

6 minutos atrás, douglaswf disse:

Mas respondendo a questão do tempo, detalhe é que depois que dá o primeiro erro de DNS (aquele 12007), começa a dar 183 em qualquer chave que consultar. não funciona mais nada até destruir o componente e recriar...

Não é algo com o certificado?

Se você descarregar o certificado e carregar novamente, em vez de destruir o componente, funciona?

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

  • Membros Pro
2 minutos atrás, BigWings disse:

Qualquer serviço se executado em loop recebendo o mesmo retorno pode causar rejeição por consumo indevido.

Não é algo com o certificado?

Se você descarregar o certificado e carregar novamente, em vez de destruir o componente, funciona?

Não funciona.

Só pra explicar, executo em média umas 50 mil consultas de chaves por dia. Quando digo que executo em Loop,  é loop de rotina, mas sempre com chaves diferentes.

Esse erro acontece ao longo do dia. Hoje, pelos logs, aconteceram 7 vezes.   só recriar e tudo volta a funcionar. Se fosse algum bloqueio no sefaz, como consumo indevido, reiniciar não iria resolver.

Link to comment
Share on other sites

  • 2 weeks later...

Olá pessoal,

  Estava efetuando um teste na consulta do contribuinte, por obra do destino em modo debug, e o erro 183 ocorreu, resolvi efetuar uma analisa, acabei descobrindo que na unit ACBrWinReqRespClass, método Send(), quando ocorre um erro no método SendData() que é chamdo pelo método Send(), logo abaixo efetuamos um raise. Com isso acaba não efetuando o código que limpa a lista FHeaderReq. Cada vez que tentamos efetuar novos envios para a sefaz ao chamar o método CalculateHeaderReq(), dentro do métode SendData() da unit ACBrWinHTTPReqResp, acaba sempre inserindo os dados do host gerando a seguinte situação:

'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Host: cad.sefazrs.rs.gov.br'#$D#$A'Host: cad.sefazrs.rs.gov.br'#$D#$A'Host: cad.sefazrs.rs.gov.br'#$D#$A'Host: hom.nfe.fazenda.gov.br'#$D#$A'Content-Type: application/soap+xml; charset=utf-8; charset=utf-8'#$D#$A'Accept-Charset: utf-8'#$D#$A'SOAPAction: "http://www.portalfiscal.inf.br/nfe/wsdl/NFeStatusServico4/nfeStatusServicoNF"'#$D#$A

E o Correto seria:

'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Content-Type: application/soap+xml; charset=utf-8; charset=utf-8'#$D#$A'Accept-Charset: utf-8'#$D#$A'SOAPAction: "http://www.portalfiscal.inf.br/nfe/wsdl/NFeStatusServico4/nfeStatusServicoNF"'#$D#$A

fico a disposição para efetuar a correção, acredito que com um "try finally" resolvemos o problema, mas gostaria da opinião de todos.

 

  • Thanks 1
LogoACBr_02.png.d3c72a4756f896a387e063fd64ed6646.png Frederico Westphalen - RS
pbnew.com.br  
[email protected]  
55 3744 - 3880  
Link to comment
Share on other sites

  • Consultores

Conseguiu resolver aplicado a tratativa ?

já efetuou testes ?

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • Membros Pro

 

6 horas atrás, Rômulo da Costa de Souza disse:

Olá pessoal,

  Estava efetuando um teste na consulta do contribuinte, por obra do destino em modo debug, e o erro 183 ocorreu, resolvi efetuar uma analisa, acabei descobrindo que na unit ACBrWinReqRespClass, método Send(), quando ocorre um erro no método SendData() que é chamdo pelo método Send(), logo abaixo efetuamos um raise. Com isso acaba não efetuando o código que limpa a lista FHeaderReq. Cada vez que tentamos efetuar novos envios para a sefaz ao chamar o método CalculateHeaderReq(), dentro do métode SendData() da unit ACBrWinHTTPReqResp, acaba sempre inserindo os dados do host gerando a seguinte situação:

'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Host: cad.sefazrs.rs.gov.br'#$D#$A'Host: cad.sefazrs.rs.gov.br'#$D#$A'Host: cad.sefazrs.rs.gov.br'#$D#$A'Host: hom.nfe.fazenda.gov.br'#$D#$A'Content-Type: application/soap+xml; charset=utf-8; charset=utf-8'#$D#$A'Accept-Charset: utf-8'#$D#$A'SOAPAction: "http://www.portalfiscal.inf.br/nfe/wsdl/NFeStatusServico4/nfeStatusServicoNF"'#$D#$A

E o Correto seria:

'Host: nfe-homologacao.sefazrs.rs.gov.br'#$D#$A'Content-Type: application/soap+xml; charset=utf-8; charset=utf-8'#$D#$A'Accept-Charset: utf-8'#$D#$A'SOAPAction: "http://www.portalfiscal.inf.br/nfe/wsdl/NFeStatusServico4/nfeStatusServicoNF"'#$D#$A

fico a disposição para efetuar a correção, acredito que com um "try finally" resolvemos o problema, mas gostaria da opinião de todos.

 

 Se puder, anexa aqui o fonte com a sua sugestão. Eu consigo testar isso com um volume grande de dados, e é fácil saber se vai parar.

 

Eu atualizo os fontes com menos frequência do que deveria já que uso apenas alguns recursos.

A ultima vez que atualizei foi em 28/12. Se eu compilar meu projeto a partir dessa atualização gera esses erros 183. Andei olhando os logs e estou tento esse erro em torno de 50 vezes ao dia. Pra tirar essa dúvida, no fim de semana fiz uma VM e voltei os fontes do ACBR com o backup que sempre faço antes de atualizar. Recompilei todo o meu projeto e tudo funciona sem gerar esses erros se uso os fontes DO ACBR desatualizados.

Então me parece que teve alguma alteração no componente nesse intervalo de tempo ou algo assim que está gerando esse 183 (Inclusive está gerando erro no CTe também).

Eu não sei como descobrir que revisão (ou versão) dos fontes eu tenho nessa pasta (Provável que a atualização anterior eu tenha feito a uns 3 ou 4 meses antes). Tem como eu descobrir a revisão dos fontes ou algo assim? Se descobrir qual é a revisão que tenho nessa pasta, da pra fazer uns testes com umas revisões anteriores pra ver se descobrimos exatamente a partir de quando isso passou a ser gerado.

Edited by douglaswf
correção de erros
Link to comment
Share on other sites

Bom dia Pessoal, 

  Apenas para explicar a situação, meu modulo de emissão de NFCe a cada nota instancio um objeto novo do ACBrNFe, dessa forma nunca obtive esse erro. Porém  em meu modulo NFe não estou fazendo isso. Ressalto que começou a ocorrer esse erro a partir de alguma versão do ACBr, trabalho com o mesmo já fazem muitos anos e não estou lembrado de obter esse erro. Entretanto tudo parte de uma instabilidade na Sefaz e acaba não executando a rotina para limpar a lista HeaderReq, por mais que a Sefaz normalize, se eu não fechar a minha aplicação acabo sempre obtendo o erro 183.

Segue em anexo o arquivo ACBrWinReqRespClass.pas

ACBrWinReqRespClass.pas

LogoACBr_02.png.d3c72a4756f896a387e063fd64ed6646.png Frederico Westphalen - RS
pbnew.com.br  
[email protected]  
55 3744 - 3880  
Link to comment
Share on other sites

  • Consultores

Obrigado por reportar.

Fechando. Para novas dúvidas, criar um novo tópico.

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • Este tópico foi criado há 514 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.