Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

Rejeição 703 Data-hora emissão posterior


  • Este tópico foi criado há 451 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Bom dia,

estou tendo problemas com alguns clientes aqui em SC. Eles estão tendo problemas com a data hora, que está sendo gerada com 1h a mais no xml, embora o relógio do computador e o fuso horário esteja com o horário correto. Também não está marcada a opção de atualizar com o horário de verão.

Alguém está passando ou já passou por isso e encontrou a solução?

Desde já agradeço

 

Társis Francke Ferreira

Link to comment
Share on other sites

  • Consultores

Todos os que estão com problemas é windows server 2008

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • Consultores

Tentar gravar informações de log para poder reproduzir

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

E como gravaria essas informações de log? Não gera nenhuma exceção ou qualquer aviso. No xml a data-hora de emissão sai com 1h a mais, mas eu informo a data da própria máquina onde o software está rodando, a qual está correta. Não sei porque o componente gera essa hora a mais, em determinadas máquinas.

Mas se tem algum recurso no componente que pode me gerar informações de log, eu desconheço.

Link to comment
Share on other sites

  • Moderadores
4 horas atrás, Gandalf disse:

No xml a data-hora de emissão sai com 1h a mais, mas eu informo a data da própria máquina onde o software está rodando, a qual está correta. Não sei porque o componente gera essa hora a mais, em determinadas máquinas.

O componente não faz isso... verifique como está alimentando a tag dEmi.

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

Pessoal, eu creio que posso ter encontrado o problema, porque vi mais uma pessoa nessa mesma situação. Eu pego a data e hora pelo Firebird SELECT CURRENT_TIMESTAMP AS DATAHORA FROM RDB$DATABASE e talvez esse comando esteja trazendo para alguns 1h adiantada.

Alguém aí já passou por isso ou sabe como evitar?

Link to comment
Share on other sites

  • Moderadores

Obrigado por reportar.
Fechando o tópico. Para nova dúvida abra um novo tópico.

 


logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Link to comment
Share on other sites

  • Este tópico foi criado há 451 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.