Jump to content
Notícias do ACBr

logos

Texto.png

p200

logos

Texto.png

p200

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

Recommended Posts

  • Usuários SAC

Bom dia!

Estou recebendo a seguinte mensagem de erro ao executar a transmissão da NFSe, tanto na minha aplicação como no demo do ACBR:

---------------------------
Demo_acbrnfse
---------------------------

Erro Interno: 0
Erro HTTP: 400
URL: https://producao.ginfes.com.br/ServiceGinfesImpl

---------------------------
OK   
---------------------------
 

Link to post
Share on other sites

Boa tarde Marcio,

O componente esta configurado corretamente?

Esta atribuindo o valor libWinCrypt para SSLLib e o valor TL_TLSv1_2 para SSLType?

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to post
Share on other sites

Bom dia Marcio,

Pelas suas imagens notei que esse programa exemplo é bem antigo.

Você esta com todos os fontes de todas as pastas atualizados?

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to post
Share on other sites

Boa tarde @zemarcio,

Erro 400 BadRequest significa que algo que foi enviado na requisição não pode ser entendido pelo servidor de destino, assim gerando o erro.

- Por favor, verifique se você está com a ultima versão do ACBr em execução.

- Por favor, verifique se não está informando caracteres especiais, vários provedores tem problema com & (e comercial), se tiver caracteres especial, remova o mesmo e faça novamente a transmissão.

 

Abraços

Att.

Victor H. Gonzales - Pandaaa

"Aprender é a única coisa que a mente nunca se cansa, nunca tem medo e nunca se arrepende” - Leonardo da Vinci

"Ter sucesso é falhar repetidamente, mas sem perder o entusiasmo"

Link to post
Share on other sites
  • 2 weeks later...
  • Usuários SAC

Bom dia!

Já atualizei o componente para a versão mais recente e o erro apresentado foi esse:

 

Erro Interno: 0
Erro HTTP: 400
URL: https://producao.ginfes.com.br/ServiceGinfesImpl

<html>
<head><title>400 No required SSL certificate was sent</title></head>
<body bgcolor="white">
<center><h1>400 Bad Request</h1></center>
<center>No required SSL certificate was sent</center>
<hr><center>nginx</center>
</body>
</html>

Link to post
Share on other sites

Boa tarde,

está informando que para consumir esse serviço, você precisa informar um certificado e no caso não tem nenhum informado.

verifica se você está carregando o certificado digital do cliente antes de enviar o rps

Abraços

Att.

Victor H. Gonzales - Pandaaa

"Aprender é a única coisa que a mente nunca se cansa, nunca tem medo e nunca se arrepende” - Leonardo da Vinci

"Ter sucesso é falhar repetidamente, mas sem perder o entusiasmo"

Link to post
Share on other sites
×
×
  • Create New...