Jump to content

dev botao

SEFAZ retornando chave diferente da enviada


Go to solution Solved by Italo Giurizzato Junior,
  • Este tópico foi criado há 891 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Administradores

Boa tarde.

Por favor anexe os XMLs

At.

Consultora SAC ACBr

Juliana Tamizou

Gerente de Projetos ACBr / Diretora de Marketing AFRAC
Ajude o Projeto ACBr crescer - Seja Pro

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

  • Membros Pro
13 minutos atrás, Juliana Tamizou disse:

Boa tarde.

Por favor anexe os XMLs

At.

 

gerado.xml.xml Processado.xml

4 minutos atrás, Italo Giurizzato Junior disse:

Boa tarde,

É a sua aplicação que esta gerando o XML?

Sim... Gero um INI com com os dados e utilizo a função NFe.CriarNFe para gerar o xml...

Link to comment
Share on other sites

  • Consultores
  • Solution

Muito estranho, pois o XML que você anexou com o nome "gerado" o tipo de emissão da nota esta com o valor 9 = Offline e consequentemente o Digito Verificador é um, já o outro XML o tipo de emissão esta com o valor 1 = Normal que condiz com o valor da tag <tpEmis>.

Analisando tanto o código do ACBrMonitor quanto o código do componente ACBrNFe que é utilizado pelo monitor, não encontrei não que pudesse provocar esse problema.

O XML "gerado" não teve a sua chave alterada pela sua aplicação e depois o mesmo foi carregado para ser enviado para a SEFAZ?

Consultor SAC ACBr

Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Araraquara - A era dos Trólebus

Link to comment
Share on other sites

  • Membros Pro

Não altero o xml de retorno.... Sempre faço a copia da pasta acbr para arquivar...

No caso da tpEmis: Pode ter ocorrido uma falha na transmissão (internet, sefaz, etc)... Como a aplicação é um bot que monitora o banco, posso ter copiado o xml errado (para disponibilizar aqui)... Vou checar.

  • Like 1
Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

The popup will be closed in 10 seconds...