Jump to content

faabiioojr

Membros
  • Content Count

    10
  • Joined

  • Last visited

Community Reputation

1 Neutral

About faabiioojr

  • Rank
    Novato
  • Birthday 05/05/1992

Profile Information

  • Sexo
    Masculino
  • Localização
    recife/pe
  1. Obrigado amigo, é isso mesmo, eu coloquei o CFOP errado de propósito que era para provocar o erro mesmo.. Esse método que vc informou retornou o texto mais bonito e amigável, era justamente isso que estava buscando! Vlw mesmo!
  2. Boa tarde, já procurei muito mas não encontrei nenhuma resposta então decidi postar um tópico... Antes de enviar a NFCe, eu utilizo o método "GerarNfe, depois Assinar e depois validar" para verificar se está tudo certo com o xml, antes de usar o método "enviar", pois geralmente, quando tento enviar uma nota e tem algum erro, aquela numeração fica perdida, e acaba quebrando a sequência... Só que, ao validar uma xml com erro, o retorno que obtenho é nesse tipo: Erro: Falha na validação dos dados da nota: 15189 '0000' violates pattern constraint of '[1,2,3,5,6,7]{1}[0-9]{3}'. The element '{http://www.portalfiscal.inf.br/nfe}CFOP' with value '0000' failed to parse. E ao utilizar o método enviar, o retorno que recebo, é mais elaborado, e me informa qual o item que está com problemas, e o texto é mais claro, nesse caso, informando que o CFOP do item 2 está incorreto... Teria como pegar o retorno no método "validar" desta mesma forma que retorna o "enviar"? Obrigado!
  3. Pessoal, o "SEM GTIN" eu coloco só no EANTrib ou no EAN tbm?
  4. estou com o mesmo problema, certificado: A3
  5. eu também estou com problemas nesse sentido, preencho mas não aparece, nem usuario, nem tributos, nem sistema...
  6. Olá, estou com dificuldades ao imprimir a NFC-e. Consigo Enviar normalmente, verifico os dados dos xmls estão todos corretos, porém na hora de imprimir acontecem alguns erros principalmente ao dar desconto no item. Na imagem abaixo, o desconto é de 6 reais, mas por algum motivo fica aparecendo um número que nem sei de onde vem.. Outro problema é no valor total do produto, ele já está indo com o desconto, quando na verdade era pra ir apenas a quantidade X valor do produto... e o xml está todo correto, mas quando vou imprimir acontece esses problemas.. Além de que existem funções que não estão saindo, como por exemplo usuário, tributos federais, municiais, eu associo os valores ao componente porém ele não os imprime... estou utilizando o componente: ACBrNFeDANFEFR1.. Alguem poderia me ajudar? Obrigado!
  7. tem alguma documentação de como usar o ACBrNCMs ? Obrigado!
×
×
  • Create New...