Jump to content

click.png click.png click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

Erro: Codigo Identificador do CSC no QR-Code nao cadastrado na SEFAZ


  • Este tópico foi criado há 1444 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa tarde, estou recebendo o erro "Codigo Identificador do CSC no QR-Code nao cadastrado na SEFAZ" ao tentar enviar uma NFC-e emitida em contingencia, porém o CSC está correto..

QrCode do XML:

<qrCode><![CDATA[http://www.dfeportal.fazenda.pr.gov.br/dfe-portal/rest/servico/consultaNFCe?chNFe=41160817434050000180650010000015969000015960&nVersao=100&tpAmb=1&dhEmi=323031362d30382d31355431363a31383a33342d30333a3030&vNF=35.40&vICMS=0.00&digVal=683361773868397a793034664457474c655835327a494f5a414a303d&cIdToken=000001&cHashQRCode=78F4C2E6A94FC77B59607D23B43683AC994742B7]]></qrCode>

Alguém sabe o que pode ser?

 

Grato

Link to comment
Share on other sites

12 minutos atrás, André Ferreira de Moraes disse:

Verifique se o CASE(letras maiúsculas e minúsculas) do CSC foi informado corretamente ao componente.

Ele está sendo passado todo em maiúsculo, e o mesmo funciona normalmente caso a nota seja enviada sem entrar em contingencia. 

Link to comment
Share on other sites

26 minutos atrás, Andre Luiz Oliveira disse:

Só uma observação ambiente de Homologação e Produção o CSC se não me engano é diferente.

Por isso em contingencia ele vai 

O token em produção é diferente, mas como eu disse acima, o envio normal, com o mesmo token no ambiente de homologação está funcionando corretamente.

Link to comment
Share on other sites

  • 11 months later...

Estou com esse mesmo problema relatado para a SEFAZ RS, enviando NFC-e de forma normal ocorre tudo certo, quando envia as que estao em contingencia da esse erro.

Nao altero nada no xml, Utilizo o envio da seguinte forma:

ACBrNFe1.NotasFiscais.Clear;
ACBrNFe1.NotasFiscais.LoadFromFile(sxml);
ACBrNFe1.Enviar('1', False, False); 

e ele esta trocando o campo idToken de 000001 para 000000, nao sei o motivo.

Edited by LeonardoZanella
Link to comment
Share on other sites

  • Moderadores
4 horas atrás, LeonardoZanella disse:

Pelo que precebi nao e problema no SEFAZ e sim do componente que na hora de chamar o metodo enviar ele ta trocando o idToken para 000000

Está configurando o CSC e IdCSC no componente antes de chamar o método Enviar? 

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

Complementando...

A informação do Token fica 000000 depois de ler o XML?

ACBrNFe1.NotasFiscais.Clear;
ACBrNFe1.NotasFiscais.LoadFromFile(sxml); // Seria aqui?

if  ACBrNFe1.Configuracoes.Geral.IdCSC='0000'  then
begin
   ACBrNFe1.Configuracoes.Geral.CSC := 'dados do CSC';
   ACBrNFe1.Configuracoes.Geral.IdCSC  := 'id CSC';
end;

ACBrNFe1.Enviar('1', False, False); 

Tentou desta forma?
 

_____________

Prates, Agnaldo

Link to comment
Share on other sites

  • 1 month later...
  • Este tópico foi criado há 1444 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.