Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

Erro na NFC-e 4.0


  • Este tópico foi criado há 1679 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Olá a todos,

Acabo de atualizar meu componente. Fui no ACBRNFe1 e setei a versão do mesmo para ve400, além de reapontar o Schemas para o novo C:\ACBR\Exemplos\ACBrDFe\Schemas

A princípio tentei compilar com o código que já uso normalmente para o NFC-e na versão 3.10, deu erro na validação dos dados...

Fui examinar o XML e na parte de impostos está gerando assim:

<imposto>
	<ICMS>
		<ICMSSN>
			<orig>0</orig>
			<CSOSN>0</CSOSN>
		</ICMSSN>
	</ICMS>
</imposto>

Alguém sabe me informar o que mais devo fazer?

Desde já agradeço a atenção de todos

Link to comment
Share on other sites

  • Membros Pro

Olá Italo, tudo bom?

Então, estou tentando usar o ACBrNFe_demo, mas só recebo o erro abaixo ao validar:

Citar

Exception: "Validar" não suportado em: TDFeSSLXmlSignClass
Erro: 
Erro Completo: 

Aí eu fui em https://www.sefaz.rs.gov.br/nfe/nfe-val.aspx para fazer a validação... O erro de validação que recebo lá é o seguinte:

Schema XML: The element 'ICMS' in namespace 'http://www.portalfiscal.inf.br/nfe' has invalid child element 'ICMSSN' in namespace 'http://www.portalfiscal.inf.br/nfe'. List of possible elements expected: 'ICMS00, ICMS10, ICMS20, ICMS30, ICMS40, ICMS51, ICMS60, ICMS70, ICMS90, ICMSPart, ICMSST, ICMSSN101, ICMSSN102, ICMSSN201, ICMSSN202, ICMSSN500, ICMSSN900' in namespace 'http://www.portalfiscal.inf.br/nfe'.

Caminho: NFe[1]/infNFe/det[1]/imposto/ICMS/ICMSSN
Link to comment
Share on other sites

  • Consultores
29 minutos atrás, doidopb disse:

Exception: "Validar" não suportado em: TDFeSSLXmlSignClass
Erro: 
Erro Completo: 

Quais as configurações SSL está utilizando para o Certificado? Está gerando o XML pelo ACBrNFe_demo? anexe o XML se possível...

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro

Então José, recebi o erro do "Não Suportado em : TDFeSSLXmlSignClass" ao tentar usar o botão Validar XML pelo ACBrNFe_demo.

Agora que mencionou as configurações SSL, estava libNone, coloquei libCapicom agora e foi.

Citar

 

Exception: Falha na validação dos dados da nota: 424

Erro: Falha na validação dos dados da nota: 424

Erro Completo: Falha na validação dos dados da nota: 424

Element '{http://www.portalfiscal.inf.br/nfe}ICMSSN' is unexpected according to content model of parent element '{http://www.portalfiscal.inf.br/nfe}ICMS'.
Expecting: {http://www.portalfiscal.inf.br/nfe}ICMS00, {http://www.portalfiscal.inf.br/nfe}ICMS10, {http://www.portalfiscal.inf.br/nfe}....

 

O erro é na parte do XML que citei acima. Segue XML em anexo.

erro-nfe.xml

Link to comment
Share on other sites

  • Consultores

Boa tarde,

Ao clicar no botão Validar, o XML foi gerado e assinado?

Lembre-se que agora o componente exige que o XML esteja assinado para poder realizar a validação.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Membros Pro

Então Italo, como disse estou reaproveitando todo o meu código, só atualizei o componente e setei os parâmetros pertinentes para a versão 4. Delphi 2010

No meu aplicativo eu faço o seguinte (sempre funcionando com a 3.10):

Citar

ACBrNFe1.NotasFiscais.Clear;
ACBrNFe1.Configuracoes.Geral.FormaEmissao := teNormal ;
GerarNFCe(IntToStr(cupom), False);

Nessa procedure GerarNFCe eu uso os comandos para alimentar as tags do componente e no final executo o comando "ACBrNFe1.NotasFiscais.GerarNFe;". Não faço nada além disso. Não uso nem Validar e nem Assinar, logo em seguida o componente me retorna o erro "Falha na validação dos dados da nota XXX".

Aí uso o ACBrNFe_demo para verificar o que ocorreu de errado, e o problema está lá na tag imposto, ele não está atribuindo o CSOSN 102 e nenhum outro.

Edited by doidopb
Link to comment
Share on other sites

  • Membros Pro

Senhores... Desconsiderem o tópico, o código que usava antes da versão 3.10 funcionou perfeitamente na versão 4.00...

A culpa foi minha, eu havia mexido nas configurações de tributação na base que uso para teste, isso foi mês passado, eu esqueci e gerou toda essa confusão.

Funcionou tudo aqui.

Abraços

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.