Jump to content

dev botao

NT 2017.002 e fim SSL


  • Este tópico foi criado há 2253 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Bom dia.

Sobre o fim do aceite do SSL em troca do TLS 1.2 previsto para 02/04, qual a configuração correta do ACBrCTe em relação aos protocolos? Estou usando no Delphi 7:

SSLCryptLib cryCapicom

SSLHttpLib httpWinNet

SSLib libCapicom

SSLXmlSignLib xsMsXmlCapicom

Obrigado.

 

Paulo Cesar Penatti.

Ibiúna-SP.

 

Link to comment
Share on other sites

  • Consultores

Bom dia Paulo,

A minha sugestão é que você atribua o valor libWinCrypt a propriedade SSLLib e deixe as demais como defaut.

Podendo variar o valor de SSLXmlSignLib de xsMsXml para xsLibXml2.

Consultor SAC ACBr

Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Araraquara - A era dos Trólebus

Link to comment
Share on other sites

  • Consultores

Paulo,

Dependendo do valor de SSLLib as demais recebem automaticamente um valor default.

Consultor SAC ACBr

Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Araraquara - A era dos Trólebus

Link to comment
Share on other sites

  • Consultores

Bom dia Paulo,

Segundo a NT 2017/002 versão 1.02 deixa claro que a partir do dia 02/04/2018 só vai aceitar conexão TLS, sendo assim é preciso configurar corretamente o componente.

Se o CT-e for aceito pela SEFAZ, depois dessa data e mediante configuração, podemos concluir que a SEFAZ esta sim recebendo o CT-e através dessa conexão.

Para testar basta configurar o componente., no que diz respeito ao Type SSL.

Consultor SAC ACBr

Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Araraquara - A era dos Trólebus

Link to comment
Share on other sites

Desculpe, não me expressei bem, digo como testar antes do prazo final de 02/04, nesta semana por exemplo?

Alterando conforme indicou o componente ficou assim:

SSLCryptLib - cryWinCrypt

SSLHttpLib - httpWinHttp

SSLib - libWinCrypt

SSLXmlSignLib - xsLibXml2

 

Paulo Cesar Penatti.

Ibiúna-SP.

 

Link to comment
Share on other sites

  • Consultores

Boa tarde Paulo,

E com essa configuração o envio ocorreu com sucesso?

Qual é o valor de SSL Type?

Consultor SAC ACBr

Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Araraquara - A era dos Trólebus

Link to comment
Share on other sites

Agradeço sua boa vontade com meu despreparo mas não setei a variável SSLType e vi comentários no fórum aberto sobre ela em relação à NF-e 4, também sobre compatibilidade com .Net framework e parâmetros no Internet Explorer.

Devo setá-la como no exemplo ACBr? Qual o valor correto?

Um teste rápido em homologação funcionou sem atribuir valor.

Obrigado.

Edited by pcpenatti

Paulo Cesar Penatti.

Ibiúna-SP.

 

Link to comment
Share on other sites

  • Consultores

Bom dia Paulo,

A configuração do SSL Type só esta disponível quando o valor de SSLLib for libOpenSSL ou libWinCrypt.

O valor LT_All faz com que o componente se utilize do SSL disponível para acessar o WebService.

Mas nada te impede de selecionar o LT_TLSv1 ou LT_TLSv1_1 ou LT_TLSv1_2.

A minha sugestão é selecionar a opção LT_TLSv1_2 pois é esta que segundo a Nota Técnica diz que será utilizada.

 

Consultor SAC ACBr

Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Araraquara - A era dos Trólebus

Link to comment
Share on other sites

Boa tarde.

Testando as alterações dos protocolos, funcionou em minha cpu onde o ACBr/Delphi7 estão instalados (homologação e produção), mas na cpu do cliente retorna o erro de "schema inválido". A versão com SSL funciona normalmente.

Usando o pacote PL_CTe_300_NT2017.002 em ambas as cpus. Alguma outra alteração exceto os parâmetros acima no componente?

Obrigado.

Edited by pcpenatti

Paulo Cesar Penatti.

Ibiúna-SP.

 

Link to comment
Share on other sites

  • Consultores

Boa tarde Paulo,

Tentou renomear o arquivo com o sufixo -OpenSSL?

tiposGeralCTe_v3.00.xsd para tiposGeralCTe_v3.00-old.xsd

e

tiposGeralCTe_v3.00-OPENSSL.xsd para tiposGeralCTe_v3.00.xsd

Consultor SAC ACBr

Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Araraquara - A era dos Trólebus

Link to comment
Share on other sites

Estou usando os schemas do portal do CT-e e neles não consta o arquivo tiposGeralCTe_v3.00-OPENSSL.xsd, mas pelo que vi está na pasta de schemas do acbr.

Fiz testes antes e alterei no acbrcte.sslxmlsignlib  de xsLibXml2 para xsMsXml e funcionou, ficando assim:

SSLCryptLib - cryWinCrypt

SSLHttpLib - httpWinHttp

SSLib - libWinCrypt

SSLXmlSignLib - xsMsXml

SSLType -  LT_TLSv1_2

schemas - PL_CTe_300_NT2017.002

Como seria melhor proceder? Tendo funcionado como acima devo usar o schema acbr renomeando o xsd?

O que muda de xsLibXml2 para xsMsXml?

Obrigado. 

Edited by pcpenatti

Paulo Cesar Penatti.

Ibiúna-SP.

 

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.