Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

click.png

click.png

click.png

classe nao registrada


Go to solution Solved by Rafael Dias,
  • Este tópico foi criado há 1061 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

pessoal tem um montao de topicos sobre isso, mas juro que nao cheguei a uma conclusao, ou melhor acredito que ate sei mas é o seguinte com todas essas atualizacoes da nfe4, em alguns micros com win7 sp1, com A3 aparece o erro de classe nao registrada, configurado assim

  ACBrNFe.Configuracoes.Geral.SSLLib                := libWinCrypt;
  ACBrNFe.Configuracoes.Geral.SSLCryptLib           := cryWinCrypt;
  ACBrNFe.Configuracoes.Geral.SSLHttpLib            := httpWinHttp;

  ACBrNFe.Configuracoes.Geral.SSLXmlSignLib := xsMsXml;
  ACBrNFe.SSL.SSLType                       := LT_TLSv1_2

é falta de atualização do windows ?

obrigado

 

Link to comment
Share on other sites

  • Consultores

Boa tarde Felipe,

Se trata de um erro de validação ou a SEFAZ retornou uma rejeição de Schema invalido?

Favor anexar o XML da nota.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

Muito obrigado pela resposta italo

esse erro schema invalido esta acontecendo em alguns micros e em outros não, isso na mesma rede, nos micros que aparece esse erro, estou colocando a pasta schemas no disco local e no sistema quando existe essa pasta pego então no disco local senao carrego do servidor, mas porque em alguns funciona pelo servidor e em outros não será ?

abs

 

 

 

Link to comment
Share on other sites

  • Consultores

Felipe,

Você esta mapeando uma unidade de rede para acessar a pasta que contem os schemas no servidor?

Se não esta esse é o problema.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

mt obrigado Italo e rafael dias pela resposta

mas galera porque sera que na mesma rede tem estação que funciona sem precisar mapear ou mesmo copiar os schemas no disco local ? isso que me intrigou nesse caso.

e aproveitando o que voces recomendam mapear ou copiar os schemas na estação ?

abs

 

 

Link to comment
Share on other sites

  • Consultores
  • Solution

É problema antigo da libXml2 ela não consegue carregar todos o Schemas.

Eu geralmente deixo no servidor e toda vez que abro o programa copio local para evitar usuário fazendo o que faz de melhor.

  • Like 1
Consultor SAC ACBr Rafael Dias
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Desenvolvedor ACBrLib.

 

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.