Acbr No Delphi Xe5

62 posts in this topic

Posted

Prezados,

 

Alguma previsão de liberação do instalador para reconhecer o Delphi XE5?

 

Att,

Alessandro Fazenda

Share this post


Link to post
Share on other sites

Posted

O ACBr, pode ser instalado manualmente no XE5, pelo ACBrInstall teremos que esperar o JEDI sair para XE5, pois usamos ele no ACBrInstall.

Share this post


Link to post
Share on other sites

Posted

O Jedi ja suporta o  DELPHI XE5 conforme informado no repositório dos componentes

Share this post


Link to post
Share on other sites

Posted

Tentei pelo instalador mais não conseguir...

Share this post


Link to post
Share on other sites

Posted

O instalador ainda não foi recompilado para XE5, estamos aguardando a liberação da biblioteca Jedi que utilizados para reconhecer o XE5 para recompilar o instalador.

Share this post


Link to post
Share on other sites

Posted

O instalador ainda não foi recompilado para XE5, estamos aguardando a liberação da biblioteca Jedi que utilizados para reconhecer o XE5 para recompilar o instalador.

 

Ola Regys baixei a ultima versão do jedi do GitHub e já está funcionando no XE5 ja instalei e estou testando o JEDI.

 

Abraços

Share this post


Link to post
Share on other sites

Posted (edited)

Segue minha colaboração segue em anexo os fontes do ACBrInstall alterado para ser compatível com o XE5, e também o exe gerado por mim.

 

Link do instalador:

http://www.lsisistemas.com.br/downloads/ACBrInstall.exe

 

Se estiver funcional podemos esperar para o pessoal do acbr adicionar no svn.

 

Abraços

ACBrInstall.rar

Edited by Sergioguedes

Share this post


Link to post
Share on other sites

Posted

Versões extras oficiais podem ser disponibilizadas no fórum a vontade, mas as alterações ou contribuições, só subirão para o repositório quando a suite JEDI for disponibilizada no site oficial, pois não podemos lançar versão do ACBrInstall se a suite que é o motor dele ainda está em versão beta, esse é nosso compromisso com nossos usuários que tentamos dentro do possível seguir.

2 people like this

Share this post


Link to post
Share on other sites

Posted (edited)

Tentei instalar manualmente os componentes , porem esta ocorrendo erro com os pacotes Fast Repot, adicionei no componente

{$IFDEF VER260} fs19, frx19, frxe19, frxDB19, {$ENDIF} // XE5, mas mesmo assim esta ocorrendo erro ao compilar.

 

 

Forma, dialogs ..etc.  tive que colocar VCL.forms,  vcl.dialogs,  ai funcionou

 

 

 

Obrigado.

Edited by medreis

Share this post


Link to post
Share on other sites

Posted

Qual o erro?

Share this post


Link to post
Share on other sites

Posted

Tentei instalar manualmente os componentes , porem esta ocorrendo erro com os pacotes Fast Repot, adicionei no componente

{$IFDEF VER260} fs19, frx19, frxe19, frxDB19, {$ENDIF} // XE5, mas mesmo assim esta ocorrendo erro ao compilar.

 

 

Forma, dialogs ..etc.  tive que colocar VCL.forms,  vcl.dialogs,  ai funcionou

 

 

 

Obrigado.

 

Realmente está acontecendo esse erro, a partir do XE2 foi adicionado essa nova mudança de nomespace no delphi, mais não estava apresentando problemas até o XE4, deve ter acontecido alguma mudança no XE5.

 

Segue em anexo uma alteração que fiz para contornar e solucionar esse problema, será a mais correta?

 

Ex:

unit ACBrNFeDANFEFR

  {$IF CompilerVersion >=16.0} // Maior ou Igual que o Delphi XE2
   VCL.forms, vcl.dialogs,
   {$ELSE}
   forms, dialogs,
   {$ENDIF}

unit ACBrNFeDANFEFRReg;

  {$IFDEF VisualCLX} QDialogs {$ELSE}

  {$IF CompilerVersion >=16.0} // Maior que Delphi XE2
    vcl.dialogs
   {$ELSE}
    dialogs
   {$ENDIF}

  {$ENDIF},

Abraços

ACBrNFe2.rar

Share this post


Link to post
Share on other sites

Posted

Já esta disponível a versão do ACBrInstall para XE5, subi ontem a noite.

2 people like this

Share this post


Link to post
Share on other sites

Posted (edited)

Já esta disponível a versão do ACBrInstall para XE5, subi ontem a noite.

 

Isaque chegou a verificar se essas minhas mudanças no danfe do Fast report são realmente necessárias? Porque não foi nada alterado no danfe quando baixei pelo svn. abraços

Edited by Sergioguedes

Share this post


Link to post
Share on other sites

Posted

A instalação está funcionando perfeitamente.

Share this post


Link to post
Share on other sites

Posted

eu instalei o acbr no xe5 normal, mas quando vou abrir o delphi ele começa a carregar e aparentemente no momento de carregar os pacotes do acbr

ele fecha e abre este site www.embarcadero.com%2Fproduct-validation-error

alguem pode me ajudar ?

Share this post


Link to post
Share on other sites

Posted

eu instalei o acbr no xe5 normal, mas quando vou abrir o delphi ele começa a carregar e aparentemente no momento de carregar os pacotes do acbr

ele fecha e abre este site www.embarcadero.com%2Fproduct-validation-error

alguem pode me ajudar ?

Você parece estar com uma licença inválida, entre em contato com a Embarcadero para conferir se não há problema algum com a sua licença.

Share this post


Link to post
Share on other sites

Posted

Não estou conseguindo instalar o Danfe para Delphi XE5

Share this post


Link to post
Share on other sites

Posted

Não estou conseguindo instalar o Danfe para Delphi XE5

 

Você precisa dar mais informações, qual modelo de DANFE está tentando instalar?

Share this post


Link to post
Share on other sites

Posted

stanleyalves, verifica se você instalou um dos suites necessários (QuickReport ou FastReport ou Rave). Sem não conter nenhum instalado, não vai funcionar mesmo !

 

Share this post


Link to post
Share on other sites

Posted

Nós compramos o Delphi XE5 com update2 que vem com o FastReport, alguém poderia me ajudar?

Share this post


Link to post
Share on other sites

Posted

e qual seria seu problema? utilizou o ACBrInstall?

 

Nós compramos o Delphi XE5 com update2 que vem com o FastReport, alguém poderia me ajudar?

Share this post


Link to post
Share on other sites

Posted

Estou com problemas no XE5 update 2 tambem. Instala normalmente, mas ao carregar o XE5 gera o erro Can´t load package C:\|Users\Public\Documents\RAD Studio\12.0\Bpl\ACBr_Boleto.bpl. Access violation at address 17A37FD9 in module 'rtl180.bpl'.

 

O mesmo erro esta acontecendo nos pacotes:

 

-ACBrCTePCN

-ACBrMDFe

-ACBRNFePCN2

-ACBRNFSe

-ACBRTCP

-TEFD

-ACBr Automacao Comercial Brasil

-ACBrBoletoFC FastReport

-ACBrCTeDacteFR

-ACBrNFeDanfeFR

-ACBrNFSeDANFSer

 

Obrigado.

Share this post


Link to post
Share on other sites

Posted

Você fez alguma coisa de diferente, acabou excluindo path que não deveria da library ou algo do genero?

rodou o ACBrinstall como administrador?

Share this post


Link to post
Share on other sites

Posted

Juliomar Marchetti, essa mensagem de erro foi logo apos instalar com o Delphi fechado. Assim que rodei o mesmo ja apareceu as mensagens de erro. So que nao tinha instalado como administrador. Ae vi sua mensagem, desinstalei os componentes, rodei como admistrador mas continua dando o mesmo erro.

Share this post


Link to post
Share on other sites

Posted

Não estou conseguindo instalar o Danfe para Delphi XE5

 

Bom dia!

 

Eu também tive problemas para instalar os DANFES (Rave) e (QuickReport) no Delphi XE5.

 

Só consegui resolver, abrindo o Dpk de cada projeto removendo a uses e adicionando a nova Uses das respectivas verões do Rave e do QuickReport que eu utilizo, ai funcionou perfeitamente.

 

Abraço!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now