Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

Retorno Consulta - Ocorrencia 102


arce
  • Este tópico foi criado há 1247 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa tarde

Ao realizar a consulta de um lote transmitido com sucesso, está retornando o seguinte erro.

 Ocorrencia 
   Código:102
   Descrição: O Evento informado não foi reconhecido pelo sistema.
Ação Sugerida: Verificar se o evento informado esta de acordo com a Tabela 9 (Tipos de Arquivo do eSocial) do eSocial.
   Tipo: 1
   Localização:

Seria uma falha do servidor da receita ou alguma inconsistência do arquivo q estou enviando?
Segue o XML do retorno e do evento S-1000

RespConsulta-154811_827.xml

S1000.xml

Link to comment
Share on other sites

Pela mensagem de retorno, diz que o schema é que está inválido http://www.esocial.gov.br/schema/evt/evtInfoEmpregador/v02_02_02

Não seria a versão 2.3 que está em teste agora?

Tem também um forum do eSocial que o pessoal tem movimentado bastante.

Caso ainda não tenha cadastro nele,  envie um email para [email protected] informando o Nome da Empresa, CNPJ, Telefone, o seu nome e email.

Abs

 

 

 

 

 

Link to comment
Share on other sites

Mudei para a versão 2.3.0 e também troquei os schemas de acordo com cada versão, e o erro permaneceu. 

Acredito que o problema seja em relação aos schemas do Pacote de Transmissão.

Pacote de Comunicação eSocial

Estes são as versões dos schemas de transmissão, minha dúvida é qual deles usar nas versões 2.2.2 e 2.3.0?

Link to comment
Share on other sites

  • 1 month later...

Bom dia amigos, estou com o mesmo problema.

O Evento informado não foi reconhecido pelo sistema.
Ação Sugerida: Verificar se o evento informado e a versão do leiaute estão de acordo com a Tabela 9 (Tipos de Arquivo do eSocial) do eSocial.

Porem ja tentei todas as opções encontrada no forum e ainda sem sucesso. 
qual versão deveria enviar pra produção restrita?
Seria essa: http://www.esocial.gov.br/schema/lote/eventos/envio/v02_04_01 
ou o erro acima não se refere a isso?

 

agradeço.

 

Link to comment
Share on other sites

3 minutos atrás, Geovane Holior disse:

Bom dia amigos, estou com o mesmo problema.

O Evento informado não foi reconhecido pelo sistema.
Ação Sugerida: Verificar se o evento informado e a versão do leiaute estão de acordo com a Tabela 9 (Tipos de Arquivo do eSocial) do eSocial.

Porem ja tentei todas as opções encontrada no forum e ainda sem sucesso. 
qual versão deveria enviar pra produção restrita?
Seria essa: http://www.esocial.gov.br/schema/lote/eventos/envio/v02_04_01 
ou o erro acima não se refere a isso?

 

agradeço.

 

Deverá enviar com a versão v02_04_01

Os esquemas tbm foram atualizados

http://portal.esocial.gov.br/manuais/esquemas-xsd-esocial-v2-04-01-24-11-2017.zip

Link to comment
Share on other sites

10 minutos atrás, Joceandro Perin disse:

Deverá enviar com a versão v02_04_01

Os esquemas tbm foram atualizados

http://portal.esocial.gov.br/manuais/esquemas-xsd-esocial-v2-04-01-24-11-2017.zip

@Joceandro Perin obrigado pelo retorno,

Mas estou enviando exatamente essa versão, mas o retorno é o mesmo:

"O Evento informado não foi reconhecido pelo sistema.
Ação Sugerida: Verificar se o evento informado e a versão do leiaute estão de acordo com a Tabela 9 (Tipos de Arquivo do eSocial) do eSocial."

em anexo o xml que estou enviando:

teste.xml

Link to comment
Share on other sites

8 minutos atrás, Geovane Holior disse:

@Joceandro Perin obrigado pelo retorno,

Mas estou enviando exatamente essa versão, mas o retorno é o mesmo:

"O Evento informado não foi reconhecido pelo sistema.
Ação Sugerida: Verificar se o evento informado e a versão do leiaute estão de acordo com a Tabela 9 (Tipos de Arquivo do eSocial) do eSocial."

em anexo o xml que estou enviando:

teste.xml

verifica os campos que vc está enviando pois o xml está errado. Por exemplo o campo multTabRubricas não existe mais na versão 2.4.1.

Link to comment
Share on other sites

@Geovane Holior pelo que eu vi no seu XML 

 

- <evento Id="ID1021463110000002017112215511000001">
- <evtInfoEmpregador Id="ID1021463110000002017112215511000001">
 
ali esta v02-02-02
 

Att,

Renato

 

http://www.edsonbill.com

Link to comment
Share on other sites

Exato, tem algumas inconsistências nos teus XMLs, outro detalhe..

no lugar de <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:v1="http://www.esocial.gov.br/schema/lote/eventos/envio/v02_04_01">
tem que ser <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:v1="http://www.esocial.gov.br/schema/lote/eventos/envio/v1_1_1">

também você esta assinando com sha1, e deve ser com sha256

Link to comment
Share on other sites

2 horas atrás, Joceandro Perin disse:

Exato, tem algumas inconsistências nos teus XMLs, outro detalhe..

no lugar de <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:v1="http://www.esocial.gov.br/schema/lote/eventos/envio/v02_04_01">
tem que ser <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:v1="http://www.esocial.gov.br/schema/lote/eventos/envio/v1_1_1">

também você esta assinando com sha1, e deve ser com sha256

@Joceandro Perin desculpe, encaminhei o XML errado. estou reenviando o que estou validando. 

E-social-S1000.xml

Link to comment
Share on other sites

  • 5 weeks later...
22 horas atrás, LUIZTEC disse:

Bom dia,

 

Estou com problema no retorno da consulta quando tenho vários eventos, o programa só lê o primeiro recibo. Alguem já passou por isso.

Luiz, bom dia!

Eu passei por esse problema, tive que alterar o TratarResposta do ACBreSocialWebServices para pegar as ocorrencias separadamente:

Na linha 953, tem um while que extrai o "retornoEventos", tem que incluir dentro desse while um outro que extraia o "evento", ficando dessa forma:

while Leitor.rExtrai(1, 'retornoEventos', '', i + 1) <> '' do
begin
    //recepcao

    //While incluído

    while Leitor.rExtrai(1, 'evento', '', i + 1) <> '' do
    begin

      Reader := TLeitor.Create;
       try
         Reader.Arquivo := Leitor.Grupo;

         ...Continua Igual daqui p/ baixo

    end

end;

Aqui no meu está funcionando certinho...

Link to comment
Share on other sites

9 horas atrás, juuninho disse:

Luiz, bom dia!

Eu passei por esse problema, tive que alterar o TratarResposta do ACBreSocialWebServices para pegar as ocorrencias separadamente:

Na linha 953, tem um while que extrai o "retornoEventos", tem que incluir dentro desse while um outro que extraia o "evento", ficando dessa forma:

while Leitor.rExtrai(1, 'retornoEventos', '', i + 1) <> '' do
begin
    //recepcao

    //While incluído

    while Leitor.rExtrai(1, 'evento', '', i + 1) <> '' do
    begin

      Reader := TLeitor.Create;
       try
         Reader.Arquivo := Leitor.Grupo;

         ...Continua Igual daqui p/ baixo

    end

end;

Aqui no meu está funcionando certinho...

Funcionou perfeitamente.

 

Obrigado.

 

Link to comment
Share on other sites

Em 05/01/2018 at 17:21, LUIZTEC disse:

Funcionou perfeitamente.

 

Obrigado.

 

Só complementando, o retorno das ocorrencias está trazendo sempre a primeira ocorrencia. Para acertar isso é só colocar o while da ocorrencia conforme abaixo

(TratarResposta do ACBreSocialWebServices):

 

            while Reader.rExtrai(1, 'ocorrencia', '', j + 1) <> '' do
            begin
              Processamento.Ocorrencias.Add;
              Processamento.Ocorrencias.Items[j].xml := Reader.Grupo;
              Processamento.Ocorrencias.Items[j].FLeitor.Arquivo := Reader.Grupo;
              Processamento.Ocorrencias.Items[j].FLeitor.Grupo := Reader.Grupo;
              Processamento.Ocorrencias.Items[j].LerXml;
              inc(j);
            end;
 

Link to comment
Share on other sites

Bom dia pessoal!

Estou com um dúvida, atualmente as consultas só podem ser feitas pelo número de protocolo correto?

Aconteceu um caso nos meus testes. O servidor demorou pra responder e não conseguir pegar a resposta, mas o evento autorizou na receita.

Quando fui tentar enviar meu evento novamente com a TAG "inclusao" ele retornou que o "ID" já estava cadastrado no período. Nesse caso não tenho o protocolo de autorização para consultar  se o evento está autorizado na fazenda. 

Eu devo enviar com a TAG " alteracao" e pegar o novo número de protocolo ou existe uma forma que eu consiga pegar o número de protocolo pelo "ID".

Obrigado!

Link to comment
Share on other sites

1 hora atrás, LeandroLJM disse:

Bom dia pessoal!

Estou com um dúvida, atualmente as consultas só podem ser feitas pelo número de protocolo correto?

Aconteceu um caso nos meus testes. O servidor demorou pra responder e não conseguir pegar a resposta, mas o evento autorizou na receita.

Quando fui tentar enviar meu evento novamente com a TAG "inclusao" ele retornou que o "ID" já estava cadastrado no período. Nesse caso não tenho o protocolo de autorização para consultar  se o evento está autorizado na fazenda. 

Eu devo enviar com a TAG " alteracao" e pegar o novo número de protocolo ou existe uma forma que eu consiga pegar o número de protocolo pelo "ID".

Obrigado!

Leandro, até onde eu sei, tem uma ferramenta para isso...

O eSocialBX, o usuário vai conseguir retornar tudo que já foi enviado por ele, inclusive os xml's e protocolos envio/recibo...

Só não está disponível ainda, e também não sei quando estará...mas isso é concreto, tanto que tem até no manual de orientações.

  • Like 1
Link to comment
Share on other sites

1 hora atrás, juuninho disse:

Leandro, até onde eu sei, tem uma ferramenta para isso...

O eSocialBX, o usuário vai conseguir retornar tudo que já foi enviado por ele, inclusive os xml's e protocolos envio/recibo...

Só não está disponível ainda, e também não sei quando estará...mas isso é concreto, tanto que tem até no manual de orientações.

Obrigado juuninho! vou dar uma pesquisada sobre o eSocialBX.

Link to comment
Share on other sites

  • Este tópico foi criado há 1247 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.