Jump to content

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png click.png click.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

MDFe não capturando CIOT e contratante


Go to solution Solved by Italo Giurizzato Junior,
  • Este tópico foi criado há 983 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

  • Membros Pro

Boa tarde,

ainda estou tendo problemas com o MDFe. Ele me retorna rejeiçao 578 (Rejeicao: Informacoes dos tomadores e obrigatoria para esta operacao), no manual do contribuinte informa que é envio do manifesto sem informar CIOT e/ou Contratante. Porém estou informando os campos, mas não estão sendo gerados no XML. 

Outra problema que percebi foi que o reboque também não foi adicionado ao xml 

Agradeco desde já a ajuda.

50181109428584000175580000000000011745742788-mdfe.xml

entnfe.txt

MDFe.ini

sainfe.txt

Link to comment
Share on other sites

  • Moderadores

bom dia..

tudo bem..

caso nao de certo.. de uma olhada nos exemplos que estou mandando.

se depois disso nao consegui, mande novamente os arquivos e com alterações pedidas.. 

valeu

 

1101124318110385087400012658001000000135100000337001-procEventoMDFe.xml

43181103850874000126580010000001351000003370-mdfe_trasmitido.xml

ent__CriarEnviarMDFe.txt

ent__CriarMDFe.txt

ent__EncerrarMDFe.txt

ent__IMPRIMIREVENTOPDF.txt

  • Like 1
Link to comment
Share on other sites

  • Consultores
  • Solution

Boa tarde Ignácio,

No seu arquivo INI faça a seguinte alteração:

[ide]
tpAmb=2

tpEmit = 2   <=== inclua essa linha

mod=58

Sem ela o Monitor gera a tag tpEmit com o valor 1 que diz que o tipo de emitente é uma transportadora, portanto devemos relacionar os CT-e.

Atribuindo o valor 2 conforme acima, o Monitor vai gerar a tag tpEmit com o valor 2 que diz que o tipo de emitente é um transportador de carga própria, portanto devemos relacionar as NF-e, como você deseja.

Outra coisa, não esta incluir no XML o reboque porque na seção [reboquexxx] foi informado a quantidade com 3 dígitos sendo que o correto é 2.

[reboque01] e não [reboque001]

Já solicitei a correção do manual do ACBrMonitor.

  • Like 2
Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Membros Pro
2 horas atrás, Italo Jurisato Junior disse:

Boa tarde Ignácio,

No seu arquivo INI faça a seguinte alteração:

[ide]
tpAmb=2

tpEmit = 2   <=== inclua essa linha

mod=58

Sem ela o Monitor gera a tag tpEmit com o valor 1 que diz que o tipo de emitente é uma transportadora, portanto devemos relacionar os CT-e.

Atribuindo o valor 2 conforme acima, o Monitor vai gerar a tag tpEmit com o valor 2 que diz que o tipo de emitente é um transportador de carga própria, portanto devemos relacionar as NF-e, como você deseja.

Outra coisa, não esta incluir no XML o reboque porque na seção [reboquexxx] foi informado a quantidade com 3 dígitos sendo que o correto é 2.

[reboque01] e não [reboque001]

Já solicitei a correção do manual do ACBrMonitor.

Muito obrigado,

Reduzir o digito incluiu o reboque no XML, e também inclui a linha do tpEmit que estava faltando

  • Like 2
Link to comment
Share on other sites

  • Membros Pro

Consegui gerar o MDFe, recebi o retorno como autorizado, mas não consigo fazer a impressão utilizando o comando MDFe.ImprimirdaMDFe e nem através do ACBrMonitorPlus 1.2.0.26, me retorna o erro da image. E se eu tento utilizar o comando que gera PDF ele gera um pdf vazio sem páginas. Preciso buscar algum outro arquivo ou realizar algum outro comando? 

50181109428584000175580000000000011711303501-mdfe.xml

sainfe.txt

ACBrMonitor_2018-11-14_15-37-36.png

Link to comment
Share on other sites

  • Consultores
8 minutos atrás, IGNACIO RODRIGUES disse:

Consegui gerar o MDFe, recebi o retorno como autorizado, mas não consigo fazer a impressão utilizando o comando MDFe.ImprimirdaMDFe e nem através do ACBrMonitorPlus 1.2.0.26, me retorna o erro da image. E se eu tento utilizar o comando que gera PDF ele gera um pdf vazio sem páginas. Preciso buscar algum outro arquivo ou realizar algum outro comando? 

Boa tarde, o comando deve ser:

MDFE.IMPRIMIRDAMDFE(path_XML) passando como parâmetro o path do XML autorizado, da mesma forma para gerar PDF...

Verifique se a impressora está configurada no menu DFe / Impressão / Impressora Padrão

  • Like 1
Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro
16 minutos atrás, Amarildo de Matos disse:

Opa.. faça um debug no seu programa, e veja se nao esta pegando o caminho do xml diferente do que é para ser..

 

Fiz alguns testes, alterando entre aspas simples duplas e entre \\ e / porém tirando os casos onde o arquivo não foi encontrado, o ACBr me mostrou a seguinte tela image.png.9562efa729dda19f423da7765a5c4728.png

Enquanto o arquivo de saida me mostra OK: DAMDFe Impresso com sucesso. E se utilizo do próprio Teste de impressão ele me retorna esta mesma tela. Então acredito que eu possa estar utilizando o XML errado.

50181109428584000175580000000000011711303501-mdfe.xml

Link to comment
Share on other sites

  • Consultores
Em 14/11/2018 at 17:37, IGNACIO RODRIGUES disse:

Continuo a receber o mesmo erro, até quando utilizo da parte de teste do ACBr

Por aqui consigo imprimir seu XML... 

Anexe o seu arquivo ACBrMonitor.ini e o log.txt do ACBrMonitor para análise...

  • Like 1
Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Consultores

Aparentemente a impressora selecionada está compartilhada na rede, experimente utilizar a impressora mapeando a mesma na rede.... Considere desmarcar a opção "Mostrar Preview antes da Impressão" e "MostrarStatus" na aba: DFe/Impresão/Geral 

Verifique se o path do logotipo está acessível....

Algum problema está ocorrendo no momento da geração da imagem para impressão... 

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro
15 minutos atrás, José M. S. Junior disse:

Aparentemente a impressora selecionada está compartilhada na rede, experimente utilizar a impressora mapeando a mesma na rede.... Considere desmarcar a opção "Mostrar Preview antes da Impressão" e "MostrarStatus" na aba: DFe/Impresão/Geral 

Verifique se o path do logotipo está acessível....

Algum problema está ocorrendo no momento da geração da imagem para impressão... 

Retirando o logo o manifesto imprimiu

  • Like 2
Link to comment
Share on other sites

  • Consultores

Bom dia @IGNACIO RODRIGUES,

Sua última postagem foi dividida em outro tópico, pois a dúvida deste já foi esclarecida. Por favor sempre crie novos tópicos para novas dúvidas.

Continuar em 

Att.

  • Like 1
Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

  • Este tópico foi criado há 983 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.