Jump to content

dev botao
  • Este tópico foi criado há 1671 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Administradores

Boa tarde.

Existiam algumas situações nas quais esse erro ocorria mas na vdd não era esse o problema, a versão atual do ACBrMonitor já deve corrigir essa situação.

A mesma está disponível aos usuários do SAC ACBr, ou caso desejar, você pode compilar.

Att.

Consultora SAC ACBr

Juliana Tamizou

Gerente de Projetos ACBr / Diretora de Marketing AFRAC
Ajude o Projeto ACBr crescer - Seja Pro

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

  • Moderadores
10 horas atrás, Rodrigo Noli Carneiro disse:
Juliana,
 
Consegui fazer a atualização completa. Fiz todas as correções, porém continua a apresentar o mesmo erro.
 
O que mais poderemos fazer?
 
Att

 

 

anexe o txt usado e configurações

  • Like 1
Consultor SAC ACBr Juliomar Marchetti
 

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
 

 

Link to comment
Share on other sites

Juliomar,

Estou aguardando o posicionamento, continuo com o problema. Não consigo fazer a carta correção.

Que configurações e arquivo txt que deseja? Pela segunda vez, envio a mesma pergunta.

Não sei o que ocorre. E preciso uma certa urgência. Tenho clientes que não estão conseguindo realizar a operação com o componente.

Att

Rodrigo.

 

Link to comment
Share on other sites

  • Moderadores
13 minutos atrás, Rodrigo Noli Carneiro disse:

 

Bom dia, Rodrigo Noli Carneiro.

Movi a sua pergunta para o local mais indicado, visto que você não trabalha com o ACBrMonitor. Sugiro que anexe os documentos de envio e retorno. Pouca informação para que possamos tentar te ajudar.

Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Link to comment
Share on other sites

  • Moderadores
Em 18/10/2019 at 13:21, Rodrigo Noli Carneiro disse:

Estou emitindo a carta de correção e ao enviar gera o seguinte erro: UF não pode ser vazia.

Está configurando a propriedade ACBrNFe1.Configuracoes.WebServices.UF?

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

  • Moderadores
10 minutos atrás, Rodrigo Noli Carneiro disse:

Sim.

A única UF envolvida no envio do evento de carta de correção é a configurada na propriedade que indiquei.

Então tem algo errado com a tua rotina.

A propósito, você não indicou em qual linha ocorre o erro...

Você vai precisar usar o debug e verificar.

Se conseguir replicar o problema usando o demo do componente informe o passo a passo aqui.

  • Like 2
Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

  • Consultores

Bom dia Rodrigo,

Vai precisar entrar com o debug nessa linha para saber o ponto exato que o erro é levantado, assim saberemos com exatidão o que esta gerando o erro.

Consultor SAC ACBr

Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Araraquara - A era dos Trólebus

Link to comment
Share on other sites

Após debug, verifiquei o seguinte:

Realizando mais teste, verifiquei que o comando ACBrNFe1.EnviarEvento(sNumeroLote) funciona perfeitamente.

Mas dentro do arquivo ACBrNFe.pas na function TACBrNFe.EnviarEvento(idLote: integer): Boolean, linha Result := WebServices.EnvEvento.Executar; gera o erro.

Aguardo ajuda.

Att.

 

Link to comment
Share on other sites

  • Administradores

Tópico movido para a área do SAC, para que o SLA de respostas seja considerado

Consultora SAC ACBr

Juliana Tamizou

Gerente de Projetos ACBr / Diretora de Marketing AFRAC
Ajude o Projeto ACBr crescer - Seja Pro

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

  • Moderadores
2 horas atrás, Rodrigo Noli Carneiro disse:

Esta é a linha Result := WebServices.EnvEvento.Executar.

Você precisa debugar além disso.

Abra o seu projeto e abra também a unit ACBr\ACBrDFe\ACBrNFe\ACBrNFeWebServices.pas.

Localize a implementação do método:

procedure TNFeEnvEvento.DefinirURL

Coloque um breakpoint no início desse método e execute o debug.

Ao chegar o breakpoint, debugue passo a passo com atenção para alterações na variável UF até chegar na chamada:

Citar

 

  TACBrNFe(FPDFeOwner).LerServicoDeParams(
    Modelo,
    UF,
    FTpAmb,
    LayOutToServico(FPLayout),
    VerServ,
    FPURL,
    FPServico,
    FPSoapAction);

 

Veja pelo debug qual o valor para o parâmetro UF nessa chamada.

 

  • Like 1
Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

Abri a unit ACBr\ACBrDFe\ACBrNFe\ACBrNFeWebServices.pas.

Localizei o método: procedure TNFeEnvEvento.DefinirURL

Fiz o debug e a linha UF := CUFtoUF(ExtrairUFChaveAcesso(FEvento.Evento.Items[0].InfEvento.chNFe));

A  CUFtoUF(ExtrairUFChaveAcesso(FEvento.Evento.Items[0].InfEvento.chNFe)); não retorna nada na variável UF. UF fica vazia.

Como resolver?

Att.

Link to comment
Share on other sites

  • Este tópico foi criado há 1671 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.