Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

Emissão de GNRE


pradilsoncarlos
Go to solution Solved by BigWings,
  • Este tópico foi criado há 830 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

bom dia.

Não consigo gerar GNRE.

Segue em anexo os xmls

Gostaria de uma atenção especial, faz um mês que estou insistindo na emissão dessa guia e não consigo progresso.

Utilizo, NFe, NFSe, SAT e MDFe, SPED REFIN, mas essa tal de GNRE, nao estou conseguindo evoluir.

2-gnre.xml 20200213084745-env-lot.xml 20200213084745-env-lot-soap.xml 20200213084755-rec.xml 20200213084755-rec-soap.xml -ped-rec.xml -ped-rec-soap.xml -pro-rec.xml -pro-rec-soap.xml

Link to comment
Share on other sites

3 minutos atrás, BigWings disse:

Tente configurar para gerar o XML no layout 2.00:

ACBrGNRE1.Configuracoes.Geral.VersaoDF := ve200;

 

eu ja tinha gerado, gerei novamente estão em anexo os xmls.

2-gnre.xml 20200213091723-env-lot.xml 20200213091723-env-lot-soap.xml 20200213091745-rec.xml 20200213091745-rec-soap.xml -ped-rec.xml -ped-rec-soap.xml -pro-rec.xml -pro-rec-soap.xml

Link to comment
Share on other sites

17 minutos atrás, BigWings disse:

O XML que anexou ainda está na versão 1.00.

agora está na versão 2.00, mas deu mesmo erro.

segue em anexo os xmls.

ps:no Frm_ACBrGNRe, não consta essa linha da versão para preenchimento.

-pro-rec.xml -pro-rec-soap.xml -ped-rec.xml -ped-rec-soap.xml 20200213093943-rec.xml 20200213093943-rec-soap.xml 2-gnre.xml 20200213093921-env-lot.xml 20200213093921-env-lot-soap.xml

Link to comment
Share on other sites

  • Moderadores
33 minutos atrás, pradilsoncarlos disse:

agora está na versão 2.00, mas deu mesmo erro.

Pelo que vi os XML estão válidos de acordo com os schemas.

Então não sei dizer o motivo do erro, inclusive fiz teste usando meu próprio certificado e tive o mesmo retorno.

Vamos aguardar o @Italo Jurisato Junior ou alguém mais familiarizado com o componente responder.

34 minutos atrás, pradilsoncarlos disse:

ps:no Frm_ACBrGNRe, não consta essa linha da versão para preenchimento.

Isso no programa exemplo do componente?

Está lá sim, na aba geral, e alimentando pelo método TfrmACBrGNRe.ConfigurarComponente.

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

8 minutos atrás, BigWings disse:

Pelo que vi os XML estão válidos de acordo com os schemas.

Então não sei dizer o motivo do erro, inclusive fiz teste usando meu próprio certificado e tive o mesmo retorno.

Vamos aguardar o @Italo Jurisato Junior ou alguém mais familiarizado com o componente responder.

Isso no programa exemplo do componente?

Está lá sim, na aba geral, e alimentando pelo método TfrmACBrGNRe.ConfigurarComponente.

Quanto a aba geral está ali a opção para mudar de versão, mas mesmo mudando opção ali não muda no envio porque no código não tem a instrução "ACBrGNRE1.Configuracoes.Geral.VersaoDF := ve200 ou ve100".

Agradeço pela sua prestatividade e vamos aguardar.

Obrigado.

Link to comment
Share on other sites

  • Consultores

Bom dia Adilson,

Tem sim, veja:

  with ACBrGNRE1.Configuracoes.Geral do
  begin
    SSLLib        := TSSLLib(cbSSLLib.ItemIndex);
    SSLCryptLib   := TSSLCryptLib(cbCryptLib.ItemIndex);
    SSLHttpLib    := TSSLHttpLib(cbHttpLib.ItemIndex);
    SSLXmlSignLib := TSSLXmlSignLib(cbXmlSignLib.ItemIndex);

    AtualizarSSLLibsCombo;

    Salvar           := ckSalvar.Checked;
    ExibirErroSchema := cbxExibirErroSchema.Checked;
    RetirarAcentos   := cbxRetirarAcentos.Checked;
    FormatoAlerta    := edtFormatoAlerta.Text;
    FormaEmissao     := TpcnTipoEmissao(cbFormaEmissao.ItemIndex);
    VersaoDF         := TVersaoGNRE(cbVersaoDF.ItemIndex);         // <--- configura a versão
  end;

No retorno consta que ocorreu um erro ao recepcionar o Lote, mas não informar o que causou o erro.

Precisa checar no manual o código 197 retornado junto a mensagem para ver se consta o motivo.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

3 minutos atrás, Italo Jurisato Junior disse:

Bom dia Adilson,

Tem sim, veja:

  with ACBrGNRE1.Configuracoes.Geral do
  begin
    SSLLib        := TSSLLib(cbSSLLib.ItemIndex);
    SSLCryptLib   := TSSLCryptLib(cbCryptLib.ItemIndex);
    SSLHttpLib    := TSSLHttpLib(cbHttpLib.ItemIndex);
    SSLXmlSignLib := TSSLXmlSignLib(cbXmlSignLib.ItemIndex);

    AtualizarSSLLibsCombo;

    Salvar           := ckSalvar.Checked;
    ExibirErroSchema := cbxExibirErroSchema.Checked;
    RetirarAcentos   := cbxRetirarAcentos.Checked;
    FormatoAlerta    := edtFormatoAlerta.Text;
    FormaEmissao     := TpcnTipoEmissao(cbFormaEmissao.ItemIndex);
    VersaoDF         := TVersaoGNRE(cbVersaoDF.ItemIndex);         // <--- configura a versão
  end;

 

Tranquilo Italo, mas não é esse o problema, pode ver nos anexos que estou gerando os xmls na versão 1 e 2, no entanto não estão sendo validados.

Link to comment
Share on other sites

43 minutos atrás, Italo Jurisato Junior disse:

Bom dia Adilson,

Tem sim, veja:

  with ACBrGNRE1.Configuracoes.Geral do
  begin
    SSLLib        := TSSLLib(cbSSLLib.ItemIndex);
    SSLCryptLib   := TSSLCryptLib(cbCryptLib.ItemIndex);
    SSLHttpLib    := TSSLHttpLib(cbHttpLib.ItemIndex);
    SSLXmlSignLib := TSSLXmlSignLib(cbXmlSignLib.ItemIndex);

    AtualizarSSLLibsCombo;

    Salvar           := ckSalvar.Checked;
    ExibirErroSchema := cbxExibirErroSchema.Checked;
    RetirarAcentos   := cbxRetirarAcentos.Checked;
    FormatoAlerta    := edtFormatoAlerta.Text;
    FormaEmissao     := TpcnTipoEmissao(cbFormaEmissao.ItemIndex);
    VersaoDF         := TVersaoGNRE(cbVersaoDF.ItemIndex);         // <--- configura a versão
  end;

No retorno consta que ocorreu um erro ao recepcionar o Lote, mas não informar o que causou o erro.

Precisa checar no manual o código 197 retornado junto a mensagem para ver se consta o motivo.

código 197 - erro ao recepcionar lote.

não tem mais nada além disso

Link to comment
Share on other sites

  • Consultores

Boa tarde Adilson,

O manual não ajuda, o webservice que deveria informar qual é o motivo, não informa.

Chegou a pesquisar aqui no fórum se alguém anexou um XML que foi recepcionado com sucesso?

  • Like 1
Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

Acredito eu que devia haver alguma instabilidade no servidor de testes.

Não fiz nada além de procurar artigos e informações para resolver, a partir de agora consegui enviar.

Retornou a seguinte mensagem:

Inicio TGNRERecepcao
Ambiente: 2 
Status Código: 100 
Status Descrição: Lote recebido com sucesso! 
Recibo: 2000318373 
Recebimento: 14/02/2020 11:18:56 
Tempo Médio: 2000 

Inicio TGNRERetRecepcao
Ambiente: 2 
Status Código: 403 
Status Descrição: Lote Processado com pendencias 

ERRO: Lote Processado com pendencias Inscricao estadual do emitente nao cadastrada.
Inicio TGNRERetRecepcao
Ambiente: 2 
Status Código: 403 
Status Descrição: Lote Processado com pendencias 

 

Alguém pode me ajudar ?

Link to comment
Share on other sites

  • Moderadores
  • Solution
6 minutos atrás, pradilsoncarlos disse:

ERRO: Lote Processado com pendencias Inscricao estadual do emitente nao cadastrada.

Tente informar a inscrição estadual do emitente em branco, caso o mesmo não tenha inscrição na UF de destino.

  • Like 1
Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

1 hora atrás, BigWings disse:

Tente informar a inscrição estadual do emitente em branco, caso o mesmo não tenha inscrição na UF de destino.

Envie sem a IE e deu certo.

Muito Obrigado.

Estou trocando emails com a "GNRE - Guia Nacional de Recolhimento de Tributos Estaduais <[email protected]efaz.pe.gov.br>", para verificar motivo do erro "197 - Erro ao recepcionar o lote".

Assim que eu obter a resposta posto aqui para concluir este post.

Agradeço a contribuição de todos.✌️

   
  • Like 3
Link to comment
Share on other sites

  • Este tópico foi criado há 830 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.