Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

click.png

click.png

click.png

Erro no Envio para MG e DF


ubaltino
  • Este tópico foi criado há 800 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Bom dia.

Estou usando a versão 1.00.

Atualizei o componente na 06/05/2019.

Agora esta ocorrendo o erro abaixo:

"cvc-complex-type.3.2.2: Attribute 'versao' is not allowed to appear in element 'TDadosGNRE'"

Consultando o portal da GNRE online, acusa que todos os estados estão funcionando na versão 1.00.

Alguém tem alguma sugestão sobre como solucionar isso?

Obrigado.

Link to comment
Share on other sites

  • Membros Pro
1 hora atrás, ubaltino disse:

Bom dia.

Estou usando a versão 1.00.

Atualizei o componente na 06/05/2019.

Agora esta ocorrendo o erro abaixo:

"cvc-complex-type.3.2.2: Attribute 'versao' is not allowed to appear in element 'TDadosGNRE'"

Consultando o portal da GNRE online, acusa que todos os estados estão funcionando na versão 1.00.

Alguém tem alguma sugestão sobre como solucionar isso?

Obrigado.

Bom dia.

Semana passada eu ajustei usando a Unit deste post e para a versão 1.0 deu certo.

 

Edited by Marcelo Calvi Belanga
Escrita errada
Link to comment
Share on other sites

7 minutes ago, Rodrigo Galvan said:

Estou Gerando a GNRE ele gera tudo certinho mas ao imprimir não aparece os dados do Destinatário isso na versão 1.00.

 

Na versão 2.00 ainda da o erro abaixo, atualizei para a ultima versão. Abaixo os Xml Gerados.

image.png.13ec226ef1a36fb1c2fb44747fc928f2.png

20190508143318-rec.xml 400 B · 0 downloads 100160-gnre.xml 1.11 kB · 0 downloads 20190508143317-env-lot.xml 1.2 kB · 0 downloads

Você atualizou hoje, após as 12h? Porque essa correção no ACBR foi comitada hoje pelo Italo.

As linhas 111 e 112 da unit pgnreGNREW.pas, deve estar como abaixo

111  //  Gerador.wGrupo('TDadosGNRE versao="1.00"');  

112  Gerador.wGrupo('TDadosGNRE');

E olhando o XML de envio, o seu esta errado

<TDadosGNRE versao="2.00">

deveria estar

<TDadosGNRE>

Mude para a versão 1.00. Acho que ainda não tem nenhum estado funcionando na 2.00.

 

Link to comment
Share on other sites

  • Moderadores
1 minuto atrás, Daniel De Paula Romanini disse:

Boa tarde eu testei a 2.00 tb não funcionou 

Boa tarde, Daniel De Paula Romanini.

Depois de atualizar você instalou? 

Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Link to comment
Share on other sites

  • Moderadores
18 minutos atrás, Daniel De Paula Romanini disse:

Não só atualizei a pasta fontes 

Tente realizar o processo completo e informe o resultado.

  • Like 1
Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Link to comment
Share on other sites

1 minuto atrás, Mauro Sergio Mansano disse:

Mesmo gerando na versao 1.0 esta me retornando esse mesmo erro  ( Versão do cabeçalho informada difere da versão do XML de Dados.) . Esta acontecendo com todos ?

Comigo também, tentei enviar o xml gerado e da erro, consegui enviar uma guia anexando o xml gerado pelo acbr, mais alterei a tag manual desse jeito :

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?> 
   <TLote_GNRE xmlns="http://www.gnre.pe.gov.br"> 
     <guias>
<TDadosGNRE>
..................

</TDadosGNRE>
    </guias> 
</TLote_GNRE>

Link to comment
Share on other sites

21 minutos atrás, Mauro Sergio Mansano disse:

Mesmo gerando na versao 1.0 esta me retornando esse mesmo erro  ( Versão do cabeçalho informada difere da versão do XML de Dados.) . Esta acontecendo com todos ?

Sim, mesmo clientes que estão rodando o programa desatualizado desde o mês passado e que emitiam normalmente passaram e enfrentar o problema. Acredito que não é algo relacionado ao ACBr.

Link to comment
Share on other sites

Já fiz de tudo, pelo portal direto vai normal, agora o ACBR enviando para GNRE via webservices não vai, retorna esse erro, desde a versão do componente de 2017, está com o mesmo problemas.

 

Inicio TGNRERecepcao
Ambiente: 1 
Status Código: 157 
Status Descrição: Versão do cabeçalho informada difere da versão do XML de Dados! 
Recibo:  
Recebimento:  
Tempo Médio: 0 

ERRO: Versão do cabeçalho informada difere da versão do XML de Dados!

Link to comment
Share on other sites

  • Membros Pro

Aqui idem, tudo atualizado corretamente. Não conseguimos gerar GNRE desde de manhã. Mesmo usando versões antigas do sistema e acbr a mensagem é sempre a mesma:
Status Descrição: Versão do cabeçalho informada difere da versão do XML de Dados! 
Testamos quase todos os estados, nenhum gera.

Edited by DOCFABIO
Link to comment
Share on other sites

  • Este tópico foi criado há 800 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.