Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

Erro: 12175 em homologação NF-e 4.0 Sefaz CE


Go to solution Solved by Valdemir Jacon Sanches,
  • Este tópico foi criado há 1431 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Olá bom dia!

 

Preciso de ajuda dos colegas para um erro que estou obtendo no ambiente de homologação da Sefaz CE - 4.00:

Erro 12175 - Um ou mais erros foram encontrados no certificado SSL enviado ao servidor.

No ACBr estou usando: WinCrypt / WinHttp / LibXML2

Aplicação compilada 32 bits

Testei no demo do ACBR e ocorre o mesmo erro.

Testei o certificado A1 no E-CAC da Receita federal e está OK.

Meu ambiente: Windows 7 - 64 bits

Segue print anexo do erro no demo do Acbr

 

Alguém poderia me dar uma luz ?

 

Agradeço desde já

 

Aloisio Pires Neto

 

 

 

 

ERRO ACBRNFE.png

Link to comment
Share on other sites

4 minutos atrás, Italo Jurisato Junior disse:

Bom dia Aloisio,

Qual é o valor de SLLType?

Se for ALL, mude para TLS 1.2

Ítalo,

já está assim SSLType =  LT_TLSv1_2

Estou testando a NF-e 4.0 e já sabia que só funciona com TL2 1.2.

Só pra testar configurei como ALL que acaba gerando o erro HTTP: 403.

O que pode ser mais?

 

 

Link to comment
Share on other sites

18 minutos atrás, José M. S. Junior disse:

O seu Windows está atualizado? aparentemente está ok esta consulta:

image.png

Tenho NF-e com ACBr desde a versão 2.00 em vários clientes.

Na verdade nunca me preocupei com essa questão de windows atualizado.

Como bem sabem, muitos clientes tem windows pirata e consequentemente desatualizado...

Na minha máquina de desenvolvimento tudo bem posso fazer a atualização... mas nos clientes vou ter quer me preocupar com isso?

Não posso simplesmente copiar uma dll atualizada?

 

 

Link to comment
Share on other sites

2 horas atrás, José M. S. Junior disse:

A WinCrypt utiliza dll nativa do Windows, se o windows não tem suporte a TLS 1.2 utilize a lib OpenSSL da pasta MinGW:

 

José, obrigado por sua ajuda!

 

Queria entender uma coisa: quando abro as configurações do internet explorer e vejo lá opção de selecionar TLS 1.2 (imagem em anexo), isso já não indica que o windows teria a capacidade de utilizar esse protocolo de comunicação?

 

 

 

CONFIG WINDOWS TLS 1-2.png

Link to comment
Share on other sites

  • Moderadores
djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.tefhouse.com.br | www.lambretinha.com.br
Link to comment
Share on other sites

  • Membros Pro

Estou com o Mesmo Problema 

Em 06/06/2018 at 10:28, aloisiopires disse:

Olá bom dia!

 

Preciso de ajuda dos colegas para um erro que estou obtendo no ambiente de homologação da Sefaz CE - 4.00:

Erro 12175 - Um ou mais erros foram encontrados no certificado SSL enviado ao servidor.

No ACBr estou usando: WinCrypt / WinHttp / LibXML2

Aplicação compilada 32 bits

Testei no demo do ACBR e ocorre o mesmo erro.

Testei o certificado A1 no E-CAC da Receita federal e está OK.

Meu ambiente: Windows 7 - 64 bits

Segue print anexo do erro no demo do Acbr

 

Alguém poderia me dar uma luz ?

 

Agradeço desde já

 

Aloisio Pires Neto

 

 

 

 

ERRO ACBRNFE.png

Estou com esse Problema, e quando coloco Openssl 

 

Em 06/06/2018 at 13:31, José M. S. Junior disse:

A WinCrypt utiliza dll nativa do Windows, se o windows não tem suporte a TLS 1.2 utilize a lib OpenSSL da pasta MinGW:

 

 

Link to comment
Share on other sites

Ainda não encontrei uma lógica nessa atualização do windows que é necessária pra funcionar o WinHttp ...

Atualizar via Windows Update pode levar horas, dependendo do link de internet da empresa.

Existe algum pacote de atualização separado que resolve essa situação sem ter que fazer todas as atualizações pendentes do windows?

Agradeço a ajuda dos colegas!

 

Aloisio Pires Neto

Link to comment
Share on other sites

  • Moderadores
5 minutos atrás, aloisiopires disse:

Existe algum pacote de atualização separado que resolve essa situação sem ter que fazer todas as atualizações pendentes do windows? 

Você tentou o método 2 descrito aqui?

Em 06/06/2018 at 19:18, André Ferreira de Moraes disse:

 

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

46 minutos atrás, BigWings disse:

Você tentou o método 2 descrito aqui?

 

BigWings obrigado pelo retorno.

 

Tentei sim a solução proposta pelo André, porém no meu caso não funcionou. (veja imagem em anexo).

 

Coisas que eu já tentei:

- Atualizei o Internet Explorer para versão 11

- Atualização KB3140245

- Windows Update várias vezes até informar que não há novas atualizações.

- Atualização do .Net Framework para versão 4.7

Alguma coia a mais que poderia tentar?

 

 

IMG_20180608_110719795_HDR.jpg

IMG_20180608_110755271_HDR.jpg

Link to comment
Share on other sites

44 minutos atrás, André Ferreira de Moraes disse:

Nesta ultima imagem vc configurou para ACBrNFe1.Configuracoes.WebServices.SSLType := LT_TLSv1_2; ?

Sim André, em todas as tentativas o SSLType estava setado para LT_TLSv1_2.

O que me preocupa é não entender a lógica de fazer isso funcionar.

 

Link to comment
Share on other sites

  • 3 weeks later...
  • Este tópico foi criado há 1431 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.