Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

Erro : 452 - Rejeicao: Tipo Autorizador do Recibo diverge do Orgao Autorizador ESTADO DA PB


Go to solution Solved by BigWings,
  • Este tópico foi criado há 309 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Bom dia!!!

Amigos me deparei com esse erro hoje: Rejeicao:  452 Tipo Autorizador do Recibo diverge do Orgao Autorizador ao tentar transmitir as NFCe’s do estado da PB no ambiente de homologação, atualizei os fontes, schemas e recompilei a aplicação e mesmo assim o erro persiste! Alguem já passou por isso?

Obs: Até ontem estava tudo normal. Segue em anexo os XMLs gerados e os retornos.182275-env-lot-soap.xml182275-rec.xml182275-rec-soap.xml182275-env-lot.xml

Edited by Fernando Di Pace
Correção ortografica e itendimento melhor do conteudo a ser exemplificado para o publico alvo
Link to comment
Share on other sites

  • Administradores

Tópico movido para a área do SAC, para que o SLA de respostas seja considerado

Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

  • Consultores
3 horas atrás, Fernando Di Pace disse:

Bom dia!!!

Amigos me deparei com esse erro hoje: Rejeicao:  452 Tipo Autorizador do Recibo diverge do Orgao Autorizador ao tentar transmitir as NFCe’s do estado da PB no ambiente de homologação, atualizei os fontes, schemas e recompilei a aplicação e mesmo assim o erro persiste! Alguem já passou por isso?

Obs: Até ontem estava tudo normal. Segue em anexo os XMLs gerados e os retornos.182275-env-lot-soap.xml182275-rec.xml182275-rec-soap.xml182275-env-lot.xml

Boa tarde Fernando.

   O erro é intermitente ou constante?

   O erro aconteceu do nada?

   Houve alguma atualização no seu software antes desse erro?

 

Tivemos um relato semelhante no discord e suspeitamos de erro na SEFAZ... Mas vamos avaliar o que pode ser.

 

[]'s

Consultor SAC ACBr

Elton
Profissionalize o ACBr na sua empresa, conheça o ACBr Pro.

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Um engenheiro de Controle de Qualidade(QA) entra num bar. Pede uma cerveja. Pede zero cervejas.
Pede 99999999 cervejas. Pede -1 cervejas. Pede um jacaré. Pede asdfdhklçkh.
Link to comment
Share on other sites

  • Membros Pro

Boa tarde EmBarbosa.

O erro é intermitente ou constante?

O erro é constante, está acontecendo no TACBrNFe.Enviar na class ACBrNFe;

O erro aconteceu do nada?

Sim. Muito estranho isso!!!

Houve alguma atualização no seu software antes desse erro?

Não, eu ia testar uma venda e me deparei com o erro, porém fiz uma atualização dos fontes do acbr compilei uma versão e aproveitei atualizei a pasta schema, e mesmo assim o problema persiste. Lembrando que o ambiente de produção está funcionando, esse problema só está acontecendo em homologação.

Obs: Segundo o erro ocorre quando Erro: 'Se o emitente fizer a transmissão da NF-e para o SVAN (SEFAZ Virtual do Ambiente Nacional) e consultar esse recibo no webservice SVRS (SEFAZ Virtual do Rio Grande do Sul), essa rejeição vai surgir, pois quem processou a informação e tem a resposta é o SVAN. Devemos sempre fazer as buscas no mesmo WebService.' fonte: https://atendimento.tecnospeed.com.br/hc/pt-br/articles/360015680413-Rejeição-553-Tipo-autorizador-do-recibo-diverge-do-Órgão-Autorizador

 

O erro 553 da fonte do site acima tem o mesmo cabeçalho de erro 452 que estou tendo.

Eu fui verificar o arquivo ACBrNFeServicos.ini em comparação com site da sefaz nacional https://hom.nfe.fazenda.gov.br/portal/webServices.aspx?tipoConteudo=Wak0FwB7dKs=

observando a chave do arquivo [NFe_SVRS_H] ACBrNFeServicos.ini  com o site da sefaz está tudo OK, o que nos leva a crer que pode ser um erro na Sefaz do SVRS_H.

image.thumb.png.ab4f75d363cd81104de18787482ddb07.pngimage.thumb.png.8280bf4f8c556097a9f27019670f1b4b.png

 

Edited by Fernando Di Pace
Link to comment
Share on other sites

  • Membros Pro
15 minutos atrás, Fernando Di Pace disse:

Boa tarde EmBarbosa.

O erro é intermitente ou constante?

O erro é constante, está acontecendo no TACBrNFe.Enviar na class ACBrNFe;

O erro aconteceu do nada?

Sim. Muito estranho isso!!!

Houve alguma atualização no seu software antes desse erro?

Não, eu ia testar uma venda e me deparei com o erro, porém fiz uma atualização dos fontes do acbr compilei uma versão e aproveitei atualizei a pasta schema, e mesmo assim o problema persiste. Lembrando que o ambiente de produção está funcionando, esse problema só está acontecendo em homologação.

Obs: Segundo o erro ocorre quando Erro: 'Se o emitente fizer a transmissão da NF-e para o SVAN (SEFAZ Virtual do Ambiente Nacional) e consultar esse recibo no webservice SVRS (SEFAZ Virtual do Rio Grande do Sul), essa rejeição vai surgir, pois quem processou a informação e tem a resposta é o SVAN. Devemos sempre fazer as buscas no mesmo WebService.' fonte: https://atendimento.tecnospeed.com.br/hc/pt-br/articles/360015680413-Rejeição-553-Tipo-autorizador-do-recibo-diverge-do-Órgão-Autorizador

 

O erro 553 da fonte do site acima tem o mesmo cabeçalho de erro 452 que estou tendo.

Eu fui verificar o arquivo ACBrNFeServicos.ini em comparação com site da sefaz nacional https://hom.nfe.fazenda.gov.br/portal/webServices.aspx?tipoConteudo=Wak0FwB7dKs=

observando a chave do arquivo [NFe_SVRS_H] ACBrNFeServicos.ini  com o site da sefaz está tudo OK, o que nos leva a crer que pode ser um erro na Sefaz do SVRS_H.

image.thumb.png.ab4f75d363cd81104de18787482ddb07.pngimage.thumb.png.8280bf4f8c556097a9f27019670f1b4b.png

 

A minha comparação se extendeu para NFe e NFCe no arquivo [NFCe_SVRS_H] ACBrNFeServicos.ini e Site do estado: https://www.sefaz.pb.gov.br/view-docs?task=document.viewdoc&id=1349image.thumb.png.a33eb39e269879a6bc18723a88b5e291.png

image.thumb.png.328c5b4944600e37515c52f1806dcea8.png

Link to comment
Share on other sites

  • Membros Pro
16 minutos atrás, BigWings disse:

Algum motivo especial pra estar usando o modo assíncrono?

Você não deve ter o erro se usar o modo síncrono.

Boa tarde BigWings!

Estou usando método Enviar com o terceiro parâmetro da função setada de forma default Sincrono:  Boolean = false, conforme a chamada do mesmo a baixo.

ACBrNFe1.Enviar(iLoteId, false);

 

Class ACBrNFe 

image.png.c960d1c375f3bee0098df2a339f4263f.png

 

Vou tentar setar como true, o terceiro parâmetro e ver o retorno.

 

Edited by Fernando Di Pace
Link to comment
Share on other sites

  • Membros Pro
10 minutos atrás, Fernando Di Pace disse:

Boa tarde BigWings!

Estou usando método Enviar com o terceiro parâmetro da função setada de forma default Sincrono:  Boolean = false, conforme a chamada do mesmo a baixo.

ACBrNFe1.Enviar(iLoteId, false);

 

Class ACBrNFe 

image.png.c960d1c375f3bee0098df2a339f4263f.png

 

Vou tentar setar como true, o terceiro parâmetro e ver o retorno.

 

Fiz o teste colocando o terceiro parâmetro = true e o retorno do recimo não vem nada pelo método ACBrNFe1.WebServices.Enviar.Recibo = ''

onde eu executo:

ACBrNFe1.Enviar(iLoteId, false, true);

ACBrNFe1.WebServices.Retorno.Recibo := ACBrNFe1.WebServices.Enviar.Recibo;

 ACBrNFe1.WebServices.Retorno.Executar;

Retorno 999 erro no Falha no processamento do webservice.

 

Conclusão testei de forma Síncona e Assincrona e de forma Assincrona não recebo o erro porém não obtenho retono pois o recibo vem vazio. 

Será que o problema esteja na SEFAZ????????????

 

 

 

Link to comment
Share on other sites

  • Membros Pro
4 minutos atrás, Fernando Di Pace disse:

Fiz o teste colocando o terceiro parâmetro = true e o retorno do recimo não vem nada pelo método ACBrNFe1.WebServices.Enviar.Recibo = ''

onde eu executo:

ACBrNFe1.Enviar(iLoteId, false, true);

ACBrNFe1.WebServices.Retorno.Recibo := ACBrNFe1.WebServices.Enviar.Recibo;

 ACBrNFe1.WebServices.Retorno.Executar;

Retorno 999 erro no Falha no processamento do webservice.

 

Conclusão testei de forma Síncona e Assincrona e de forma Assincrona não recebo o erro porém não obtenho retono pois o recibo vem vazio. 

Será que o problema esteja na SEFAZ????????????

 

 

 

Prezado Fernando, boa tarde. Estamos com o mesmo problema no ambiente de homologação aqui na Bahia, o envio da NFC-e tb é para SVC-RS. Acredito que seja problemas na SEFAZ.

Link to comment
Share on other sites

  • Membros Pro
15 minutos atrás, wendelswl disse:

Prezado Fernando, boa tarde. Estamos com o mesmo problema no ambiente de homologação aqui na Bahia, o envio da NFC-e tb é para SVC-RS. Acredito que seja problemas na SEFAZ.

Boa tarde wendelswl,

Rapaz, acredito que seja isso mesmo, mandei um e-mail para sefaz da PB e caso eles não respondam vou tentar mandar para o RS. Ainda bem que o problema está só no ambiente de homologação. Espero que eles não estende para produção.

Link to comment
Share on other sites

  • Moderadores
26 minutos atrás, Fernando Di Pace disse:

Fiz o teste colocando o terceiro parâmetro = true e o retorno do recimo não vem nada pelo método ACBrNFe1.WebServices.Enviar.Recibo = ''

No modo síncrono não existe recibo, nem é feita a consulta do mesmo.

Veja o programa exemplo do componente pra saber como capturar o cStat, protocolo, no modo síncrono.

Lembrando que pela NT 2020.005 v1.20, o envio em modo assíncrono com apenas uma NFCe vai ser bloqueado pela SEFAZ nos próximos meses.

  • Like 1
Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

  • Membros Pro
14 horas atrás, BigWings disse:

No modo síncrono não existe recibo, nem é feita a consulta do mesmo.

Veja o programa exemplo do componente pra saber como capturar o cStat, protocolo, no modo síncrono.

Lembrando que pela NT 2020.005 v1.20, o envio em modo assíncrono com apenas uma NFCe vai ser bloqueado pela SEFAZ nos próximos meses.

Prezado, bom dia. De acordo a NT 2020.005 v1.10 a alteração do modo síncrono entrou em vigor no ambiente de homologação no dia 01/07/2020. Este poderia ser o motivo da rejeição? Qual o padrão do componente, modo síncrono ou assíncrono?

  • Like 1
Link to comment
Share on other sites

  • Moderadores
1 hora atrás, wendelswl disse:

Prezado, bom dia. De acordo a NT 2020.005 v1.10 a alteração do modo síncrono entrou em vigor no ambiente de homologação no dia 01/07/2020. Este poderia ser o motivo da rejeição? Qual o padrão do componente, modo síncrono ou assíncrono?

Difícil saber se esse é o motivo, sem a resposta da SEFAZ-RS...

No método de envio, se não for informado o terceiro parâmetro, será usado o modo assíncrono.

image.png

  • Like 2
Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

  • Membros Pro
2 horas atrás, BigWings disse:

Difícil saber se esse é o motivo, sem a resposta da SEFAZ-RS...

No método de envio, se não for informado o terceiro parâmetro, será usado o modo assíncrono.

image.png

Bom dia BigWings.

Depois de analisar o metodo enviar do exemplo e conforme a NT 2020.005 v1.10 com uma NFCe; sua observação em preencher o método de forma Síncrona a aplicação transmitiu normalmente.

ACBrNFe1.Enviar(iLoteId, false, true); // ou seja terceiro parâmetro tem que ser informado.

Obrigado pela ajuda!

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

  • Este tópico foi criado há 309 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.