Jump to content

prime

Membros
  • Content Count

    31
  • Joined

  • Last visited

Community Reputation

5 Neutral

1 Follower

About prime

  • Rank
    Membro
  • Birthday 01/01/1900

Contact Methods

  • Website URL
    www.p1s.com.br
  • Skype
    suporte.prime.solutions

Profile Information

  • Sexo
    Masculino
  • Localização
    Brasil

Recent Profile Visitors

732 profile views
  1. @thiagosantanna10 finalmente consegui emitir a NFC-e 4.00 com emitente para Bahia em ambiente de homologação porém no componente ACBr tive que mudar em Configurações.Geral.VersãoQrCode para vcQr1000. Tenta aí cara !!!
  2. obrigado pela atenção @RicardoVoigt, o contador mandou novo CSC e agora a NFC-e já está funcionando no demo do ACBr. No meu aplicativo está dando erro: Endereço do site da UF da consulta via QR-Code diverge do previsto. Agora vou tentar encontrar a falha contudo a diferença entre meu aplicativo e o demo é que estou tentando usando o componente TACBrNFeDANFeESCPOS junto com o TACBrPosPrinter, espero que eles não estejam interferindo em nada. Valeu !!!
  3. @thiagosantanna10 consegue me dizer se a emissão da NFC-e 4.00 está correto? No meu aqui está dando erro: Endereço do site da UF da consulta via QR-Code diverge do previsto
  4. Vale @RicardoVoigt, pedi para o cliente gerar outro CSC, estou no aguardo porém o CSC atual é para homologação, foi guardado e enviado pra mim o comprovante do credenciamento no portal da BA. Com relação ao schemas estou usando o que abaixei hoje com o demo e ACBr, inclusive também estou usando o demo para testes. E para terminar percebi que na parte do QrCode do XML que anexei acima tem a linha abaixo sobre o QrCode, é normal do jeito que está? Tenho como validá-la em algum portal? Agradeço a todos pela ajuda. <qrCode> -<![CDATA[http://hnfe.sefaz.ba.gov.br/servicos/nfce/qrcode.aspx?chNFe=29180617840040000152650010000000011000000013&nVersao=100&tpAmb=2&dhEmi=323031382D30362D31345431313A30393A35342D30333A3030&vNF=100.00&vICMS=18.00&digVal=3842627754546B652B6F694D79594B542F3574717069486A5776773D&cIdToken=000001&cHashQRCode=BDCA1E8D2284B81ADA1100F2EA7E1408AEC75E8D]]> </qrCode>
  5. Muito obrigado pela ajuda @RicardoVoigt e @André Ferreira de Moraes, a princípio mudei os testes para o emissor demo da NF-e/NFC-e do ACBr, baixei a última versão do trunk, peguei a pasta schemas em [ACBr\trunk2\Exemplos\ACBrDFe\Schemas\NFe] que está igual a minha e tentei novamente realizar o envio. Deu erro que CSC no Qr-Code não cadastrado no SEFAZ como podem ver na imagem em anexo, também anexei o XML. Percebi que o ID CSC do cliente é 1 e ele ainda não o utilizou em NFC-e pois no momento está usando ECF e li em algum tópico do fórum que o CSC pode estar desatualizado por isso pedi para o contador gera um novo CSC. Gostaria de saber se esse pode ser o problema, alguém sabe? Também gostaria de saber como é que vcs conseguem detectar pelo primeiro print que minha pasta schema pode estar desatualizada, apenas gostaria de aprender. Enfim se puderem me ajudar com os arquivos em anexo agradeço muito. 29180617840040000152650010000000011000000013-nfe.xml
  6. Boa tarde a todos, alguém pode me ajudar. Desenvolvemos e testamos a emissão da NFC-e em homologação para o estado de SP e tudo está funcionando normal, para impressão usamos o componente TACBrNFeDANFeESCPOS junto com o TACBrPosPrinter. Contudo em nosso cliente da Bahia a NFC-e não é transmitida, dá o erro em anexo e não gera XML para nós capturarmos e anexarmos junto. Estamos emitindo NFC-e 4.00, tipo de danfe tiNFCe e versão do QRCode veqr200. Alguém pode nos ajudar com relação ao erro em anexo?
  7. Também estou com o mesmo problema do usuário @slashman para emissão de NFC-e para o estado da BA, o cDest possui caracteres inválidos e acusa o erro de: rejeição: Codigo identificador do CSC no QR-Code nao cadastrado na SEFAZ
  8. Muito obrigado pelo feedback @BigWings e @Sommus contudo resolvi meu problema ativando um SAT para meu CNPJ e depois me credenciando para emitir a NFC-e 4.0 aqui mesmo em SP. Acho que usando a versão da NFC-e 3.10 ia dar certo pelo portal de AM mas eu ia ter que alterar outras coisas no meu software. Valeu pessoal !
  9. Obrigado pela atenção @Italo Jurisato Junior porém o SEFAZ/AM ambiente homologação não está aceitando, por exemplo, o meu CNPJ como emitente por isso perguntei se há um CNPJ de teste. Tem alguma sugestão? Obrigado novamente.
  10. Bom dia a todos, somos de SP e estamos iniciando a realização de testes para emissão de NFC-e devido a necessidade de um cliente nosso da Bahia. Alguém sabe se existe alguma forma de usar um ambiente de homologação de qualquer estado para testes de emissão de NFC-e? Caso positivo pode informar além do estado os dados que devemos informar para realizar o teste como, por exemplo, o CNPJ, I.E., CSC e idCSC? Nosso PDV já emite NF-e na versão 4.0 e queremos realizar os testes da NFC-e também na versão 4.0. Obrigado por qualquer ajuda !
  11. Honestamente não mas vou testar, grato pela dica @José M. S. Junior !
  12. Minha versão está atualizada sim, inclusive peguei minha versão na semana passada. Será que há no Fortes alguma propriedade a qual habilito/desabilito impressão DOS/Win?
  13. Bom dia a todos, peço ajuda para tentar resolver um problema estranho: nosso software de emissão de NF-e (impressão em Fortes usando Delphi XE 8 / VCL) parou de imprimir (impressora HP LaserJet M1536 dnf MFP) num cliente que já o usa há dois anos, o motivo foi a atualização do Windows 7 para Windows 10. Todos os demais relatórios do nosso software imprimem normalmente, inclusive outros relatórios feitos em Fortes (estranho), o único que não imprime é justamente a NF-e. Esse problema também já aconteceu num outro cliente nosso mas nunca demos a devida atenção, acreditávamos até então que o problema era na impressora HP LaserJet M1536 dnf MFP ou no Windows 10 desse cliente. Chamamos um técnico de nossa confiança e ele acredita que o Windows 10 removeu algumas características/opções de impressão DOS pois ele encontrou o mesmo problema de impressão DOS em outros clientes dele. Enfim, alguém sabe como resolver esse problema ou tem alguma dica? Alguém já passou por problema semelhante? Grato a todos pela atenção dispensada...
  14. boa!!! deu certo. Muito obrigado! Só uma dica caso alguém também passe por isso: Para encerrar via chave é necessário o protocolo (que eu também não tinha). Então fiz uma consulta via chave, obtive o protocolo em AcBrMDFe1.WebServices.Consulta.protMDFe.nProt e depois sim fiz o encerramento via chave.
  15. prezados, estou em ambiente de homologação do MDF-e e enfrentando o seguinte problema: eu configurei o ACBrMDFe, populei, gerei o xml, assinei, validei e transmiti, demorou bastante até que tive um erro de timeout. Fiz a operação novamente e ai tive o retorno de "Rejeição por duplicidade". Eu entendi o que houve: o primeiro XML foi aceito mas houve timeout no retorno e fiquei com a impressão de que não havia transmitido nada. No entanto, quando executei as operações novamente, gerei um novo XML que sobrescreveu o XML original. E ai que está o problema. Não tenho mais o XML original. Quando vou Encerrar o MDF-e, carrego XML que tenho disponível (o segundo que foi gerado) e ao enviar o evento de encerramento recebo o seguinte erro: "Rejeição: falha no schema XML específico para o evento" Ou seja, sem o XML original não consigo enviar nenhum evento. O que preciso saber é se há alguma forma de encerrar o MDF-e via componente ACBrMDFe apenas com a chave e protocolo? Ou há alguma forma de recuperar também via componente o XML original? Lembrando que estou desenvolvendo software para terceiros e soluções como "entre no site da sefaz" ou use o "programa do governo" não me servem pois preciso criar mecanismo no meu software para corrigir e evitar que situações como essa venha a acontecer com o usuário final. Estou em ambiente de homologação e meu problema maior é evitar/corrigir este cenário quando ocorrer em ambiente de produção com os meus usuários.
×
×
  • Create New...