Jump to content

diadoacbr

Versão 4.00 da NFe/NFCe com ACBr


Go to solution Solved by Célio Rafael Martins Júnior,
  • Este tópico foi criado há 1894 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Moderadores

Para evitarmos diversos tópicos sobre o mesmo assunto, as alterações relativas a versão 4.00 da NFe/NFCe deverão ser concentradas neste tópico.

Os fontes do componente já foram atualizados para permitir gerar os XMLs para essa nova versão. Também já foram ajustados para não gerar o SOAP Header quando configurado para a versão 4.0(ve400).

Assim que os schemas e webservices forem disponibilizados pelo SEFAZ, iniciaremos os testes com o componente.

Mais informações sobre as mudanças podem ser obtidas na NT 2016.002 - http://www.nfe.fazenda.gov.br/portal/exibirArquivo.aspx?conteudo=c4S6yXTKpXY=

Apenas como informação, neste manual fiquei com dúvida em dois campos:

descANP - Campo numérico com tamanho de 2 - 95? O campo tem a seguinte descrição: Descrição do produto conforme ANP, então provavelmente deve ser do tipo carácter e não numérico.
O campo vBCFCPSTRet possui o mesmo ID de outro campo na versão 3.10 - N27a - V3.10 vICMSDeson / V4.00 vBCFCPSTRet

  • Like 30
  • Thanks 1
djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.tefhouse.com.br | www.lambretinha.com.br
Link to comment
Share on other sites

  • Moderadores

Penso que os dois casos são erros. Provavelmente deve vir com errata na próxima versão da NT.
A descrição da ANP segundo o SIMP (Sistema de Informações de Movimentação de Produtos) é extensa e com caracteres. 

 


logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Link to comment
Share on other sites

  • Moderadores
Citar

A partir da versão 4.0 da NFe será permitido unicamente o protocolo TLS 1.2 ou versão superior. Ou seja, não será mais permitida à comunicação via protocolo SSL.
O motivo desta mudança está amplamente documentado na Internet, pela falta de segurança comprovada no uso do Protocolo SSL.

Pelo que entendi não poderemos mais usar o OpenSSL para comunicação com os Webservices.

Já temos alguma alternativa ou precisaremos aguardar a liberação do ambiente de homologação?

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

  • Moderadores
1 hora atrás, BigWings disse:

Pelo que entendi não poderemos mais usar o OpenSSL para comunicação com os Webservices.

Pq não funcionaria?

djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.tefhouse.com.br | www.lambretinha.com.br
Link to comment
Share on other sites

39 minutos atrás, André Ferreira de Moraes disse:

Pq não funcionaria?

2. Padrões Técnicos (item 3.2.2 do MOC)

2.1 Protocolo de Comunicação A partir da versão 4.0 da NFe será permitido unicamente o protocolo TLS 1.2 ou versão superior. Ou seja, não será mais permitida à comunicação via protocolo SSL. O motivo desta mudança está amplamente documentado na Internet, pela falta de segurança comprovada no uso do Protocolo SSL.

tmb intendi isso!! 

 

  • Like 1
  • Thanks 1

 

 

Link to comment
Share on other sites

  • Moderadores
9 minutos atrás, Fabio Damasceno Silva disse:

Quando teremos uma versão do acbrmonitorPlus com o novo padrão 4.0?

Quando o fisco disponibilizar o ambiente de homologação.

  • Like 2
djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.tefhouse.com.br | www.lambretinha.com.br
Link to comment
Share on other sites

  • Moderadores
1 hora atrás, Alexsandro Lopes disse:

2. Padrões Técnicos (item 3.2.2 do MOC)

2.1 Protocolo de Comunicação A partir da versão 4.0 da NFe será permitido unicamente o protocolo TLS 1.2 ou versão superior. Ou seja, não será mais permitida à comunicação via protocolo SSL. O motivo desta mudança está amplamente documentado na Internet, pela falta de segurança comprovada no uso do Protocolo SSL.

tmb intendi isso!! 

 

 

2 horas atrás, André Ferreira de Moraes disse:

 

  • Like 1
djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.tefhouse.com.br | www.lambretinha.com.br
Link to comment
Share on other sites

  • Fundadores

Fiz alguns testes com o OpenSSL, usando TLS 1.2... é necessário usar a versão 1.0.1 ou superior...

Notei porém, problemas na libXMLSec, que também usa o OpenSSL para assinar o XML...

Consegui rodar todas as funcionalidades do ACBrNFe usando o conjunto de DLLs que ficam na pasta 

XMLSec\MinGW\32

É necessário ativar o suporte a MinGW no ACBr.inc 

  • Like 2
Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

Caros companheiros de fórum :

Hoje tomei conhecimento da Nota Técnica 2016.002 Alteração Leiaute da NF-e , baixei e dei uma rápida analise.

Muitas dúvidas e é claro que será necessário muito esforço do grupo do ACBr para atender.

Pretendo na próxima reunião da empresa que trabalho propor a eles retornar o pagamento do SAC como forma de ajuda e de reconhecimento ao esforço do team ACBr.

Gostaria de fazer um apelo a todos os demais que ajudássemos também desta forma, pois vai tomar tempo fazer muitas dessas mudanças.

Abraço a todos.

  • Like 14
Link to comment
Share on other sites

Hoje recebi um e-mail, com alterações da DANFE para a versão 4.1

05/12/2016 - Atenção: Publicado o Manual de Especificações Técnicas do DANFE NFC-e e QR Code - Versão 4.1, contendo as seguintes alterações:

- Alteração da data de vigência para 03/04/2017; 
- Alteração da largura mínima do papel na impressão do DANFE NFC-e, visando atender demanda de desenvolvedores que pretendem utilizar equipamento Point of Sale (POS); 
- Alteração de imagens do modelo DANFE NFC-e com emissão em contingência.

Manual Versão 4.1 – Dezembro de 2016

Só não ficou claro se a versão 4.0 continua sendo obrigatória para Janeiro, ou a 4.1 substitui completamente com a nova data de vigência para 03/04.

Alguém já pesquisou sobre o assunto?

 

Link to comment
Share on other sites

  • Moderadores
59 minutos atrás, cesarliws disse:

Hoje recebi um e-mail, com alterações da DANFE para a versão 4.1

05/12/2016 - Atenção: Publicado o Manual de Especificações Técnicas do DANFE NFC-e e QR Code - Versão 4.1, contendo as seguintes alterações:

- Alteração da data de vigência para 03/04/2017; 
- Alteração da largura mínima do papel na impressão do DANFE NFC-e, visando atender demanda de desenvolvedores que pretendem utilizar equipamento Point of Sale (POS); 
- Alteração de imagens do modelo DANFE NFC-e com emissão em contingência.

Manual Versão 4.1 – Dezembro de 2016

Só não ficou claro se a versão 4.0 continua sendo obrigatória para Janeiro, ou a 4.1 substitui completamente com a nova data de vigência para 03/04.

Alguém já pesquisou sobre o assunto?

 

Isso eh outra coisa....

Att

Ricardo

Link to comment
Share on other sites

Você está ciente que o programa da SEFAZ vai parar de se atualizar a partir de Janeiro agora ne?
Portanto acredito que nem existirá layout oficial do TXT para ser usado para importação.

Se você utiliza essa ferramenta, aconselho olhar a importação por INI do proprio Acbr, que é bem facil de se lidar

  • Like 1
Link to comment
Share on other sites

9 minutos atrás, sossystem disse:

Você está ciente que o programa da SEFAZ vai parar de se atualizar a partir de Janeiro agora ne?
Portanto acredito que nem existirá layout oficial do TXT para ser usado para importação.

Se você utiliza essa ferramenta, aconselho olhar a importação por INI do proprio Acbr, que é bem facil de se lidar

É por este motivo mesmo que comentei, vou dar uma olhada na importação por ini. Obrigado.

Link to comment
Share on other sites

Boa tarde, 

Ontem dia 06/12 saiu a Versão 4.1 com duas alterações

 

- Alteração da largura mínima de 58mm para  56mm do papel na impressão do DANFE NFCe, visando atender demanda de desenvolvedores que pretendem utilizar equipamento Point of Sale (POS);

- Alteração de imagens do modelo DANFE NFC-e com emissão em contingência.

 

Referente a alteração 2,  verifiquei que vai ter que ser impresso a mensagem de nota em contingência no cabeçalho e na parte mais no rodapé,  gostaria de verificar se vai ser feito esta alteração já que a mesma entra em vigor a partir de  03/04/2017; 

 

Em anexo segue o documento referente aos dois ajustes.

 

Manual de Especificacoes Tecnicas Versao 4.1.pdf

  • Like 1
Link to comment
Share on other sites

  • Moderadores
7 horas atrás, DIOGOWAR disse:

Boa tarde, 

Ontem dia 06/12 saiu a Versão 4.1 com duas alterações

 

- Alteração da largura mínima de 58mm para  56mm do papel na impressão do DANFE NFCe, visando atender demanda de desenvolvedores que pretendem utilizar equipamento Point of Sale (POS);

- Alteração de imagens do modelo DANFE NFC-e com emissão em contingência.

 

Referente a alteração 2,  verifiquei que vai ter que ser impresso a mensagem de nota em contingência no cabeçalho e na parte mais no rodapé,  gostaria de verificar se vai ser feito esta alteração já que a mesma entra em vigor a partir de  03/04/2017; 

 

Em anexo segue o documento referente aos dois ajustes.

 

Manual de Especificacoes Tecnicas Versao 4.1.pdf

Este tópico é para tratar sobre a versão 4.00 do XML e não do DANFe.

djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.tefhouse.com.br | www.lambretinha.com.br
Link to comment
Share on other sites

Em 02/12/2016 at 08:04, Daniel Simoes disse:

Fiz alguns testes com o OpenSSL, usando TLS 1.2... é necessário usar a versão 1.0.1 ou superior...

Notei porém, problemas na libXMLSec, que também usa o OpenSSL para assinar o XML...

Consegui rodar todas as funcionalidades do ACBrNFe usando o conjunto de DLLs que ficam na pasta 

XMLSec\MinGW\32

É necessário ativar o suporte a MinGW no ACBr.inc 

e como eu ativo nesse campo

// Ative a diretiva abaixo, para usar a Libxml2, libxslt, libxmlsec compilada
// com MinGw ftp://ftp.zlatkovic.com/libxml/64bit/
{.$DEFINE USE_MINGW}
{$IfDef CPU64}
 {$DEFINE USE_MINGW}
{$EndIf}

 

Link to comment
Share on other sites

  • Este tópico foi criado há 1894 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.