Jump to content

Embarcadero Conference 2019

22/10 - Visite o Stand do ACBr
Saiba mais

Nova Loja Oficial
loja.projetoacbr.com.br
Ajude o projeto a crescer, com estilo

Comprar

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Recommended Posts

Estou com meus fontes atualizados e usando o arquivo DANFeNFCe.fr3 para gerar a DANFE, porém as margens passadas pelo sistema não estão sendo respeitadas pelo DANFE.

Está comendo o lado esquerdo da impressão, já tentei mudar as margens com vários valores mas a impressão sempre corta.

0da17949-4e28-4f44-ac4a-491e2d3cb023.jpg

Share this post


Link to post
Share on other sites

Bom dia.

Eu sei que o tópico é antigo, mas estou exatamente com o mesmo problema em uma Impressora Epson TM-T20 com Fast Report.

Já tentei ajustar as margens e a largura, mas não respeita.

Tentei com ACBrNFeDANFeESCPOS1, mas não imprimiu o QrCode e a impressão ficou bem desconfigurada.

 

Share this post


Link to post
Share on other sites
1 hora atrás, Joabe Geraldo disse:

Já tentei ajustar as margens e a largura, mas não respeita.

Realmente as configurações de margem do componente não são respeitadas, por hora é preciso alterar diretamente no .fr3.

  • Like 1

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites

Boa tarde.

Obrigado @everson.turossi e @BigWings pelas respostas.

Para não ter que criar uma outra cópia do arquivo .fr3 eu segui a dica do Everson.

Eu estava configurando errado a propriedade Modelo, estava preenchendo com 'ppEscEpsonP2'.

Depois dessa configuração a impressão saiu perfeita, do jeito que eu precisava.

Obrigado pela atenção.

 

  • Like 3

Share this post


Link to post
Share on other sites

boa tarde a todos
aproveitando que o tópico ainda está aberto, estou com problema nessa questão.
a única forma que saiu correta a impressão foi gerando o pdf
abrindo esse manualmente e imprimindo este pdf.
aqui uso o FastReport para imprimir.
O modo POS utilizando a impressora Epson não está saindo legal, dados do QRCode estão saindo em apenas 1 linha e não está respeitando os comandos para pular linha no final, antes da impressão.
Porém, esse problema começou a apresentar depois da atualização do ACBr que fiz em 30/08/2019 por conta de questões no CTe.

nfce.jpg

nfce1.jpg

nfce2.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...